Tag Info

New answers tagged

1

It works after you switch to pdfLaTeX. For this, it's required to remove fontspec from the loaded packages. With XeLaTeX I noticed the issue persisting.


2

I can think of two ways of accompishing this without external help. Both use the fact that tikz/pgf keeps track of the picture's bounds in a special node called current bounding box. Use tikz's baseline option, which must be given as an argument to tikzpicture environment. This can be achieved by changing forest's option begin draw (at any node, but ...


4

First, a remark: the error occurs even without sn edges style. I believe this is not a forest, but rather a pgf bug. I've tracked the problem down to \pgfintersectionofpaths of pgf's intersections library. The following code replicates the exact error without forest. \pgfintersectionofpaths{% \pgfpathmoveto{\pgfpoint{0.0pt}{-3.53297pt}} ...


3

Here is a way of using multicol with \parbox commands to format the glossary. The section=section package option is used to prevent a page break before the glossary by altering the sectioning level from the default chapter to section (which doesn't start a new page). \documentclass[openright,12pt,dutch]{report} ...


4

something like this? \documentclass[openright,12pt,dutch]{report} \usepackage{multicol} \usepackage[nomain,nonumberlist,nogroupskip,nostyles]{glossaries} % voor de lijst met glossen. \usepackage{glossary-super} \usepackage{leipzig} % voor glossen \makeglossaries \newglossarystyle{myglosses}{% \renewenvironment{theglossary}% ...


1

The package forest (which builds on the graphics package tikz-pgf) can be configured as shown below to give you a straight-spined tree with symmetric binary branching. I took the intermediate projection (bar-level) labels out of your MWE to show the straight line through empty nodes as you requested. \documentclass[10pt]{article} \usepackage{tikz} ...


3

I'm not sure why this might be the case, but this error seems to be related to the font being used. I can replicate your error when I compile your MWE using the following configurations: no font specification (Computer/Latin Modern), compiled with pdfLaTeX or XeLaTeX \usepackage{palatino}, compiled with pdfLaTeX or XeLaTeX \usepackage{libertine}, compiled ...


0

It seems like numoffset is the parameter we would want to manipulate in order to keep the number at (but not in) the right margin, but neither positive nor negative values for that make any difference in your MWE. If you set textoffset to -\textwidth, the number will be aligned with the left margin. Wider labels are handled correctly. However, this breaks ...


4

There's a parameter for this: extraglskip (see §11.3 of the docs): \documentclass{book} \usepackage{expex} \begin{document} Default spacing: \ex \begingl \gla Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nam consectetuer mollis dolor.// \glb Sed dolor. Praesent a lacus vitae turpis consequat semper. Duis sem velit,// \endgl\xe Desired ...


2

You can redefine \glt to capture content up to some ending delimiter. Below I've used \end from \end{exe}: \documentclass{article} \usepackage[english]{babel} \usepackage{gb4e} \usepackage{csquotes} \begin{document} \begin{exe} \ex \gll Etwas fremdsprachiger Text \\ some {foreign language-y} text \\ \glt \enquote{Free translation.} \end{exe} ...


3

You should avoid philex for the reasons egreg gives in his answer. The most commonly used packages for typesetting linguistic examples are gb4e, expex, and linguex (which is loaded by philex). See Alan Munn's excellent comparison of these packages for more details. Many of the features that philex adds to linguex (cross-referencing, repeating examples, ...


2

The lingmacros package is very old, and is really not very practical for numbering anything other than the most basic examples. For instance, it requires you to label subexamples manually, which really defeats the purpose of LaTeX and automatic numbering of things. See the following question for a summary of three widely used packages for linguistic ...


1

For completeness, the extremely powerful forest package should be included ;): \documentclass[standalone, border=5pt]{standalone} \usepackage{forest} \newcommand*\primary{\textsuperscript{0}} \begin{document} \begin{forest} for tree={ where n children=0{tier=terminal}{}, parent anchor=south, child anchor=north, } [S [NP [John ...


6

Gəʿəz can be beautifully typeset using XeLaTeX (xelatex) and fontspec (fontspec), which support all kinds of complex scripts and advanced font abilities. As far as I know, this should be possible in a very similar way with LuaLaTeX (lualatex) and fontspec, but I’m not familiar with Lua(La)TeX. Here is an example; it uses free (OFL) fonts — Abyssinica SIL ...


2

The reason is that the philex package is written in a terrible way and doesn't protect end-of-lines in definitions. The space you see is caused mainly by these unprotected spaces. See When is it harmful to add percent character at end of lines in a \newcommand, or similar for more information. They are too many unprotected end-of-lines for proposing a fix; ...


2

You have to use a font that supports the IPA characters, for instance CMU Serif: \documentclass[a4paper,12pt]{book} \usepackage{fontspec} \setmainfont{CMU Serif} \begin{document} \textipa{\|`\oe}, \textipa{\|+0} \end{document} You can also input the characters directly: \documentclass[a4paper,12pt]{book} \usepackage{fontspec} \setmainfont{CMU ...


2

As mentioned in the comments, you have two simple options that I present below. However, I'm not quite sure what you are after. \documentclass{minimal} \usepackage{forest} \forestset{ with translation/.style={ l sep=0,inner xsep=0, append translation/.expanded/.wrap pgfmath arg={\gettranslation{##1}}{content}, content/.expanded/.wrap ...


0

This is an answer to the edited question concerning the problem combining the code given in Sašo Živanović's answer with the use of a custom macro. The trick is to replace the use of \trace in the tree with a new style, trace which executes the macro and overrides the application of with translation to nodes with 0 children. \documentclass[tikz, ...


3

The problem, I think, is that you do not really want with translation to apply to the nodes which constitute the tabular. So the code you have for the translation stuff assumes that the nodes with 0 children are the right ones to apply with translation to but that won't work. You need instead to apply this to the nodes marked terminus which are the final ...



Top 50 recent answers are included