New answers tagged

1

Actually, this is the default setup that the text is wrapped and indented and not aligned under the bullet: \documentclass{article} \usepackage{blindtext} \begin{document} \begin{itemize} \item Foo \item \blindtext \end{itemize} \end{document}


2

Here is a solution, with the etoolbox package. You can reference the rows. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T2A]{fontenc} \usepackage[russian]{babel} % Включаем пакет для поддержки русского \usepackage{multirow,tabularx} \usepackage[a4paper,margin=1in,landscape]{geometry} \usepackage{etoolbox} \newcounter{rowcnt} ...


3

The tcolorbox package puts the tcolorbox environments in a paragraph, unless the option nobeforeafter is used. A better way to preserve the indents is to apply before={\hskip\dimexpr\leftmargin-\speechskip} and an empty after={} The remaining spacing is \itemsep and the natural \interlineskip. Compare the difference between \martax and \martay ...


3

I'd recommend the enumitem package, which is an improvement over the older enumerate, and is highly customizable and flexible: \documentclass{article} \usepackage[shortlabels]{enumitem} \setlist[enumerate,2]{label=\arabic*.} \begin{document} \begin{enumerate}[I] \item numeral I. This is ok. \begin{enumerate} \item This is now ``1.'' \end{enumerate} ...


6

\begin{enumerate}[I] \item numeral I. This is ok. \begin{enumerate}[1.] \item I expect this to be "1", but it is "a)" \end{enumerate} \end{enumerate}


1

Very basic, not much can be done here. Otherwise customize the itemize list with enumitem package to provide other typesetting facilities. \documentclass{article} \begin{document} \begin{description} \item Foo We have something to say here \item Foobar We have to say something differently here \end{description} \end{document}


1

Something like this? \documentclass{article} \newcommand\mybullet{{\tiny\raise0.5ex\hbox{\textbullet}\ }} % custom-size "bullet" \begin{document} \noindent \begin{tabular}{@{\mybullet}ll} list-item & i want this\\ longgg-item & and this to be aligned\\ another-item & at the same level auto\\ \end{tabular} \bigskip\noindent ...


5

Just replace item \#1 with \quad. :-) \documentclass{article} \begin{document} \begin{enumerate} \item \quad \begin{enumerate} \item sub list 1 \item sub list 2 \item sub list 3 \end{enumerate} \end{enumerate} \end{document}


2

You only need to remove spaces before nested enumerate. \documentclass{article} \usepackage[a4paper,showframe]{geometry} \begin{document} \begin{enumerate} \item% \begin{enumerate} \item sub list 1 \item sub list 2 \item sub list 3 \end{enumerate} \end{enumerate} \end{document} Edit: Mico noted , that I misunderstand the question :-( ...


8

Try this: \begin{enumerate} \item \leavevmode \begin{enumerate} \item sub list 1 \item sub list 2 \item sub list 3 \end{enumerate} \end{enumerate} (see The TeXbook for the discussion of \leavevmode for switching from the 'vertical mode')


3

\documentclass{article} \usepackage[T1]{fontenc} \begin{document} \begin{tabular}{r|p{11cm}} \emph{Jun 2010 - Current} & Soccer Player at \textsc{University of ...}, City, Country \\ & \begin{itemize} \item An excellent forward and some more stuff \item bullet list item one \item bullet list item two \end{itemize} \end{tabular} ...


2

\Item is not the same as \item. Do not use uppercase in a command when it should be lowercase and the error will be removed. \documentclass[a4paper,10pt]{article} % Default font size and paper size \begin{document} \begin{itemize} \item this is not a test \end{itemize} \end{document}


3

Here are some more options, using either a tabularx or list (via enumitem) to make full use of the text block width. \documentclass{article} \usepackage{tabularx,array} \usepackage{enumitem} \begin{document} \noindent \begin{tabularx}{\textwidth}{@{}l<{:}@{\ }X@{}} item in list & item description \\ another item in list & ...


3

You could use a longtable environment. In the example below, I've chosen p for the second column to allow automatic line breaks. Set the width of the p column to suit your page layout (of which we know nothing so far). \documentclass{article} \usepackage{longtable} \begin{document} \begin{longtable}{ l p{3in} } % choose suitable width for "p" column item in ...


0

This is not necessarily better but I have used the following, due to Michel Bovani, for many years: \makeatletter \newcommand{\interitemtext}[1]{% \begin{list}{} {\itemindent=0mm\labelsep=0mm \labelwidth=0mm\leftmargin=0mm \addtolength{\leftmargin}{-\@totalleftmargin}} \item ...


1

Here's another enumitem approach, but automatic switching to \ttfamily using before={\ttfamily}. \documentclass[11pt]{report} \usepackage[utf8]{inputenc} \usepackage{textcomp} \usepackage[T1]{fontenc} \usepackage{enumitem} \newlist{itemtt}{itemize}{1} \setlist[itemtt,1]{label={\textbullet},before={\ttfamily}} \begin{document} \begin{itemtt} \item This ...


1

something like this : \documentclass{article} \usepackage{enumitem} \begin{document} \ttfamily \begin{itemize}[label=\textbullet] \item item1 \item item2 \end{itemize} \end{document}


1

The best way to do this is using a description environment together with tweaks from the enumitem package. Unfortunately, there is an issue using nested lists with enumitem's style=nextline but Bernard has given a fix in Problem using enumitem's nextline style with nested lists. Another benefit of using enumitem is that you can control the formatting of the ...


0

the bad spacing in your example is due to the spurious space you've added from the end of line characters, This just adds \par before \vspace so it is used in vertical mode, and % to avoid adding white space \documentclass{article} \newlength{\itemspace} \let\olditem\item \newenvironment{myitemize}{% \setlength{\itemspace}{0in}% \begin{itemize}% ...


3

The rule won't work as it occupies more space than you want. If you don't want to use Davids solution you could change the baseline of the tikzpicture with the baseline-key: \documentclass[10pt]{article} \usepackage[inner=1.1in,outer=.7in,top=.9in,bottom=1in,paperwidth=8.5in,paperheight=11in,twoside]{geometry} \usepackage{amsmath} \usepackage{amsthm} ...


2

rather than make the grey box have zero space let it be natural size then the list automatically adjusts: \documentclass[10pt]{article} \usepackage[inner=1.1in,outer=.7in,top=.9in,bottom=1in,paperwidth=8.5in,paperheight=11in,twoside]{geometry} \usepackage{amsmath} \usepackage{amsthm} \usepackage{amssymb} \usepackage{multicol} \usepackage{enumitem} ...


1

Since I hadn't really been satisfied with any Plain TeX macros I found, and the vintage 1991 macros were either taken down or moved (link rot), I eventually wrote my own, which follow. These are not for LaTeX. The result looks like this: At the end of the macros there is an example outline. % % Plain TeX macros to create simple outlines, texoutlines.tex ...


5

The \item from the dramatist package confuses the tcolorbox settings as well as the following enumerate environment. A \leavevmode just before \begin{tcolorbox}...\end{tcolorbox} cures this. I strongly suggest to use enumitem package to adjust the spacings of the enumerate and as well as using a special \newtcolorbox definition which is easier to maintain ...


1

This is a generic problem with theorem environment (the one as redefined by amsthm) being used as the first thing following an \item. (there is an hidden \item from the adjustwidth environment). This goes a bit deep into LaTeX's management of lists. Rather than patching theorem, I propose here a hack on adjustwidth, which may be enough for your document, ...


1

I can propose not using adjustwidth, but a small modification of http://tex.stackexchange.com/a/67251/4427 The trick with \normalparindent is necessary in order to avoid timing problem (in a \list the \parindent parameter is set to zero). \documentclass{book} \usepackage{lipsum}% just to generate text for the example \usepackage{amsmath, ...


2

You could use some tricks from Macro to capture until end-of-line as argument to capture each \item and process it. Below I've provided \boxitem and \varboxitem that would process each \item as either a boxed \parbox or varwidth box (of appropriate maximum width): \documentclass{article} \usepackage{xparse,environ,varwidth} \usepackage[nopar]{lipsum} ...


2

If the multicols environment is no real demand, the tasks environment provides left to right alignment of the individual items. \documentclass{article} \usepackage{tasks} \begin{document} \begin{tasks}(3) \task A \task B \task C \task D \task E \task F \end{tasks} \end{document}


2

This is easy to do with the enumitem package: \documentclass[x11names]{article} \usepackage[utf8]{inputenc} \usepackage{graphicx, xcolor} \usepackage{enumitem} \setlist[itemize, 1]{label =\raisebox{-0.3\height}{\scalebox{2}{\color{Red3}\textbullet}}} \begin{document} Some text some text some text some text some text some text some text some text some text ...


2

In my point of view the spacings between the nested levels are quite good and there's no need to change the separations, but the space above (and below!) an item list is controlled by topsep, which can be set with topsep=... in the optional argument to enumerate If this length should be valid for all 2nd level lists, use \setlist[enumerate,2]{topsep=...} ...


0

@HarishKumar suggested the easiest way to fix the problem. It approximates what \nonzeroparskip does (which is slightly more flexible). However, if you want to avoid using enumitem, then you could do this: \documentclass{memoir} \makeatletter % memoir.cls has these two commands: % \newcommand*{\abnormalparskip}[1]{% % ...



Top 50 recent answers are included