Tag Info

New answers tagged

3

xunicode sets up for these commands also some OT1 defaults, but the main point are accents commands. E.g. \DeclareEncodedCompositeCharacter{\UTFencname}{\M}{0322}{0322} % (Combining retroflex hook below) You can naturally redefine the command if you don't use it, but there is a tradition to use "one-char-commands" for accent commands and so I would never ...


3

A simple example follows. For details, see documents of luatex-ja package. \documentclass{ltjsarticle} \usepackage{luatexja-fontspec} \setmainfont{TeXGyrePagella-Regular} \setmainjfont{IPAexMincho} \begin{document} This is a test. 漢字のテスト。 This is a test. \end{document}


3

Make sure /usr/texbin is included in your PATH environment variable.


0

The checkbox (Use a ‘build’ subdirectory for output files) in Texmaker adds the '–output-directory=build# parameter to the PdfLaTeX command. As you want to use the same for LuaLaTeX you could try to add '-output-directory=build' manually to the LuaLaTeX command.


2

The problem with oversized fonts in adobe reader comes from a bug with XeLaTex when using fonts in OTF format that have a particular resolution (see http://typophile.com/node/46451). What I do to circumvent this issue is to work locally with the .ttf version of FontAwesome. Added benefits to this is to make the new fonts available to you, it's easier to ...


0

This is a solution for the first issue (taken from here): Download the latest version of fontawesome from their site: http://fortawesome.github.io/Font-Awesome/ Install the .ttf version of the font (by simply double clicking the file on the most operating systems) Replace the line \newfontfamily{\FA}{FontAwesome} in your fontawesome.sty file with ...


3

Use the proper family number for j: \documentclass{article} \usepackage{amsmath} \usepackage{fontspec} \usepackage{unicode-math} \setmainfont{Minion Pro} \setmathfont{MnSymbol} \setmathfont[range=\mathup/{num,latin,Latin,greek,Greek}]{Minion Pro} % this is number 4 \setmathfont[range=\mathbfup/{num,latin,Latin,greek,Greek}]{MinionPro-Bold} ...


5

\documentclass{article} \usepackage{amsmath} \usepackage{fontspec} \usepackage{unicode-math} \AtBeginDocument{\Umathcode`j="0"0"6A } \begin{document} \begin{equation} j ~~\text{is}~~ \mathrm{j} \end{equation} \end{document} I don't have MinionPro. but here is your extended version using Arial (you want 6) \documentclass{article} ...


2

You missed the \usegdlibrary{trees}. For the inputenc error, if you only need English, you can remove lines 88 and 130 of the class file and make sure you change all non-English letters, like ö, in the class file also. For a more elegant solution to this, you can use the etoolbox package, which provides commands like \pretocmd with which you can ...


3

Yet again tcolorbox answer. First with a macro version: \documentclass{article} \usepackage[fitting]{tcolorbox} \usepackage{lipsum} \usepackage{lmodern} \newtcboxfit{\mybox}[3][]{colback=red!25!olive, colframe=red!75!olive,fonttitle=\bfseries, boxsep=1mm,left=0mm,right=0mm,top=0mm, bottom=0mm,center upper,valign=center, nobeforeafter,#1,width=#2,height=#3} ...


3

\documentclass{myClass} \renewcommand{\@Author}{Aldous Huxley} \def\preambleloaded{Precompiled preamble loaded.} would work if @ was a letter at that point (which it isn't here) or simpler just use the class defined \Author command. This will work: preamble.tex \documentclass{myClass} \Author{Aldous Huxley} \def\preambleloaded{Precompiled preamble ...


2

The problem is in how luatexja-fontspec defines \newjfontfamily when fontspec version 2.4 is available; it's actually the auxiliary package luatexja-fontspec-24.sty that has the problem: 208 \DeclareDocumentCommand \newjfontfamily { m O{} m O{} } { 209 \cs_set_eq:NN \fontspec_set_family:Nnn \ltj_fontspec_set_family:Nnn 210 \newfontfamily #1 [#2] {#3} ...


7

It looks like it was a bug in luatex. This seems to have been fixed in the latest version of luatex, version 0.80.0, as provided in texlive 2015-pretest. Using these versions, the output is as expected:


5

The definition of \ettl@ifd@f contains two instances of ^^a7 that is an invalid UTF-8 sequence. That character is made active in the documentation part, but it should be irrelevant. I guess the intention was to provide a “non standard” delimiter for the purpose of the macro, but of course it's a wrong decision. \def\ettl@ifd@f#1#2{% ...


1

Run with LuaLaTeX because of graphdrawing and change the \documentclass to some thing like article (as also suggested by fpast). The standalone was meant to be used for a single picture for example and not a running text. \documentclass{article} \usepackage{tikz} \usepackage{verbatim} \usetikzlibrary{graphdrawing} \usetikzlibrary{graphs} ...


5

For completeness, here's what I actually ended up with, using an argument to set an initial before the redefinition: \newenvironment{textblock}[1] {#1\def\par{\unskip\nobreak\quad{\color{red}\P}\nobreak\enspace}} {\endgraf} This allows me to use a lettrine at the beginning, which is somehow a required use case: ...


4

The bottom line at the top. Don't try this at home kids! Using MnSymbol with unicode-math will kill your time! The symbols provided by MnSymbol are not set up for use with unicode-math. Some are missing, some are not scalable in size. These need to be replaced by a different math font. For my opinion XITS Math does a good job. One just needs to find the ...


19

I'll first address the "how" and "what" components of your question, and defer the "why" component to the end of this answer. Both TeXLive and MikTeX include the texdoc utility. (I don't know if any other TeX distributions do as well.) The following is applicable for a MacTeX-based system; I would assume that other TeXLive systems are set up very similarly. ...


2

This is an update on egreg's answer and - beware - I did not test the code (I only somewhat proved it correct, to quote the author of TeX) \newenvironment{nopars} {\par\def\par{\if\@currenvir\@nopars\unskip\nobreak\quad\P\nobreak\enspace\else\endgraf\fi}} {\endgraf} This should cope at least with anything that introduces a nested environment ...


4

CW from the comments: luaotfload normalizes all names supplied by the font. Apart from lowercasing you can also leave out spaces if you wish. So, for XeLaTeX, spacing and casing are significant, while for LuaLaTeX, they are not. This is not engine-dependent, just how luaotfload (and, incidentally, ConTeXt) treat things. The rationale is simple: ...


14

Here's a nopars environment: \documentclass[a4paper,12pt]{memoir} \usepackage{polyglossia} \usepackage{fontspec} \usepackage{csquotes} \setmainlanguage{german} \newenvironment{nopars} {\par\def\par{\unskip\nobreak\quad\P\nobreak\enspace}} {\endgraf} \begin{document} \begin{nopars} Dies hier ist ein Blindtext zum Testen von Textausgaben. Wer diesen ...


1

In a current miktex and texlive 2014 one can get the search path for font feature files with kpsewhich --show-path="font feature files" and this gives pathes of the type <texmf-tree>/fonts/fea. I tested it with both systems and it worked fine after I updated the fndb/ls-R.


2

Instead of adding the -lualatex flag to each application of latexmk, you could place the following $pdflatex = 'lualatex -file-line-error %O %S'; $pdf_mode = 1; in an '.latexmkrc' file. This file should reside in your home folder, if you use lualatex in all your jobs, or in the folder(s) where your lualatex jobs are. More generally, you will find a ...


5

This is already fixed in luatex from current TeX Live trunk svn. The Debian binaries for unstable and testing (soon stable) are based on newer svn versions, and don't exhibit this behaviour. So you need to update to newer luatex, either by compiling it yourself, or waiting for TL2015.


1

As pointed out by Robert in the comments, the problem has nothing to do with Microtype. But by activating Microtype or any other font feature by \setmainfont[Microtype]{Latin Modern Roman} the default font settings get overwritten. Fonts which have a special subfont for smallcaps may not work afterwards. By reinitializing the smallcaps subfont it will ...


3

You need to recreate the lualatex format. Try first to do it with miktex-settings (admin). If this doesn't help you probably have a format in your user profile which takes precedence and which the admin tools can't overwrite. In this case you must recreate the format with the user miktex-settings.


2

The reason why the behavior differs when LuaTeX or XeTeX is used, is explained here. The XeTeX uses xdvipdfmx and this converter sets the UTF8 to UCS2 conversion automatically. On the other hand, when we are using direct pdfTeX primitives (like in LuaTeX) then the UTF8 to UCS2 conversion must be done at macro level. And the hyperref package does this when ...


5

unicode-math makes only sense if you also have a sensible "unicode math" font that you want to use as base math font. There is no "cm bright math" (sans serif math fonts are sparse ...). So it is better to use for the math setup the non-unicode way: \documentclass[a4paper,12pt]{article} \usepackage{cmbright} \usepackage{amsmath,amssymb} ...


3

The easiest way is to add an alias latex=lualatex to your .profile.


1

If you are using a Unix-like OS: Make a shell script which call lualatex and save it as latex. Add the directory to PATH as the first item. Example on bash (untested): mkdir ~/bin cd ~/bin cat << _EOT_ #!/usr/bin/env bash lualatex --output-format=dvi "$@" _EOT_ > latex chmod u+x latex cd ~ echo 'export PATH="~/bin:$PATH"' > .bash_profile ...


2

I modified the code from this answer quite substantially -- we don't have to mark every item in the environment specially, there's no need for a picture environment, we only use the temp box register. The new generativelayout.sty: we create new lengths for the root box that can be set dynamically (I'm simply using all the available space). The environment ...



Top 50 recent answers are included