Tag Info

New answers tagged

0

You can use the subcaption package; each column is a subfigure environment; inside each column the three images are placed inside a tabular: \documentclass{article} \usepackage{graphicx} \usepackage{subcaption} \begin{document} \begin{figure} \centering \begin{subfigure}[b]{0.12\linewidth} \caption{AC} \begin{tabular}{@{}c@{}} ...


3

I use Ben Jann's estout suite of commands: http://repec.org/bocode/e/estout/ . Very well documented, and very flexible. It has commands that makes LaTeX tables from Stata output (not only regression results, also matrices, summary stats etc ), but it allows you to append/prepend text to lines (eg \addlinespace or cmidrule from the booktabs package), which ...


0

the sloved in example insert > math > arry environment.


0

In lyx: 1- insert > math > arry environment. 2- in first row: add ( W ... = ) in the first square, then add ( min ) in the 2nd square. 3- in 2nd row: let first square empty. in the 2nd square add ( R ... ). Without any tex code. Regards


2

Insert > Float > Figure. Inside float figure: Insert > Box > Frameless. Inside Frameless: Add your first image, then Insert > Caption to add the caption. Inside float figure (but outside the first frameless box): Insert > Box > Frameless. Inside frameless: Add your second image, then Insert > Caption to add the caption. Right click on the frameless box, ...


1

Copy everything between \begin{equation} and \end{equation}, that is W(\mathbf{F},\lambda_{\chi})=\min_{\mathbf{R}\epsilon S^{2}} (I changed the \textbf to \mathbf) and paste it into a math-environment in LyX, just using Ctrl + V, not Paste Special. With a normal displayed equation, added with Ctrl + Shift + M, you will get Pasting everything ...


0

Click on the image with the Right Mouse > Settings.. Graphics tab > Set the image size in the PDF. LaTeX and LyX options tab > Set the image size in the screen. Suggestions: Usually is better set a small scale for the screen as 10%, so you can still focus in the surrounding text and recognize the image. If you have intuitive file names for the ...


2

When you Insert > File > External Material, you should choose the PDF pages template: Note how it mentions the option pages=- in order to include the entire document. That is, by default, this template (using the pdfpages package) only includes the first page. Therefore, under the LaTeX and LyX options tabs, enter This should include the entire PDF in ...


1

As far as I can understand, mainly you have a problem with floats placements. At this respect, some suggestions for a smooth layout transition: Inside the floats, always use table/image widths relatives to line width in %,never fixed sizes as 5 cm, nor sizes relatives to the text or column width. For example, for a figure use: This must produce in ...


1

As you discover ... Document > Settings... > Modules > Number Figures by Section > Delete This remove \numberwithin{figure}{section} in the LaTeX Preamble (as well as \usepackage{amsmath} if not needed by another command). Note that in LaTeX preamble you can use also the chngcntr package to control the numeration of floats. See Continuous v. ...


1

Path handling has changed due to the increased security framework in El Capitan. To fix it, go to the Paths item of Lyx → Preferences. Change the contents of the PATH prefix box from /usr/texbin to /Library/TeX/texbin. Then go to Tools → reconfigure and reset LyX.


0

I think I found the problem. First point the path of hunspell to your equivalent folder: C:\Program Files (x86)\LyX 2.1\Resources\dicts Then, it is an incorrect or corrupted en_US.aff/dic files. I downloaded another version from hunspell project: http://sourceforge.net/projects/hunspell/files/Spelling%20dictionaries/en_US/ and overwrite ir in the dicts ...


0

Thank you so much, LaRiFaRi! You saved me a lot of frustration. While your suggestion did not solve my problem right away, it put me on the right track. Browsing the package list in Synaptic, I noticed the package 'fonts-lyx' (true-type versions of some TeX fonts used by LyX). Installing that package solved the problem. It should be installed by default, if ...


0

In the preamble (Document -> Settings -> LaTeX Preamble), add: \usepackage{fullpage}


0

it appears that lyx ignores grouping braces when a file is reloaded. this is fatal when actual [brackets] occur in optional arguments. (it should also be considered a design flaw in lyx.) (la)tex provides the pair \lbrack and \rbrack to substitute for these. the original reason was to accommodate keyboards that don't have square brackets (sometimes the ...


2

There are not random results but inconsistent settings. Please use the option showframe in the package geometry and see the log file to understand what happen with your settings. Take into account that top margin in Lyx should be 15 mm plus headheight plus headsep and that header text should be enough small to fit in the headheight, otherwise LaTeX will ...


0

I solved this removing the new file I add in the LyX Layouts folder. So it looks like a bug. So I guess I must load "local layouts" every time.


1

This seems to be a bug in LyX. LyX is supposed to automatically load the right packages (unless you use ERT, then you're on your own). For some reason, when the document is set to Vietnamese, the package is not loaded automatically. To work around this bug, go to Document > Settings > LaTeX Preamble and put the following: \usepackage{textcomp}


0

As of LyX 2.1.0, put the cursor at the beginning of the frame (so your layout should say "Frame"), then go to Insert > Frame Options and put in 't'. For more information, please read the LyX Beamer guide under Help > Specific Manuals > Beamer Presentations.


3

Make a new float, write the caption, and then, right-click over the caption, and select Insert Short Title in the menu This make a opt box inside the caption where you can write the text shown in the list of figures. The results must be: With Edit > View source you can see that the generated LaTeX code will be: \caption[shown in list of ...


1

If you have to use the Word document, you could first create a PDF from Word and then include the PDF pages in your LyX document. By doing it through LyX, you avoid having to post-process as suggested by David Carlisle. Personally, I recreate in LyX, the content from Word, et al, if at all possible.


1

I had this problem earlier after updating my Acrobat programs. After a great deal of fruitless searching, I found reference to a solution buried on this page: http://www.lyx.org/trac/ticket/9512 Look right towards the end for comment 19 and there is a reference to replacing a file called pdfview.exe on your system with a new version from the link given ...


4

My advice would be to first check the cluster computers (e.g. the ones students have access to, such as in libraries). I know at some universities (e.g. Princeton) there is access in some clusters. If it is not there, you could ask the IT to install it. Remind them that it is free and open source so there are no license or cost issues. Here are some other ...


4

There is a mistake in your definition of the tabular environment. While the table contains only two columns, the number of columns specified in the argument of \begin{tabular} is larger: there is one column aligned to the left (l) and additional columns with a format specified by S[table_format=..]. You could try this slightly modified code instead: ...


1

Read the bottom of the site which you linked: LyX includes the template files svjour3.lyx for the sbvjour3 class, svmono_book-master.lyx for the svmono class and svmult_editor-master.lyx for the svmult class. (The files svmult_author.lyx and svmult_appendix.lyx are subdocuments of svmult_editor-master.lyx.) So start Lyx, menu file, new from ...


2

Thanks to scottkosty and Torbjørn T. for directions. Indeed, I recompiled Lyx changing source file /src/insets/Inset.h from static int const TOC_ENTRY_LENGTH = 40; to static int const TOC_ENTRY_LENGTH = 400; On Lyx 2.1.4 it is on line 77 of aforementioned file.


2

This is the intended behaviour, as far as I can tell from the comments to http://www.lyx.org/trac/ticket/9572. As such your only option would be to add a feature request in the bug tracker to disable the truncating.


1

As a extensive LaTeX user, who handles most of the texts under version control, I have found that it is useful to structure my writing so that editing is mostly shuffling lines around. Text editors have special commands for this, and it makes e.g. differences between versions (as given by the version control system) really show differences, not artifacts due ...


1

Thanks Scott! Your answer about changing the Hunspell path in Tools > Preferences > Paths worked for me. I pointed the path to "C:\Program Files (x86)\MiKTeX 2.9\hunspell\dicts" Lastly, had to restart Lyx and the spell checking started working. I tried pointing it to the dict files in the Lyx resources directory ("C:\Program Files (x86)\LyX ...


0

The UK solution works, but if you want any other language like US English, this is the way to fix it: First, find the hunspell directory with all the dictionary (dic and aff) files in it. For me, it was "C:\Program Files (x86)\MiKTeX 2.9\hunspell\dicts" Next, point Tools > Preferences > Paths > Hunspell Dictionaries text box to this directory. Lastly, ...


0

I was having the same problem, and I found a ridiculously easy fix. Are you starting a new paragraph before you insert your figure float? I mean, are you pressing ENTER and then inserting the float? I was doing that, until I tried just inserting the float at the end of the paragraph, without pressing ENTER, and voila! Worked like magic. Seems stupid, but ...


3

Add the line \usepackage{stackrel} to the top of your preamble in Document > Settings > LaTeX Preamble. Alternatively, instead of using stackrel you might consider the following: create the sum sign. Then, in LyX press _ to put it in subscript. Put i=1 in the subscript. Then press space (this gets you out of the subscript). Then press ^ (this puts you in ...


2

inset-modify should be used just in front of the inset. Thus, the command should be: Item "Insert Minipage" "command-sequence box-insert Frameless; char-backward; inset-modify width \"100line%\"" How did I know that inset-modify should be used in front of the inset rather than inside it (which I agree is more intuitive)? Well, if you use the GUI and ...


1

The easiest way I'd think of doing this is with @{}. Using @{} you can make columns use zero, custom or even negative space (i.e., columns overlap). On purpose I modified your table to contain huge space between some columns, zero space between others, and negative space (making columns overlap). Should you choose this solution, I am sure you will ...


4

The amount of intercolumn whitespace is set by the parameter \tabcolsep. Its default value in the mwbk document class is 6pt. You may find that setting its value to 3pt generates a table that's more to your taste. \documentclass[oneside,english]{mwbk} \usepackage{mathpazo} \usepackage{eulervm} \renewcommand{\familydefault}{\rmdefault} ...


2

I had a similar problem which I managed to fix by going into Document -> Settings -> Language and then changing the default, which was English, to English (UK).


0

I would advice to install the free reader SumatraPDF, which is the best choice for TeX files: it doesn't lock the .pdf files when you recompile, allows for direct and inverse search (don't know if this is important for LyX, but in a traditional TeX editor, it lets you go back and forth between a point in the .pdf and the corresponding line of code), is very ...


1

Your question is very general, so it is impossible to give specific answer. I summarize advice given by Torbjorn, and add tow examples for figures: The code for above picture: \documentclass{article} \usepackage{tabularx}% for tables \usepackage{ragged2e}% for smart right adjusting text in table \usepackage{graphicx}% for figures ...


0

Ok so thanks to Adam's help, I was able to see there actually is a workaround for this. However, it involves a fair bit of tweaking in order to make the chunks appear the same way as my other chunks do. So for now, my solution was to set tidy=FALSE and eval=FALSE in the chunk options, and put this in the chunk: boxplot(fumeurs$imc, horizontal=TRUE, ...


0

you can do it by: - from "insert">math>matrix... - in matrix window, let rows=1 and columns=5 - write your equestion formula in first cell (num1). - write your text in last cell (num5).


0

I managed to do it with the following and then use \thispagestyle{plain} on the Section pages to retain page numbers but remove headers: \renewcommand{\sectionmark}[1]{\markright{#1}{}} \renewcommand{\headrulewidth}{0pt} \renewcommand{\footrulewidth}{0pt} \fancyhf{} \renewcommand{\sectionmark}[1]{\markboth{\chaptername \ \thesection. #1}{}} ...


1

Write "equation 1". Click Ctrl+m then write your equation. Put the cursor between the text and the equation. From the main menu, "insert" then "horizontal fill".


0

It looks like in newer version of LyX one can simply change the command under Tools / Preferences / File handling / Converters / LyX Preview -> PNG to: python -tt $$s/scripts/lyxpreview2bitmap.py --png --fg="ccffff" Where in this example #ccffff was chosen as the foreground color.


1

I managed to overcome this problem by setting foxit reader as a default program for .pdf files. For some reason, win10 by itself had set internet explorer edge as the default program for .pdf files. In order to do so, do the followings: (This procedure works on win10. I assume that these steps are similar also for win7 and win8) control panel --> ...


1

Assuming that the truetype and opentype versions of the Crimson font are similar, the following should work: \documentclass{article} \usepackage{fontspec} \setmainfont{Crimson Roman}[Ligatures=TeX] \begin{document} Some text. \end{document} It should work if you have the truetype but, since I've got the opentype version, that's the one I actually ...


0

I was able to find a solution to this problem. Copy your dic and aff files from where they are now (C:\Program Files (x86)\LyX 2.1\Resources\dicts, usually), to a new folder, C:\dicts (or similar), and then change the path in lyx accordingly, and reconfigure lyx. I don't know exactly why this works though.


1

There are two choices: 1) install esint.sty (precise method depends on which LaTeX distro one uses); or 2) in LyX go to Document -> Settings... -> Math Options and uncheck "Use esint package automatically". This option will only work if you are not using any of the 'advanced' integral signs that esint provides (double integrals, path integrals, etc.), but ...


1

The Solution I kept digging around searching both XeLaTeX support files and found I completely misunderstood the purpose of the "crop" package. The "crop" package is designed to place various sundry post-production marks on paper that is larger in size than the actual page of content. My misunderstanding was that in either the geometry package or in LyX's ...



Top 50 recent answers are included