Tag Info

Hot answers tagged

4

You want the top and bottom marginnotes handled automatically yes? Assuming so I would replace the definition of your example environment with \usepackage{xparse} \NewDocumentEnvironment{example}{oo} {\begin{eoexample}\begin{exa}% \IfNoValueF{#1}{\marginnote{\flushleft{\color{framerule}{#1}}}[-7.5mm]}}% ...


4

You want leftmargin=*. I have also fixed some other glitches, mainly the proper usage of \SI for units, but also ties after one letter prepositions. \documentclass{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[czech]{babel} \usepackage{enumitem} \usepackage{siunitx} \addto\extrasczech{\shorthandoff{-}} \begin{document} ...


4

Turns out, there was a little bug hidden in eso-pic. Using the updated version that can be found on CTAN (since 2015/04/21) resolves the issue. \listfiles \documentclass{article} \usepackage[a4paper]{geometry} \geometry{bindingoffset=5cm} \usepackage{lipsum} \usepackage{eso-pic}[2015/04/20] \usepackage{showframe} \begin{document} \lipsum[1-30] ...


4

The culprit is \usepackage{ulem} that changes \em (and \emph) to mean underline rather than italicize. Underlining is something that should never appear in a printed text; the package ulem is very primitive in this respect and its underlining feature prohibits line breaks. However, nobody should ever use it for any purpose. So, remove \usepackage{ulem} or, ...


4

Yes, it is possible to have tufte-like citations in a general documentclass. What you need is (1) a citation style that uses footnotes, and (2) a mechanism that places footnotes in the margin. Amongst others you can use biblatex or bibtex for (1) and snotez, sidenotes, as well as built in commands in memoir and KOMA-script. I will provide some ...


4

The 'offending' code is a \llap in the \@makechapterhead macro, within the \if@thesisfancy branch, causing the left indentation into the margin. This can be removed by applying a patch at the relevant place. Edit This does not work if the chapter title is longer than the textwidth (minus the width of the chapter number figure) (so far) ...


3

You need \newenvironment{aside}{% \noindent %% added \begin{minipage}[t]{0.25\textwidth}% \begin{flushright} }{% \end{flushright}% \end{minipage}% } \newenvironment{main}{% \noindent \begin{minipage}[t]{\dimexpr0.75\textwidth-1pt-2em\relax}% %% modified }{% \end{minipage}% } and \end{aside}% %% % here is badly needed % ...


3

You can adjust the separation between line numbers and text by \setlength\linenumbersep{-8mm} Adjust the value as suitable. \documentclass[12pt,oneside,article,letterpaper]{memoir} \usepackage[margin=1in]{geometry} \usepackage{lineno} \newenvironment{mylinenumbers}{% \setlength\linenumbersep{-8mm} %% here ...


2

Ok, i got it. I have to the define showframe within the geometry options instead of using the package... \documentclass{article} \usepackage[a4paper,showframe]{geometry} \geometry{bindingoffset=1cm} \usepackage{lipsum} \begin{document} \lipsum[1-10] \end{document}


2

The spacing before and after a longtable are configured by the registers \LTpre and \LTpost. Both are set to \bigskipamount by default. The following example sets \LTpre, the space before` to zero: \documentclass[12pt,a4paper]{scrartcl} \usepackage{longtable} \begin{document} \section*{Practical experiences} \setlength{\LTpre}{0pt} ...


2

The caption package -- at least if it's loaded with no other options than justification=centering (which is the default anyway) -- seems to be causing the penetration of the top margin by the first caption of the table* environment. A workable fix would appear to consist of loading the package with options skip=5pt and position=bottom as well (even though ...


2

This is just an add to christian Hupfer's answer, in case, there is long title of chapter (but i think it is bad idea: long text in uppercase) \documentclass[12pt,tocnosub,fancy,offcenter]{uiucecethesis09} \usepackage{geometry} \geometry{verbose,tmargin=1in,bmargin=1in,lmargin=1in,rmargin=1in} \usepackage{blindtext} \usepackage{xpatch} \makeatletter ...


2

I don't think this is the full solution, but it's too long for a comment (and I've not figured out what could go wrong in here) Looking into documenation of geometry: reset sets back the layout dimensions and switches to the settings before geometry is loaded. Options given in geometry.cfg are also cleared. Note that this cannot reset pass and mag ...


2

Yes, you can enlarge the page (goal) by a negative value: \documentclass{article} \usepackage[a6paper,margin=1in]{geometry}% Just for this example \usepackage{lipsum} \begin{document} \enlargethispage{-\baselineskip}% \lipsum[1-3] \end{document} It's clear that there's a missing line (\baselineskip) on the first page as a result of ...


1

You could also do something like: \documentclass[twoside,DIV=calc]{scrartcl} \usepackage[side,ragged]{footmisc} \usepackage[style=verbose-ibid, autocite=footnote, backend=biber]{biblatex} \setlength{\marginparsep}{0.5cm} % just to add some space to margin note \usepackage{marginfix} % to avoid problems at the end of the page with margin notes See ...


1

Some workaround as a combination of \marginote and \footnote: \footmarginnote[optional number]{some text}[optional margin text] will print the footnote number in the right margin and the corresponding 'footnote' without marker as a real footnote. If the optional argument is given, that number (no check so far!) is used instead of the current footnote ...


1

I think you want "paragraph-style footnotes." You can get these in any document class by loading the footmisc package with the para option. You can also use the memoir class and issue the command paragraphfootnotes. \documentclass{article} \usepackage[para]{footmisc} % OR: % \documentclass{memoir} % \paragraphfootnotes \begin{document} This is ...


1

i'm sure there's another question already that answers this, but i can't find it. if the idea is to get a small .pdf file to include somewhere else, there are two steps to follow: make sure the output doesn't have anything extraneous, like a page number. to do this, add \thispagestyle{empty} just after \begin{document}. when you have the minimal .pdf ...


1

Here are two solutions. The second sets a left margin for the lists that will not change from one list to another (this may be important if you have many lists close to each other): \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{lmodern} \usepackage[showframe]{geometry} \usepackage{enumitem} %Start a document ...


1

You have parindent+0.25\textwidth+1em+\space+1em+\space+0.75\textwidth=\textwidth+parndent+2em+2\space > textwidth Try redifine your environment like this Edit: thanks to Harish Kumar's answer i add \ignorespaces \newenvironment{aside}{\noindent \begin{minipage}[t]{0.25\textwidth} \begin{flushright} }{ \end{flushright} ...



Only top voted, non community-wiki answers of a minimum length are eligible