Tag Info

New answers tagged

4

Here is a solution \documentclass[twocolumn]{memoir} \usepackage{xpatch} \usepackage{graphicx} \makeatletter \xpatchcmd{\@outputdblcol}{\vrule\@width\columnseprule}{\rotatebox{90}{\parbox{\textheight}{\dotfill}}}{}{} \makeatother \usepackage{lipsum} \begin{document} \lipsum \end{document}


4

This is a preliminary version uing the multicol package as requested: \documentclass{memoir} \usepackage{multicol} \usepackage{etoolbox} \usepackage{tikz} \usetikzlibrary{tikzmark} \usepackage{lipsum} % \newcounter{mymulticol} \setlength\columnsep{20pt} % \makeatletter \def\LR@dotcolumn@boxes{% \process@cols\mult@gfirstbox{% ...


0

You haven't given an MWE for me to play with, but if you have a complex bibliography in which each can be more than one paragraph (e.g. I have images in bibliography) you can put each entry in a minipage a) Remove your previous hack b) Add this code to preamble \renewbibmacro{begentry}{\begin{minipage}[t]{1\linewidth}}% ...


7

One option using TikZ and the tikzpagenodes package (adjust the settings according to your needs). According to comments, the first page of each chapter should also have the new page style, so \aliaspagestyle{chapter}{solid} was used: The code: \documentclass{memoir} \usepackage[hmargin=3cm]{geometry} \usepackage{xcolor} \usepackage{lmodern} ...


2

use \titleformat{\chapter}[display]{\normalfont\bfseries}{\thechapter}{0pt}{\Large} ^^^^^^^^^^^^ or \titleformat{\chapter}[block]{\normalfont\bfseries}{\thechapter}{1em}{\Large} ^^^^^^^^ ^^^^^^^^^^^^ ^^^^ for " 1 title"


0

Here is a solution \renewcommand{\printchaptername}{} \renewcommand{\printchapternum}{} \renewcommand{\printchaptertitle}[1]{\chaptitlefont ##1}% code \documentclass{memoir}% \makechapterstyle{mychapterstyle}{% \renewcommand{\chapnamefont}{\LARGE\sffamily\bfseries}% \renewcommand{\chapnumfont}{\LARGE\sffamily\bfseries}% ...


0

It's best not to use \noindent to suppress indentation as it causes problems with white space and especially blank lines at the start. You can use \@afterheading which is the mechanism latex uses to suppress indentation after headings. \documentclass[a4paper]{memoir} \setstocksize{11.0in}{8.5in} \settrimmedsize{11.0in}{8.5in}{*} \setlength{\trimtop}{0.0in} ...


2

I had two answers, the first being the same as John Kormylo's, which indents all paragraphs except the first (note the % in \mysidenote{%). The second answer for if you want a note consisting of a single paragraph to be indented is not to modify your \mysidenote macro but in any multiparagraph sidenote to put \noindent before the first paragraph of any ...


2

It's a simple fix, but I never thought of it myself until I saw it being used in a sty file. \documentclass[a4paper]{memoir} \setstocksize{11.0in}{8.5in} \settrimmedsize{11.0in}{8.5in}{*} \setlength{\trimtop}{0.0in} \setlength{\trimedge}{\stockwidth} \addtolength{\trimedge}{-\paperwidth} \settypeblocksize{9.0in}{4.87in}{*} \setlrmargins{*}{1.0in}{*} ...


0

Yet another option is to use titletoc: \documentclass{memoir} \usepackage{titletoc} \usepackage{lipsum} \newcommand\chaptertoc{ \startcontents[chapters] \printcontents[chapters]{}{1}{}} \begin{document} \tableofcontents \chapter{First chapter} \chaptertoc \section{Section A} \lipsum \section{Section B} \lipsum \chapter{Second chapter} \chaptertoc ...


5

If you want a local ToC at section level consider loading etoc and use \etocsettocdepth.toc{section} \localtableofcontents* MWE: \documentclass{memoir} \usepackage{etoc} \begin{document} \chapter{My Chapter} \etocsettocdepth.toc{section} \localtableofcontents* \section{A Section} Some text. \section{Another Section} Some more text. \end{document} ...


1

This is only for non-hyperref usage. And I don't recommend it all. Temporarily redefine \addcontentsline with 3 arguments to catch them within a \begingroup...\endgroup pair and issue the \chapter then. \documentclass{memoir} \begin{document} \begingroup \renewcommand{\addcontentsline}[3]{}% Do nothing \chapter{My Chapter} \endgroup \tableofcontents* ...


1

This works just fine. Remember to be exact as to where the threeparttable goes. Also the placement of the threeparttable is what saves you here. \subbottom does not really like the table notes list afterwards. But wrapping it in threeparttable, this now becomes a box, as seen by \subbottom, and it is fine with that. \documentclass[a4paper]{memoir} ...


1

There is no reason at all to use \chapter* here, as it is basically what it is already doing. But before you mess with \afterloftitle it might be an idea to take a look at what that macro is actually doing. This works \documentclass{memoir} \usepackage{calc} % for calculating width of LoF headings \renewcommand\afterloftitle{\afterchaptertitle ...


3

As Mike mention, you are messing with the text width but there are many other parameters that control the layout. This works \settypeblocksize{23.45cm}{11.85cm}* \setlrmargins{*}{*}{0.75} \checkandfixthelayout Note that if you leave out the \setlrmargins then you get what you showed.


2

Try this (minus any typos): \documentclass{memoir} \begin{document} \appendix \nopartblankpage \appendixpage This is the appendix \end{document} In memoir the \nopartblankpage command inhibits a blank page after a part-like page and the command \partpageblank sets the normal behaviour of a blank page after a part-like page.


1

Unfortunately, your page design is too crowded, as the warning shows: Overfull \vbox (12.0pt too high) has occurred while \output is active [2] Class memoir Warning: The material used in the headers is too large (24.0pt) for the given head height (12.0pt), it is recommended to either increase the head height or redesign the header (in both cases you will ...


0

I think the real issue here is \setulmargins -- you're not using it to specify a defined top margin, which is what your question is asking for. From the memoir manual, the syntax is \setulmargins{⟨upper⟩}{⟨lower⟩}{⟨ratio⟩} -- where <upper> and <lower> are your desired margins. By calling \setulmargins{*}{*}{1.3} you're actually explicitly telling ...


3

This is what I would do. As Barbara mentioned it is the box that exists around the page number. In the example below, we simply redefine the macro that provides this box, such that the box is gone (as it makes no sense in this application) \documentclass[a4paper]{memoir} \renewcommand{\cftchapterfont}{\normalfont} \renewcommand{\cftsectionfont}{\itshape} ...


1

the spacing has nothing to do with the number of entries in the toc, but in the number of digits in the page number. in most document classes, there is a box of fixed width assigned for the page number. it looks like you are using a class designed for a article of fewer than 100 pages in length, because as soon as the page number exceeds two digits, it ...


1

I found a solution by using the para* option of manyfoot to get rid of the initial indentation and then redefining \footnoteB. \documentclass{memoir} \setlength{\footmarkwidth}{\leftmargin} \setlength{\footmarksep}{0em} \footmarkstyle{#1\hfill} \usepackage[perpage,ruled,para*]{manyfoot} \DeclareNewFootnote{A}[alph] \DeclareNewFootnote[para]{B} ...


4

This answer doesn't include the float or ltablex packages, since they don't appear to affect things one way or the other. If you want a small caps heading above the LoF, just adjust the \afterloftitle and \widthof commands accordingly. \documentclass{memoir} \usepackage{calc} % for calculating width of LoF headings ...


3

This is caused by the \EmulatePackage feature of the memoir class. It emulates the setspace package and seems to disable some stuff thereby. This feature can be switched off using \DisemulatePackage{setspace}. The reason, why it works with book class is that screenplay-pkg loads setspace already. \documentclass{memoir} %\documentclass{book} ...


3

I would also suggest to use caption.sty. I suggest you put your caption above your longtable and use the facilities provided by caption.sty to customize it. This means you can use \caption and not \captionof. I would also drop multirow and use makecell (see below): \documentclass{memoir} \usepackage{longtable, booktabs, multirow, caption, lmodern, ...


3

You could just create the caption after setting the table: \documentclass{memoir} \usepackage{longtable, booktabs, multirow, caption} \usepackage[left=1cm,right=1cm]{geometry} \begin{document} \begingroup \tiny \renewcommand{\arraystretch}{0.8} \setlength{\tabcolsep}{3pt} \begin{longtable}[c]{r*{13}{c}} \toprule \multirow{2}{*}{\#} & \# ...


2

For question (1) just place \label inside \subfigcaption{...}. This is due to how \subfigcaption is made. The material for \label is made inside a group and thus not available in \subfigcaption{}\label{} As for (2), I don't think it is possible to easily be changed. Especially if we want (2) in text, and 1a at not 1(a). The code is hardwired into the ...


2

It's similar, but you need to let memoir know that you are going to have a subfloat, thus \subcaption and not \caption has to be used; this can be done using the optional argument for \newfixedcaption: \newfixedcaption[\subcaption]{\subfigcaption}{figure} A complete example: \documentclass{memoir} \usepackage{graphicx} \usepackage{lipsum} ...


2

I don't have the precise font installed, but here's the basic idea: \documentclass{memoir} \usepackage{sqrcaps} \usepackage[T1]{fontenc} \makechapterstyle{section}{% \renewcommand{\printchaptername}{} \renewcommand{\chapternamenum}{} \renewcommand{\chapnumfont}{\normalfont\Huge\sqrcfamily} \renewcommand{\chaptitlefont}{\normalfont\Huge\sqrcfamily} ...



Top 50 recent answers are included