Tag Info

Hot answers tagged

8

Here's one possibility admitting page breaks using tcolorbox: \documentclass{article} \usepackage[skins,many]{tcolorbox} \usepackage{lipsum} \definecolor{myblue}{RGB}{32,92,195} \newtcolorbox{mybox}[1]{ freelance, breakable, title=#1, left=0pt, right=0pt, width=.9\textwidth, enlarge left by=.1\textwidth, coltitle=black, frame ...


3

A solution with a tabular: %\PassOptionsToPackage{table}{xcolor}%% maybe needed if you have a special class \documentclass{article} \usepackage[table]{xcolor}%%% Delete it if your special class alread loads it \usepackage{tabularx,booktabs} \usepackage{blindtext} \definecolor{myblue}{RGB}{32,92,195} \newenvironment{mybox}[1] ...


3

The workaround is simple: boxit.mx(\btex {\begin{minipage}[t]{1em}M U X\end{minipage}} etex); The documentation tells that the braces around environments is necessary when mpost is used as the argument to a command, which is always the case with beamer.


3

The listings way is to use aboveskip and belowskip which are initially set to \medskipamount: \begin{lstlisting}[aboveskip=-1.4\medskipamount] Code: \documentclass{article} \tracingonline1 \tracingoutput1 \tracingparagraphs1 \usepackage{lua-visual-debug} \usepackage{listings} \usepackage{unravel} \makeatletter % \def\rst{\gdef\everypar={\setbox \z@ ...


3

It has to do with a \par command that must be at the end of the paragraph so it's constructed. I will try to say a few things but I'm not the most versed one :D First (and logical option): \documentclass[a4paper,pagesize]{scrbook} \usepackage[ngerman]{babel} \begin{document} \begin{titlepage} \begin{minipage}[t]{\textwidth} Some text at the ...


2

Use a save box: \documentclass{article} \usepackage{subfig,alltt} \newsavebox{\allttbox} \begin{document} \begin{table} \begin{lrbox}{\allttbox} \begin{minipage}[t]{0.48\linewidth} \tiny \begin{alltt} aaa This is in alltt bbb \end{alltt} \end{minipage} \end{lrbox} \subfloat[Caption]{\usebox{\allttbox}} \end{table} \end{document} Alternatively, use ...


2

Maybe you are looking for something like that: Then you can name the parent node of the tree and position a matrix beside the tree using the matrix and the fit library. Code: \documentclass[margin=10pt]{standalone} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} %%%%Tikz%%%%%% \usepackage{tikz} \usetikzlibrary{ trees, matrix, fit } ...


2

There is an invisible char in your text. Place your cursor in front of \begin{minipage} and you will notice that you can do one backspace without any visible effect. That was the one... The problem does not appear without \usepackage[T1]{fontenc}. That's why we always need a complete minimal working example (just for the next time). Here is your approach ...


1

You could just add \hfil or \hfill (try what you like more) between your two figure. This will "push" the two images to the margins and put some blank space between them. Here is a version with minipage and one with subfigure from subcaption. If the \hfill is not possible for you, you should take a look on the command \subcaptionbox in the documentation ...


1

cfr's answer did it for me, although I used tables. Was stuck on this issue for quite some time, and the addition of \restylefloat*{table} solved the issue I was having with side-by-side tables (in a two-column environment) not rendering one of the captions. For brevity's sake, I've attached source code for tables below. \restylefloat*{table} \begin{table*} ...


1

If the second column should be vertically centered to the picture you can use two m columns \begin{tabular}{>{\centering}m{0.5\textwidth}|m{0.4\textwidth}} Code: \documentclass[10pt,mathserif,smaller,fleqn]{beamer} \usepackage{tikz} \usepackage{multicol} \usepackage[utf8]{inputenc} \usetheme{Antibes} \setbeamertemplate{navigation symbols}{} ...


1

Another alternative is use of package adjustbox with export option. Here valign=t,c,b can go with the minipage location specifiers t,c,b Code \documentclass[10pt,mathserif,smaller,fleqn]{beamer} \usepackage{tikz} \usepackage[export]{adjustbox} \usepackage{multicol} \usepackage[utf8]{inputenc} \usetheme{Antibes} \setbeamertemplate{navigation symbols}{} ...


1

Well, I got to a manual workaround, which is to use \vspace{-1.2\baselineskip} right after the second {minipage} starts; the output is then: ... which, I guess, is what the [t] + [t] would have been expected to do. I used the unravel package to step through the critical sections, and compare those logs in meld; the problem seems to reduce to \everypar ...


1

With the threeparttablex, you can have something that looks like what you want, if I understand well: you can have the caption under the figure, then the notes of the same width as the table. For that, one needs to use the measuredfigure environment. As there seems to be a bug with labels in the measuredfigure environment, I had to define a \fakecaption ...


1

When all else fails, you can always write your own caption. \documentclass{article} \usepackage[margin=1in]{geometry} %\usepackage{caption} \usepackage{graphicx} \usepackage{mwe} \usepackage{hyperref} \newif\iffigure \newif\iftable \newcommand{\widecaptionof}[2]% #1=figure/table, #2=text {\refstepcounter{#1}% \begingroup% trying not to load other packages ...


1

The problem is that you are telling LaTeX to fill in all the horizontal space to the right of your left boxes so there isn't room for anything else on that page. To avoid this, wrap the boxes in an outer minipage environment something like the following. I've also made your minimal example a bit more minimal by eliminating unneeded preamble. Note that you ...



Only top voted, non community-wiki answers of a minimum length are eligible