Tag Info

Hot answers tagged

5

Woah, the LaTeX kernel is still able after two decades to come up with surprises! What a nasty bug and in there since day -1. This is not a problem of eledmac it is a problem of the way LaTeX tries to keep at least 2 lines of text after a section heading. It does that by setting \clubpenalty to 10000 and then uses \everypar to restore the original setting ...


5

You can define a new environment mymulticols in this way \newenvironment{mymulticols}[1] {\ifdim\textwidth<\mylength\else\begin{multicols}{#1}\fi} {\ifdim\textwidth<\mylength\else\end{multicols}\fi} so that if \textwidth < \mylength, multicols is not used, otherwise it is. Set the length of \mylength to the needed value. In this example I've ...


3

I'm not sure where \topskip comes from, but the default is 12pt regardless of the font size. Values less than .6\baselineskip seem to have no effect. Larger values move the top higher. \documentclass[12pt]{article} \usepackage{multicol} \setlength{\columnseprule}{.4pt}% \newcommand{\m}{\topskip=.6\baselineskip \begin{multicols}{2} \noindent this is ...


3

Full automation is right now only possible with a code change. As a one-off it is easy: Before the environment set the counter unbalance to 2. This will enlarge the starting vertical size by 2 \baselineskips. The counter will be reset to zero after each environment. A more general solution that does it automatically could look like this: ...


2

The use case for which multicolhas been written is to mimic page creation as it normally happens execpt that instead of a single column several columns are produced. That means that on the top of each column \topskip is used to position the first line of the multicols environment. \topskipis a register that is normally not changed throughout the document ...


2

A rudimentary proposition, without much effort and smart stuff \documentclass{article} \usepackage{advdate} \usepackage{tcolorbox} \usepackage{pgffor} \usepackage{xparse} \NewDocumentCommand{\journal}{+m+m}{% \begin{tcolorbox}[title={Date: #1},colbacktitle=yellow,coltitle=black] Captain's log, stardate #1 \tcblower #2 \end{tcolorbox}% \clearpage } ...


2

multicol and longtable are not designed for such use and table environment don't allow page break. Here a solution with paracol package \documentclass[12pt,a4paper,final]{report} \usepackage[T1]{fontenc} \usepackage{lmodern} \usepackage{relsize} \usepackage{paracol,lipsum} \usepackage[frenchb]{babel} %\columnratio{.5} %\columnsep =10pt ...


2

Check this: Added | in the tabular specification as \begin{tabular}[ht]{|c|c|c|c|c|} %%instead of " and \multicolumn{2}{c|}{\textbf{Sub}} %%note the | after c giving \documentclass{article} %Used to create Macro 1 \usepackage{array} \usepackage{multirow} %Used for \textsubscript \usepackage{fixltx2e} %Macro ...


2

If you add \fbox{This is the top line of text and I want it to go on a bit.} at the start of the first column, you can see that the image is perfectly aligned: So some adjustments are needed to make things 'look right': \documentclass{article} \usepackage[export]{adjustbox} \usepackage{multicol} \usepackage{lipsum} \begin{document} \hrule ...


2

Please always post complete documents. The inter-item separation is a parameter of a list: \documentclass{article} \usepackage{enumitem,multicol,amsmath} \begin{document} \begin{multicols}{2}\large \begin{enumerate}[itemsep=9pt] \item $\dfrac{2}{8}=\dfrac{1}{4} $ \item $\dfrac{2}{6}=\dfrac{1}{3} $ \item $\dfrac{4}{6}=\dfrac{2}{3} $ \item ...


2

expex issues an \noindent at the end of \xe. Imho if would be better to use (like lists) \@doendpe. (There is no need to load xunicode in a current system, and xltxtra is often unnecessary too so I remove both). \documentclass{scrartcl} \usepackage{fontspec} \usepackage[english]{babel} \usepackage{multicol} \usepackage{expex} \makeatletter \def\xe{% ...


1

Maybe the enumitem package is an alternative, which allows for individual fine control of list parameters. If you use \itemsep=1in this does only hold within the inner enumerate environment, due to grouping (lengths/dimensions are group safe, i.e. changes within a group do not effect the value outside of the group), so for the outer enumerate, the \itemsep ...


1

Vertical space is removed at page/column breaks, so the \itemsep between items 2 and 3 disappears. What you want is to box the items so that they will occupy a prescribed height. \documentclass{article} \usepackage{multicol} \newenvironment{subquestions}[1][1in] {\begin{multicols}{2}\begin{enumerate}\setlength{\subqheight}{#1}} ...


1

The multirow-command takes three parameters usually (How many rows there should be spanned, the width of the content and whats to be printed). You must also remember to use the tabular-environment correctly. You forgot to add two & in the row containing the missing vertical bar. The bar is missing because \\ ends the table at that point in the column. ...


1

While your problem was fixed (\multirow requires 3 arguments), I would honestly change your table to improve its readability. These are the changes I'd do: Get rid of all the vertical rules and most of the horizontal ones, and switch to the booktabs package. Align the numerical values at the decimal point using the dcolumn package and setting a new column ...


1

you should read how multirow works \begin{table*} \centering \newcolumntype{C}{>{\centering\arraybackslash}X} \begin{tabularx}{\linewidth}{|l|C|C|C|C|C|C|} \hline \textbf{} & \multirow{2}{*}{\textbf{Value}} & \multirow{2}{*}{\textbf{Value}} & \textbf{Some Value} & \textbf{ome Value} & \multirow{2}{*}{\textbf{ome Value}} & ...


1

This seems to do what you want, without \multicol or \varwidth. \documentclass{article} \usepackage[paperwidth=10cm,paperheight=5cm,showframe]{geometry} \begin{document} \noindent LABORE ET DOLORE \vfill \noindent\begin{minipage}[b]{\linewidth} \raggedleft LOREM IPSUM LOREM IPSUM \end{minipage}\strut \noindent\begin{tabular}{@{}l@{}l@{}} ...



Only top voted, non community-wiki answers of a minimum length are eligible