Tag Info

New answers tagged

1

I modified abbrvnat.bst to issue \myand{} instead of and (changing the places where " and " appears). Then prepared this input file: \begin{filecontents*}{\jobname.bib} @book{RefWorks:1, author={John Johnson}, year={2015}, title={Book Name}, publisher={Publishing Company}, address={United States of America}, edition={1st}, ...


1

You can create a Makefile or a script to do this. The script can be called from the TexMaker or other editor. At Linux, I use a Makefile for the purpose. I just need to run make and everything is compiled! :) A Makefile or script is useful since you don't need to "stick" with an editor configuration. You can run it also from a terminal, allowing you to ...


0

Ok so it looks like all i had to do was to compile manually my main file with pdflatex, then bibtex once for each included part, then pdflatex twice on the main file... Is it possible to make it happen as a fast compilation with TexMaker?...


1

There is some problem with using achemso when you do not have any citations. If I run \begin{document} \bibliographystyle{achemso} \bibliography{library.bib} \end{document} I get an error. But running \begin{document} \bibliographystyle{plainnat} \bibliography{library.bib} \end{document} or \begin{document} \cite{somebody1990} ...


0

In my case it was sufficient to remove draft option from list of document class options. The following command in document preamble \documentclass[twoside,openright,titlepage,numbers=noenddot,headinclude, footinclude=true,cleardoublepage=empty,draft,abstractoff, BCOR=5mm,paper=a4,fontsize=11pt, ngerman,american,slovak% ...


1

The formatting of your @article-type entries is specified in a part following FUNCTION {article} which starts on line 482 for apalike.bst and line 1036 for (the current version of) science.bst. In order to remove the title field from article entries in apalike.bst (or for that matter any other *.bst-file), comment out line 488 by adding a %: % ...


-1

More suggestions for a workaround can be found here: http://www.latex-community.org/forum/viewtopic.php?f=31&t=2840


2

The apacite.sty package that's loaded by class wrongly defines \PrintBackRefs in case back references are not wanted. Indeed, it defines it to be the same as \@gobble, but the end of an entry in the generated .bbl file is like \APACjournalVolNumPages{Journal of Economic Psychology}{25}{5}{565--580}. \newblock \begin{APACrefDOI} ...


4

From the questions's MWE: \usepackage[colorlinks=true,linkcolor=blue]{hyperref}% Citation links are configured via option citecolor: citecolor=blue Or if all kind of links should be blue (since hyperref 2011-02-05 v6.82a): allcolors=blue


2

Your citations are in a c column and that won't spread itself over multiple lines, unlike a p column. To get a centered p type column, load the array package and add >{\centering\arraybackslash} before the p declaration. Alternatively, additionally load the ragged2e package and use its \Centering command instead of \centering, this allows better ...


1

The extra pair of curly braces around the contents of the author field tell bibtex that the piece has a single "corporate" author, rather than four distinct authors. Remove the curly braces, and replace the two "connective" commas with the keyword and. The author field should look like this: author = "Barnett, S. and Etchells, D. and Weidelich, Z. and ...


2

I added a *-variant that prints the citation anyway, and it doesn't count as the first (maybe you want it in the introduction or later in the document). \begin{filecontents*}{\jobname.bib} @Manual{vcd, title = "vcd: Visualizing Categorical Data", author = "David Meyer and Achim Zeileis and Kurt Hornik", year = "2015", note = ...


1

on the assumption that \nocite isn't really needed, this should work: \newcommand{\expkg|[1]{\textsf{#1}\ixp{#1}} \newcommand{\pkg}[1]{\textsf{#1}\ixp{#1} \citep{#1}\expkg{#1}} after all, a single \cite will put an entry in the \.aux file that tells bibtex to identify a matching entry in the .bib file and create an equivalent entry in the .bbl file -- ...


3

May be you need this: \def\pkg#1{\textsf{#1}\ixp{#1}~\citex{#1}} \def\citex#1{\expandafter\ifx\csname cit:#1\endcsname\relax \expandafter\gdef\csname cit:#1\endcsname{}% \citep{#1}% \else \nocite{#1}% \fi } The \citex macro tests if the parameter was used before, i.e. if the control sequence \cit:parameter is defined. If not, then ...


0

This is not a direct answer, but perhaps you would find it useful. Here is a package I wrote, but never published to serve a similar but not identical purpose. The purpose of this package is to make it easier to write articles on programming languages. To reference a language such as Java, you write \Java in your input. It would add the citation, but only if ...


0

The issue was related to extra.label, which was missing in the original bst-file. Running the makebst again and copying the code-snip from the new bst-file works for me now. Old code: FUNCTION {format.date} { month "month" bibinfo.check duplicate$ empty$ year "year" bibinfo.check duplicate$ empty$ { swap$ 'skip$ { "there's a month but ...


1

You have to use elsarticle-num-names: \begin{filecontents*}{\jobname.bib} @article{AAA, author = {A. Uthor}, title = {TTTitle}, year = {2017}, } \end{filecontents*} \documentclass[10pt, a4paper]{elsarticle} \usepackage[latin1]{inputenc} \usepackage{amsmath} \usepackage{amsfonts} \usepackage{amssymb} %\usepackage{natbib} \usepackage{graphicx} ...


1

This error is casued by the .bst file rather than by an entry in the .bib file. As a rule, you must use natbib-compatible bst files with natbib: abbrvnat rather than abbrv, unsrtnat rather than unsrt etc.


4

If you need to use all features of apacite, change \bibliographystyle{apalike} to \bibliographystyle{apacite}. One of the important features is the customization. In particular, the formatting of book titles in apacite is determined by the command \APACrefbtitle defined as: \newcommand{\APACrefbtitle}[2]{\Bem{#2}} Here \Bem is normally \emph. Now let ...


4

You have two errors in your hack. First, you leave urldate on stack after your if$ statement. This is how you get two dates. You need to use this instance with swap$ instead of putting the third instance of urldate on stack: FUNCTION {format.urldate} { urldate duplicate$ empty$ { pop$ "" } { "~(Accessed: " swap$ * ")" * } if$ } However, if ...


2

You have to use \LetLtxMacro: the documentation of the letltxmacro package tells why. See also When to use \LetLtxMacro? \documentclass{scrartcl} \pagestyle{empty} \usepackage{xparse} \usepackage[authoryear,round]{natbib} \usepackage{letltxmacro} \LetLtxMacro\oldcitep\citep \RenewDocumentCommand{\citep}{O{} O{} m}{\oldcitep{#3}} ...


1

elsarticle defines biboptions and passes everything to package natbib. You can pass all options you formerly used to natbib directly: \usepackage[sort&compress]{natbib}


0

Fixed it... Just had to delete all of the temporary files and recompile (thanks to References not updating from BibTex)



Top 50 recent answers are included