Tag Info

Hot answers tagged

11

LaTeX prevents a page break right after \section to avoid a single section title at the bottom of the previous page. Just add some dummy text until the section text is written, e.g.: \part{Title of Part I} \chapter{Title of chapter a} \section{section-1} TODO \section{section-2} TODO ...


6

At the end of a list (itemize and enumerate included), LaTeX issues a number of vertical adjustments that are not scrutinized by your \nopagebreak requirement. So, instead of patching \enditemize, include your The end as part of the list where you have more control over the page breaking restrictions: \documentclass{report} \usepackage{lipsum} ...


6

You can use \\* to prevent a page break \multicolumn{2}{c}{\cellcolor[gray]{0.75}2013}\\* If lines are involved you need to change the commands for the lines too: Prevent page break after \midrule in \longtable How to disable pagebreak on \hline in longtable?


5

here you can just prevent a full page of footnotes: \documentclass{article} \dimen\footins\dimexpr\textheight-\baselineskip\relax \begin{document} Before\footnote{Lorem ipsum dolor sit amet, consectetur adipiscing elit. In sit amet feugiat magna, vitae rutrum magna. Nam viverra lacus nec augue sodales, sed imperdiet quam egestas. Maecenas sed tellus in leo ...


4

You are using \begin{figure}[] \hspace*{1.5in} \makebox[\textwidth][c]{\includegraphics[width=1.2\textwidth]{1.png}} and the figure environment doesn't end there but only at the end of document i.e., \end{figure} comes only before \end{document}. The contents inside figure environment are put in a box and box can not be broken across pages. Remedy is to ...


4

You can use only one align environment that will break across pages with the \allowdisplaybreaks switch. Note that if you use empheq with option overload, you cannot break across pages anymore. To do so, you will have to use the AmSalign environment. I also replaced array with bmatrix: \documentclass[12pt]{article} \usepackage{amsmath} \begin{document} ...


4

you can use \dimen\footins=\dimexpr\textheight-2\baselineskip\relax% or <num>\baselineskip or \dimen\footins=10cm code complete \documentclass{article} \dimen\footins=\dimexpr\textheight-2\baselineskip\relax \begin{document} Before\footnote{Lorem ipsum dolor sit amet, consectetur adipiscing elit. In sit amet feugiat magna, vitae rutrum magna. ...


3

The images show the difference between \flushbottom and \raggedbottom, adding \raggedbottom to your preamble (which is the default for single side `article) will cause LaTeX to pad any short pages with stretchable space at the bottom of the page.


2

This is the default behaviour of the report class; the following minimal example should work on your LaTeX. \documentclass[a4paper,12pt,twoside]{report} \usepackage{lipsum} \begin{document} \chapter{Introduction} \lipsum[1] \chapter{Literature Review} \label{chap:litreview} \lipsum[1] \section{Concepts} \label{sect:concepts} \lipsum \section{Academic} ...


2

One possibility is to have two slides where there is no frametitle in the second one: \begin{frame} \frametitle{Lorem ipsun} \end{frame} \begin{frame} Lorem Ipsun. \end{frame} In this way, you kind of visually "break" one slide into many slides. Other ways which affects the visual appearance are make text smaller to put more text in the same space ...


2

This will never break a subsection, obviously you can customise the spacing and hide the markup in a \newenvironment definition. \section{zzzz} \noindent\begin{minipage}{\textwidth} \subsection{zz aa} zzzzzzzzz zzzz zzz zz \end{minipage} \bigskip \noindent\begin{minipage}{\textwidth} \subsection{zz aa} zzzzzzzzz zzzz zzz zz \end{minipage} ...


2

The \needspace commands are part of the problem but the real culprit is the \color-command which inserts a whatsit. Either add a \nopagebreak or use the solution from egreg here: http://tex.stackexchange.com/a/101643/2388 \documentclass{article} \usepackage{fontspec} \usepackage{lipsum} \usepackage{tikz} \usetikzlibrary{calc} \usepackage{anyfontsize} ...


2

The official line is you should always use latex commands like minipage not underlying TeX primitives like \vbox, but sometimes... \documentclass[a4paper,11pt,titlepage,headings=big, chapterprefix=true,headsepline,parskip=half]{scrreprt} \usepackage[activate={true,nocompatibility},final,tracking=true,kerning=true, spacing=true,]{microtype} ...


1

This is how to adjust things manually. You need to be able to identify the longest elements on the left-hand side (LHS) and right-hand side (RHS) of either set, and use that to prop out the shorter of the two: \documentclass{article} \usepackage{mathtools}% Loads amsmath \begin{document} \[ \phantom{P_{333}} \mathllap{P} = \mathrlap{ ...


1

The lines are to separate the headers of your pages and the text. You can disable them by setting its width to 0: \renewcommand{\headrulewidth}{0pt} It gets set by the fancyhdr package. They are by default disabled on "special" pages, like the first page of the TOC or of chapters, which use a different format. The empty pages are inserted because every ...


1

Another simple solution is turn 90° the content of a normal float (without [H]) using only normal (portrait) pages: \documentclass[12pt]{article} \usepackage{lipsum} \usepackage{graphicx} \begin{document} \lipsum[1-2] \begin{figure} \rotatebox{90}{ \begin{minipage}{\textheight} \includegraphics[width=\linewidth]{example-image-a} \caption{DVA part of the ...


1

Thanks to lockstep's editing of the tags, I found the answer myself. \documentclass{report} \usepackage[backend=bibtex,citestyle=verbose-ibid,bibstyle=numeric,sorting=nyt]{biblatex} \DeclareBibliographyCategory{websites} \DeclareBibliographyCategory{spoken} \DeclareBibliographyCategory{books} \AtEveryCitekey{ \ifentrytype{misc}{ ...


1

longtable breaks naturally at the end of the page, as shown here where I have doubled the length of the table, and reduced the length of the page, so it goes on to page 2. \documentclass[a4paper, 10pt]{scrartcl} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{lmodern} \usepackage[italian]{babel} ...


1

Here is a solution. I make \headline part of tabularx. There is no need to split tabular \documentclass[10pt]{article} \usepackage{ltablex} \usepackage[top=2.5cm, bottom=2.5cm, left=2.5cm, right=2.5cm]{geometry} \usepackage{bibentry} \usepackage{etoolbox} \usepackage{helvet} \usepackage{xcolor} \usepackage{graphicx} \usepackage{color} ...


1

Use \onecolumn right after \appendices; if needed, you can switch back using \twocolumn (each of those commands starts a new page): \documentclass{IEEEtran} \usepackage{lipsum} \usepackage[]{minted} \begin{document} \section{Introduction} \lipsum \section{Material} \lipsum \appendices \section{BaudRate} ...



Only top voted, non community-wiki answers of a minimum length are eligible