New answers tagged

3

A single table environment cannot be broken across pages. Here, I merely remove the table and tabular environments, and move the \caption inside the longtable, followed by a \\. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{longtable} \usepackage{tabularx} \usepackage{booktabs} \begin{document} \vspace*{8cm} \centering \vspace*{1cm} \...


1

Your approach is not what I’d recommend: if you want to customize the appearance of sectioning titles, use, for example, the titlesec package. However, even if you insist for a do-it-yourself solution, there’s no need to have recourse to the minipage environment: it suffices to insert penalty items at the right spots, which can be done by means of the \...


3

You try putting the items you do not want to be on separate pages inside minipage since minipage do not break across pages, all its content is forced to be on one page. \documentclass{article} \begin{document} Lots\\of\\text\\here\\to\\fill\\space\\so\\that\\the\\new\\section\\is\\right\\near\\the\\bottom.\\ Almost\\there.\\ I\\bet\\there's\\a\\better\\way\\...


1

One of the (IMO) best ways to fix something like this is to make the space above \part and \chapter entries flexible, that usually solves the problem. Otherwise use the \addtocontents{toc}{\protect\newpage} \part{title} Not sure what you mean by "but I would prefer a solution, that avoid such a page break in the header" \setlength{\cftbeforepartskip}{2....


0

Don't use the report class, but book. \documentclass[a4paper, twoside, 11pt]{book} \usepackage{emptypage} \pagestyle{plain} %irrelevant stuff \begin{document} \begin{titlepage} some nonsense \end{titlepage} \begin{titlepage} Abstract \end{titlepage} %Tried as above \tableofcontents Some more text \end{document}


1

the \thickhline command defined here does not allow page breaking, using \hline allows the table to break normally (I also removed the center which can not center a longtable and just adds spurious space) Note that \tiny{...} is a strange markup as \tiny doesn't take an argument, mostly it works here as the font change is restricted by the table cell, and ...


0

It seems as though the most complicated part of this problem is the case when a paragraph continues through a page break. Perhaps the easiest thing to do is to prevent paragraphs from doing so: \widowpenalties 1 10000 \raggedbottom


0

I have found a solution that works for me, although the factor that \linewidth needs to be multiplied by may need to be adjusted in different situations: Put \newenvironment{stanza} {\begin{minipage}{1.1\linewidth} \begin{verse}} {\end{verse} \end{minipage}} in the preamble, and use the stanza environment for the stanzas that are troublesome.


0

Combining the following three worked for me: 1) Insert -> Formatting -> New Page 2) Insert -> Formatting -> Ligature Break 3) Insert -> Formatting -> New Page


0

If you are using the natbib package, you may try the option sectionbib: \usepackage[sectionbib]{natbib}


0

The easiest way is to locally increase the interlinepenalty for your Bibliography by this commands: \makeatletter \interlinepenalty=10000 \bibliography{library} \bibliographystyle{style.bst} \makeatother


1

I prefer moving the introduction to a minipage: \begin{minipage}{\textwidth} And here, finally, is the list of mission-critical items: \begin{itemize} ... \end{itemize} \end{minipage} Note that this prevents page breaks inside the list too.


0

For the time being, I am going with the standard solution that prevents any code chunk from ever being broken. But to enable line breaks in the middle of paragraphs, I am sprinkling \stdbreak liberally throughout paragraphs, where \stdbreak is defined as follows: \newcommand\vfilbreak[2][200]{% \vskip 0pt plus #2 \penalty -#1 \vskip 0pt plus -#2 \relax} \...


1

Thinking on the way I have implemented \ledpb, I remember that I have inserted setting option. In your case, you must use \ledpbsetting{after}. Cf THIS MWE \documentclass{article} \usepackage{reledmac} \begin{document} \ledpbsetting{after} \beginnumbering \setstanzaindents{0,0,0} \stanza[\emph{A}] Twinkle, twinkle, little star, & how I wonder what ...


3

Insert the instruction \allowdisplaybreaks in the preamble, after loading the amsmath package. And, instead of using the \title and \maketitle machinery, just type \begin{center} \Huge <Title String> \end{center}.


1

As you are NOT in parallel typesetting, you can just use the standard \pagebreak. \documentclass{article} \usepackage{reledmac} \begin{document} \beginnumbering \setstanzaindents{0,0,0} \stanza[\emph{A}] Twinkle, twinkle, little star, & how I wonder what you are. \& \setstanzaindents{0,0,0} \stanza[\emph{B}] Up above the world so high, & ...



Top 50 recent answers are included