Tag Info

Hot answers tagged

6

The problem is not with all odd pages; the problem is with pages that internally have assigned the plain style (which, with the default settings, happen to be odd), such as the first page of each chapter. You can redefine plain to give you the desired formatting: \fancypagestyle{plain}{% \fancyhf{} \fancyfoot[C]{\circled{\thepage}} ...


4

In report the page style for \chapter is plain by default. To change this you either need to change the plain page style, which may well have undesired side effects for other formatting in your document, or to patch the \chapter command to use your own style: \usepackage{etoolbox} \patchcmd{\chapter}{plain}{ChapterStyle}{}{} If you had been using ...


3

memoir uses the chapter page style for the first page of every chapter. The chapter page style is considered a alias of the plain page style. In order to modify an alias page style, you first have to make a true copy of the page style: \copypagestyle{chapter}{plain} The above makes a true copy of the plain page style and calls it the chapter page style. ...


3

If the writing direction is always right-to-left when calling \pageref, this will do. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[LFE,LAE,OT1]{fontenc} \usepackage[english,arabic,farsi]{babel} \usepackage{xparse,etoolbox} \ExplSyntaxOn % the following is from the other answer, not really needed here ...


3

This is very much the same problem as in Why doesn't \pagestyle{empty} work on the first page of a chapter? The first page of every chapter is issued with the plain page style by default. You'll either have to redefine plain, or add some adjustments to the \chapter command to not issue plain. The minimal example below patches \chapter to insert a different ...


3

Just a wild guess, but you could use package unnumberedtotoc with option indentunnumbered found in http://tex.stackexchange.com/a/199086/37907. As you didn't provide any useful code, this is just guesswork. \documentclass{book} \usepackage{blindtext} \usepackage[indentunnumbered]{unnumberedtotoc} \begin{document} \tableofcontents \addchap{Preface} ...


3

Since you're using custom headers and footers (mystyle), you could just define a similar footer-only style called mytitlestyle and tell the first page to use that style with the command \thispagestyle{mytitlestyle}. Code: \documentclass[12pt,a4paper,oneside, twocolumn]{memoir} \usepackage{lastpage} \usepackage[utf8]{inputenc} \usepackage[danish]{babel} ...


2

In beamer, page number refers to the “physical” page number: any overlay increments the number. You want to use frame number, that's incremented by \begin{frame}.


2

Package chappg helps: \documentclass{report} \usepackage[auto]{chappg} \pagenumbering{bychapter} \begin{document} \chapter{First chapter} \end{document}


2

Your page number is already at 2cm from the right margin. In order to move it up, just add headsep=1.5cm, so its base will be at 2cm from the page margin. If it's the top that should be at 2cm from the page margin, then use headsep=\dimexpr1.5cm-8.1pt\relax, in the code that follows, because 8.1pt is the height of a digit for the Times font at a 12pt font ...


2

Well, I discovered it by myself. The solution is customizing the numbering of pages by redefining the \thepage command, using \renewcommand{\thepage}{C\arabic{page}} Also, if we want to avoid page numbers to appear in that cover section, we can use \thispagestyle{empty} So the MWE that would work for me is this: \documentclass[11pt]{book} ...


2

The simplest implementation would combine a custom counter with a \marginpar. You can define a command that sets the counter to the start page, and another that both increments the counter and prints it in the margins in the style of your choice. \documentclass{article} % count source pages \newcounter{spp} % format marginal note ...


2

(Converting my comment into an answer.) You can set the page style as appropriate in the glossary preamble by redefining \glossarypreamble somewhere before \printglossaries. For example: \renewcommand{\glossarypreamble}{\thispagestyle{myheadings}}


2

\frontmatter switches to roman (lower case) numbers, and \mainmatters switches back to arabic numbers, so if this should be prevented, it means either dropping \frontmatter and \mainmatter or patch this behaviour out of those macros using xpatchcmd from egreg's xpatch package. I was a little bit lazy about the success/failure test of the command \xpatchcmd ...


1

Tikzpagenodes got confused by pdflandscape, so I had to do it the hard way. \documentclass{article} \usepackage{pdflscape} \usepackage{tikz} \begin{document} Test 1 2 3. \pagebreak{} \begin{landscape}% \thispagestyle{empty} \begin{tikzpicture}[overlay] \node[above] at (.5\linewidth,-\textwidth-\footskip) {\thepage}; \end{tikzpicture} ...


1

With tikz and shapes.geometric library \documentclass[11pt, oneside]{thesis} \usepackage{fancyhdr} \usepackage{tikz} \usetikzlibrary{shapes.geometric} \usepackage{lipsum} \pagestyle{fancy} \renewcommand{\headrulewidth}{0pt} \fancyhead{} % clear all header fields \fancyfoot{} % clear all footer fields \newcommand{\diam}[1]{\tikz\draw (0,0)node[shape ...


1

For the article class I use the following in the preamble to get the page numbers to be A-1, A-2...B-1, B-2, etc. so you don't have to hardwire the section letter for each appendix. Including \break makes so that each appendix starts on its own page and gets a new page numbering style according to the section A, B, C, etc. ...


1

As rotation goes along with page count, I though to change it, so tables are oriented as you want. I hope page numbering was not a mandatory requirement. :) Your Line A hass been changed. \documentclass[10pt,twoside,letterpaper,oldfontcommands,openany]{memoir} \usepackage{rotating} \pagenumbering{roman} \title{Test title} \author{Test author} ...


1

Since titlepage option is given to article class, the abstract environment uses a titlepage internally, thus the page numbers are reset. In order to correct, the resetting of page numbers has to be patched out as well as the call to \endtitlepage in the \endabstract command, being replaced by a \clearpage. I did not address other issues with the original ...


1

I am sure that there are switches somewhere in beamer for doing this, but here is one way of doing it: \documentclass{beamer} \usetheme{Darmstadt} \usecolortheme{seahorse} \setbeamertemplate{footline} {\begin{beamercolorbox}[sep=1ex]{author in head/foot} \rlap{\textit{\insertshorttitle}}\hfill\insertauthor\hfill\llap{\insertframenumber}% ...



Only top voted, non community-wiki answers of a minimum length are eligible