Tag Info

New answers tagged

1

I tried to use the same combination of Texlive (2014) and Texstudio on a flahs drive and ran into the same issues. Providing the direct path worked fine but would probably not on another computer. Using relative links didn't work. At some point I ommited the dots in the beginning of the link (i.e. "/texlive/bin/win32/pdflatex.exe" -synctex=1 ...


1

Well, the Windows backslash file path seperator \ is used in (La)TeX to indicate a control sequence (aka. macro). That is why you get a Undefined control sequence error. In this case it takes \report as a macro. Normally you need to exchange it with the Unix file path seperator / instead, which under (La)Tex also works under Windows. Not sure if network ...


0

An alternative replacing the file using bash script: #/bin/bash MY_PATH=$(pwd) subpath() { echo "$1" | rev | cut -d"/" -f1-$2 | rev } BASE=$(subpath $MY_PATH 2) for f in *.tex do echo "fixing gnuplot tex file - $f" NAME=$(basename $f .tex) mv $f $f.back sed "s|${NAME}|${BASE}/${NAME}|" $f.back > $f rm $f.back done


-1

So I fixed it by passing the filename as the argument instead of the whole path.


0

my guess is that you have the texlive package installed, but not texlive-full. If this is true, there are two options: install texlive-full with apt-get or your favorite package managers. It will bring you most packages there are, but a few released only recently. if you go for the installation of TeX Live from TUG, install to the default, and then adapt ...



Top 50 recent answers are included