Tag Info

Hot answers tagged

11

The easiest way to do this that I have found is to provide overlay specifications to the elements of the picture. The basic commands, \path, \draw, \node and so forth are all overlay-aware. The one thing to be ware of is that the bounding box might jump around a bit as different parts of the drawing are put in or taken out. However, once you're aware of ...


11

I think the problem is that \pause isn't smart enough. The footline appears in the following: \documentclass{beamer} \providecommand\thispdfpagelabel[1]{} % Not sure what this does but our installation requires it. \usepackage{tikz} \usetheme{Madrid} % Has a footline. \begin{document} \begin{frame} \frametitle{test} \begin{tikzpicture} ...


11

You can use \only: \documentclass{beamer} \setbeamercovered{dynamic} \begin{document} \begin{frame} \centering \only<1->{\includegraphics[width=4cm]{ctanlion}} \only<2>{\includegraphics[width=4cm]{ctanlion}}\par \end{frame} \end{document} To preserve the relative position in slide one, you can use overlayarea: \documentclass{beamer} ...


11

You can also use \visible<1>{content} in order to have content only visible on slide 1, but reserve space for it on the other slides. This may help you with your positioning problem.


11

An interactive version with beamer may be constructed along the following lines: \documentclass{beamer} \begin{document} \begin{frame}[fragile]% \begin{semiverbatim} \frametitle{Input \&\ Output} \#include <cstdio> \only<1>{(1)?}\only<2->{int main() \{} \only<3>{(3)?}\only<4->{long a,b,c;} ...


10

This is due to the way that \pause works. As beamer processes a frame, it has an internal counter beamerpauses which it uses to work out what the current "logical" slide is. This is for use when you want to specify an overlaid command without referring to a specific slide, which is useful if you don't know (or haven't yet decided) what the specific slide ...


10

I just stumbled over this issue and found another work-around that does not require nesting lots of paused elements in braces: Add \onslide<1-> at the end of the tikzpicture environment (strangely it does not work if you put it after the environment): \documentclass{beamer} \providecommand\thispdfpagelabel[1]{} % Not sure what this does but our ...


9

Yes, \pause inserts "something" on an empty line in your instance. You could get rid of it by "jumping back" a line using \vspace*{-\baselineskip} before \pause: \documentclass{beamer}% http://ctan.org/pkg/beamer \begin{document} \begin{frame} Without pause: \[A\]\[B\] Not too much space between displayed equations. \end{frame} \begin{frame} With ...


9

From the beamer manual, in the middle of a use case: Euclid finds that he can also add a \pause between the definition and the example. So, \pauses seem to transcede environments, which Euclid finds quite useful. After some experimentation he finds that \pause only does not work in align environments. He immediately writes an email about this to ...


8

You can escape to LaTeX (Section 4.14 Escaping to LaTeX of the listings documentation) and use \pause: \documentclass{beamer} \usepackage{listings} \usepackage{bera} \lstset{basicstyle=\small\ttfamily, numbers=left, escapeinside=|| } \begin{document} \begin{frame}[fragile] \begin{lstlisting} line1 |\pause| line2 |\pause| line3 \end{lstlisting} \end{frame} ...


8

This is covered in Section 17.6 on page 191 of the beamer manual. \setbeamercovered{invisible} hides the content completely. Note that, the content which is already presented and become transparent and the content that is still about to be presented can be distinguished with the options of this command.


8

It's a sync problem; if you add \thebeamerpauses in some places (to get the value of the beamerpauses counter), you can see what's going on: \documentclass{beamer} \usepackage[utf8]{inputenc} \usepackage{default} \begin{document} \begin{frame} \begin{itemize}[<+->] \item A\thebeamerpauses \item B\thebeamerpauses \item C\thebeamerpauses ...


8

It's not much different than what you have already. \documentclass{beamer} \usepackage{mwe} % For dummy images \usepackage{lmodern} % To suppress some warnings \begin{document} \begin{frame} \centering \begin{tabular}{c@{}c} \includegraphics[width=0.4\textwidth,trim=0 120 160 0,clip]{example-image-a}\pause% ...


7

Delete the \noalign command from the definition of \cellcolor: \documentclass[xcolor=table]{beamer} \rowcolors{1}{gray!30}{gray!10} \makeatletter \def\rowcolor{\noalign{\ifnum0=`}\fi\bmr@rowcolor} \newcommand<>{\bmr@rowcolor}{% \alt#1% {\global\let\CT@do@color\CT@@do@color\@ifnextchar[\CT@rowa\CT@rowb}% ...


7

Have a look at section 9.6.4 and section 23.1 of the beamer manual: You can use a dot in the overlay specification (e.g. <.->). The dot is replaced by the current value of beamerpauses minus one, so if you use \item<.->, this item is shown simultaneously with the previous \item. For example, if you have a list with four items and you want to ...


7

Using \only means that the material is not printed on any slides you don't specify. At the same time, \pause automatically spreads material across slides. Thus trying to combine the two means that most of the input won't be printed: it's excluded from the \only list but is not on the 'correct' slide due to \pause. In the example given, it looks like you ...


6

Here's one option: \documentclass{beamer} \begin{document} \begin{frame} \begin{itemize}[<1->] \item First. \only<2>{\begin{itemize} \item First. \item Second. \end{itemize}} \item Second. \only<3>{\begin{itemize} \item First. \item Second. \item Third. \end{itemize}} \item Third. \end{itemize} \end{frame} ...


6

That's some curious behaviour you observed! There's nothing inherently wrong in the syntax you use – I'll explain below why the output goes awry nevertheless. Neil's suggestion to use \begin{itemize}[<+->] is a great alternative to \pause in your example. If you want to use \pause all the same, then there's an easy fix: adding an empty line (or a ...


5

Finally I followed Joseph's advice, and in the end found an easy fix for my problem: redefine \beamerorig@set@color and \beamerorig@reset@color to what they were before 2007. With the code below, the \pauses work exactly like expected: I also tested this with two sets of real-world slides, and encountered no unwanted side effects. \documentclass{beamer} ...


5

(Posting this as a separate answer since I seriously propose the code here as a bug fix for beamer, or maybe even better for pgfsys-pdftex.def.) In the end I found out the real cause of my trouble: beamerbasecolor.sty redefines the \reset@color command, and the redefinition contains the line \pgfsys@color@unstacked{beamer@tempcolor}% The pgf manual ...


5

It is not possible :-( This is clearly stated on page 60 (§8.1) of the beamer manual in the documentation of the allowframebreaks option: allowframebreaks=⟨fraction⟩. When this option is given, the frame will be automatically broken up into several frames if the text does not fit on a single slide. In detail, when this option is given, the following ...


5

I don't have my LaTeX here, but this ought to work. You have to rewrite each \pause to proper <n-m> syntax. \begin{frame} \frametitle{An example} \only<1>{ insert a picture for instance } \only<2-3>{ \begin{itemize} \item<2-3> here is my first remark \item<3-3> and here is my second \end{itemize} } \only<4>{ insert a 2nd ...


5

By putting the \section command inside the frame environment you are ensuring that it is executed for each overlay of that frame. The use of the \pause command then ensures that this is done more than once. So LaTeX thinks that you have three sections called "Study Background" because that particular \section command is executed three times. It is ...


5

The problem here is that the pause counter is reset when you leave the columns environment, so it doesn't generate the expected overlays. A workaround is to use \pause[10] for the first \pause after the environment so the counter is set to the correct value (cf. the beamer manual, section 9.1): \documentclass[blue,aspectratio=1610]{beamer} \begin{document} ...


4

You can use visible on style (see Mindmap tikzpicture in beamer (reveal step by step)). This one is used in code below but there are some other options not far away provided by Matthew Leingang, Claudio Fiandrino, Qrrbrbirlbel or Gonzalo Medina just to mention some of them. \documentclass{beamer} \usepackage{tikz} \usepackage{amssymb} ...


4

As Daniel mentioned in his answer, it's not possible to use frame breaks and overlay specifications; however, using a beamercolorbox (or an appropriate variant, depending on the theme used) you can define a new environment that behaves as the proof environment, except for the title, and then you can use this new environment to write the successive parts of ...


4

There is special syntax for item's - I've never tried pause with lists for that reason, but my guess is that it's causing trouble. Try removing all the pauses and replace \begin{itemize} with \begin{itemize}[<+->] This causes each item to be uncovered one by one. For more fine-grained control, instead of the above change, use e.g. \item<3-> ...


4

As you are aware, beamer will create a new page for each overlay. Each time a page containing a lstlisting environment is created the counter lstlisting is incremented. As this goes for any counter (tables, figures, etc.) beamer supports resetting the counter on overlays. Place \resetcounteronoverlays{lstlisting} in the preamble and your problem should be ...


3

In the beamer user guide, in the explanation of \pause it says: This command does not work inside amsmath environments like align, since these do really wicked things. The wicked thing that align, gather and friends do is that they evaluate the contents of the environment twice. In particular, overlay commands such as \pause are executed twice, which ...


3

I have just answered a very similar question here on tex.stackexchange, and I figured it would be a good solution for your problem too. The whole idea derives from this post about beamer pause and includegraphics. So, in short, your code is almost perfect if you download this custom style file and add it with a usepackage statement: \documentclass{beamer} ...



Only top voted, non community-wiki answers of a minimum length are eligible