Tag Info

New answers tagged

1

The mentioned page lists the more useful information, which PDF variant is required. It is essentially PDF/A, whereas PDF/A-1a is the most preferred one. However, having doubts that pdflatex is smart enough to add document structure, you might have to rely on PDF/A-1b, or PDF/A-2b. In any case, you will have to provide sufficient Metadata. A standard way ...


4

Use GhostScript (gs) to embed all fonts Compile your document normally, and then process it with this command: gs -DSAFER -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -dEmbedAllFonts=true -sOutputFile=$NEWFILE.pdf -f $YOURFILE.pdf (Replace $YOURFILE.pdf with the name of the file produced by pdflatex, and $NEWFILE.pdf by the name of the file you want to obtain) ...


2

Adobe has specified a syntax to open PDF files with some parameters inside URLs, see Parameters for Opening PDF files. With package hyperref, your PDF document can refer to other PDF documents. For example, the external document should be opened at page 4: \url{http://www.example.com/foo.pdf?page=4} ...


1

I was able to resovle the issue with the following command. (Credits to Ulrike Fischer, for pointing me in the right direction) \includepdf[pages={1-},scale=0.8,pagecommand={\thispagestyle{fancy}},frame]{myfile.pdf}


1

Beamer's rule "Your presentation will look exactly the same no matter which computer or viewer program is being used." If this won't happen you have to check your "accessibility option" in your pdf viewer and disable unwanted options. Using Adobe Reader (for example):


1

I uninstalled all previous versions of Ghostscript so now I have only the latest one 9.16 and after restarting the computer my Output profile latex->ps->pdf works fine.


0

The problem appears to be related to the transparency of the PNG and PDF graphics I was using. I solved the problem by flattening the PDF graphics before inserting them, and opening the PNG files in gimp to remove the alpha channel from those files. (It would appear that pdflatex is invisibly spreading the transparent layer of transparent graphics across ...


0

Adding to Sverre's answer of using TeX Gyre Termes (tgtermes package): it doesn't work for me with \ttfamily / \texttt{} i.e. typewriter fonts. I get the following from pdftotext (version 0.12.4): rmfamily: zażółć gęsią jaźń ttfamily: za»óª¢ g¦si¡ ja¹« I have browsed The LaTeX Font Catalogue and found out the following solution -- use TXTT font for ...


4

You can use the Times font TeX Gyre Termes: \documentclass{article} \usepackage{tgtermes} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \input glyphtounicode \pdfgentounicode=1 \begin{document} \noindent \rmfamily rmfamily: zażółć gęsią jaźń \\ \ttfamily ttfamily: zażółć gęsią jaźń \\ \end{document} Copy and paste from the .pdf gives this ...


0

I would use ghostscript to remove the transparency once the pdf is generated, using gs -o converted.pdf -sDEVICE=pdfwrite -dHaveTransparency=false input_file.pdf


0

I solved my problem. There was a conflict with an old version of Lyx on my max. So I deleted all directories Libary/Application Support/Lyx and reinstalled Lyx. Problem solved. best regards Jean-Christophe


1

You can use xmpincl, "which allows you to add arbitrary metadata in the Adobe XMP (Extensible Metadata Platform) format. But you have to write a separate XML file to do this" (suggested in threads here). They also propose a more recent package hyperxmp. You can find an example .xmpdata file and other files needed on creating high-quality PDF/A documents ...


4

The PDF format also knows link annotations with named actions, which calls functions of the PDF viewer. The official list of these named actions in the PDF specification for version 1.7 (ISO standard version) is quite short: NextPage, PrevPage FirstPage, LastPage However, the list supported by AcrobatReader is much longer. Section "5 Acrobat-specific ...


1

As I answered for Friggeri resume - Very different rendering in different readers, this problem comes from a bug with the pdf engine of XeLaTex with the OTF font file format when it is at a particular resolution as discussed in http://typophile.com/node/46451. As a workaround, you can download the latest FontAwesome package at ...


2

I also encountered this problem while trying to achieve exactly the same thing as you with the Friggeri template. This problem comes from a bug with the pdf engine of XeLaTex with OTF font file format when it is at a particular resolution as discussed in http://typophile.com/node/46451. As a workaround, you can use the .ttf version of the font. To do this, ...


1

An unusual short answer from me: The import package is 'only' suitable for importing/inputting/including subdocuments, which in turn might have basically any valid LaTeX code (few exceptions remain, of course). It allows for setting remote paths but the \subimport or \import command cannot be used as a replacement for \includegraphics or \includepdf ...


1

pdfnup uses pdfjam, which in turn uses the LaTeX package pdfpages. The latter one knows the option rotateoversize, from the documentation: This option allows to rotate oversized pages. E.g. pages in landscape orientation are oversized relatively to their portrait counter- part, because they do not match within the contour of a portrait page without ...


2

Your overpic is in a paragrapĥ with indentation. Use \noindent to remove this indentation: \documentclass[a4paper]{article}% ensure identical page size \usepackage[abs]{overpic} \usepackage{tikz} \usepackage{geometry} \geometry{a4paper, top=0mm, left=0mm, right=0mm, bottom=0mm} \setlength\unitlength{1mm} \begin{document} ...


0

Thank You very much for your idea Jiri Srubar but fortunately I don't need to try because a few minutes ago I managed to solve this problem in the following way: I reinstalled MiKTeX again but before installing any of the necessary packages I used the packagemanager's 'Synchronize' option from the 'Repository' menu. After this, I downloaded the packages the ...


0

I had similar problem. I usually use the "latex > dvips > ps2pdf" workflow, and for ps2pdf I'm using GPL GhostScript batch. And it seems that GhostScript is the culprit. When I downgraded GhostScript back to version 9.02 (from 9.15), PDF bookmarks are generated correctly again. (Upgrading to 9.16 didn't help.) (W7, MikTeX 2.9, TexStudio 2.9.4)


1

The solution is simple. Open your PDF using some PDF viewer/editor. For instance using Foxit Reader. Then print the file using a virtual printer, for example Foxit PDF printer. The printed version of your PDF would be image-based. However, to increase the quality you can choose a higher resolution, such as 300 dpi. The printed PDF file can be easily uploaded ...


3

\autoref knows only a basic set of names; just teach it what it should substitute for thm: \documentclass{article} \usepackage{hyperref} \usepackage{cleveref} \pdfstringdefDisableCommands{\let\Cref\autoref} \newtheorem{thm}{Theorem} \newcommand{\thmautorefname}{Theorem} \newtheorem{theorem}{Theorem} \begin{document} \section{Section 1} ...


1

The \Cref command cannot be used in \section when bookmarks are being produced; however, \autoref works (it's less powerful, though). For a simple application like this you can do as follows: \documentclass{article} \usepackage{hyperref} \usepackage{cleveref} \pdfstringdefDisableCommands{\let\Cref\autoref} \newtheorem{theorem}{Theorem} \begin{document} ...



Top 50 recent answers are included