New answers tagged

0

You are using a really old TexLive. It is not your fault, Ubuntu has always been way behind regarding LaTeX. Update your TexLive installation to a more current version, not using Ubuntu, using these instructions Installing TeX Live over the Internet and I think your problems will be history.


1

I would recommend the background package for this. Admittedly, this is mostly because I know it mostly works. (However, it turns out, there is also a good reason to use something other than xwatermark if using a KOMA class. See below.) Solution with background package For example: \documentclass[11pt,ngerman,a4paper]{scrartcl} \usepackage{background} ...


3

In recent (later than 2007, I'd say) TeX distributions, there's no more a separate pdfelatex program, because pdflatex uses e-TeX extensions by default. Older versions of rubber might have a different compiler modules for pdfelatex, but the most recent version (1.2) hasn't. If your rubber insists in calling pdfelatex or elatex, just make shell aliases for ...


0

I am missing the reputation to add a comment to Herr K.'s answer... In order to generate individual PNG files on Windows, you may need to specify the actual convert executable on your path (standalone assumes this to be imgconvert on Windows, instead of convert). MWE: \documentclass[ multi={mymath}, border=2pt, ...


1

The underlying cause are different coordinate-system conventions: Both DVI and PostScript have the origin in the top-left corner of the page, whereas PDF unfortunately moved it to the bottom-left corner. So any program that converts between PostScript and PDF (or DVI and PDF) has to assume a paper height, and shift all coordinates by that height. ...


0

To add a caption to the figure and another caption to the Table of Figures, you can use \caption[Caption for Table of Figures]{Caption (may be longer) for the figure}. Frank


1

Okay, even more searching gave me this: \begin{frame}[c,allowframebreaks] \begin{figure} . . . \end{figure} \end{frame} which does the trick.


3

I guess, that you actually you like to have portrait orientation for your document and only very big table to be on landscape orientation. The table, which example you show, is not really so big that this is (to my opinion needed. According to your preamble, you have a plan to use tabularx tables. With it you can already at shoved table use it in by it ...


2

The default layout is for US letter which does not match A4. To ensure you get A4, add a4paper to the class options or to the options for geometry. I would use: \documentclass[12pt, oneside, a4paper, landscape, leqno]{report} Here, I correct the typo in landscape as well. Note that examining the console output when you compile sometimes tells you useful ...


1

It seems that this happend when there is no \end{document} in the .tex file. In my case, the file was just empty as I forgot to save it.


0

I would use: \documentclass{amsart} \begin{document} \[ \max\{\, x e^{-x^2}\mid 0\le x\le 1\, \} \] \end{document} giving


0

This is not really a latexmk issue; it's about the behavior of pdflatex. No combination of options (as far as I can tell) both turns off the usual voluminous output and turns on file-line errors only. (I have a vague memory that pdflatex used to behave differently many years ago.) The best that you can do is use some other program that analyzes the log ...


0

I don't think there is a built-in solution. But if I understand your question correctly, you could use something like this: latexmk -pdf -pdflatex="pdflatex -file-line-error -interaction=nonstopmode" file.tex | grep "^.*:[0-9]*: .*$" Or the even less verbose variant that just prints the message lines: latexmk -pdf -pdflatex="pdflatex -file-line-error ...


0

You may use a hack with hyperref. \href{alt-text}{\includegraphics{...}} How it works: Some PDF-Viewers, including Adobe, render the exact URL as tooltip over links. Other PDF Viewers like Skim do the same, but some don't: Apple's Preview app. But beware, that the alt-text should not be a valid link. Don't forget to disable this hack when delivering the ...


2

What you see is just a report on the usage of memory during a run of TeX. Here's a sample of what I got with a document: Here is how much of TeX's memory you used: 1035 strings out of 493054 13273 string characters out of 6134760 70364 words of memory out of 5000000 4626 multiletter control sequences out of 15000+600000 4548 words of font info for 17 ...


0

Check out this extensive answer. Solutions range from using gs to pdfsizeopt.


4

You have some errors in your code: unmatched braces are the main one. Secondly, \hfill\\ is a don't-do-it; after \noindent you need \ignorespaces. And finally you have a load of unprotected end-of-lines, which may be irrelevant in this particular case, but it's good habit to have the correct % everywhere. \NeedsTeXFormat{LaTeX2e} ...


1

if everything else fails, you can try to fake the euro sign. this solution may not look as good, but it works anytime: \newcommand{\euro}{{\mathrm{C}\!\!\!\!\!\!=}}


1

Multiple spaces are interpreted as one space by LaTeX. You could add the space you need with \hspace*{} commands. \blockquote{ \#6 \\ you\\ \\ \\ \hspace*{1em}are\\ \\ \hspace*{3em}inscribed\\ \hspace*{5em}in the\\ \hspace*{6em}lines on the\\ \hspace*{2.5em}ceiling\\ \\ \hspace*{3em}you\\ \\ \hspace*{1em}are\\ \\ \hspace*{3em}inscribed in\\ ...


2

The %& magic line has been supported by implementations of TeX from many years. However, the feature is implemented differently in the various TeX distributions. Note that no editor/front-end I know of interprets such a line: this is specific for the TeX engine. In TeX Live, the line can contain only the specification of a format to be loaded and a TCX ...


0

The problem was solved by adding export HOME='/var/www' to the shell-script just before the pdflatex command.


0

After loading auto-pdt-pdf set the command \psfragfig to \relax then pstool can define it in its own way: \documentclass{article} \usepackage{auto-pst-pdf} \let\psfragfig\relax \usepackage[process=all]{pstool} \usepackage{pst-barcode} \begin{document} \begin{pspicture}(1in,1in) \psbarcode{http://example.org}{eclevel=L}{qrcode} \end{pspicture} ...


0

I needed to use -shell-escape parameter, i.e. call pdflatex -shell-escape input.tex to make it work. (I've found note about -shell-escape in output of pdflatex command)


4

It sounds like this might be a problem in the pdf encoding. Often, compiling the document using pdflatex instead of latex fixes this kind of problem. (Or if you are invoking LaTeX from your editor instead of the commandline, set up your editor to call pdflatex instead of latex.) There are various other advantages to pdflatex as well, as discussed in e.g. ...


5

Under Linux, you can use the facilities of bash. First, you make an array—a list of .tex files in the current folder (based on a wonderful StackOverflow answer): arr=( $(find ./ -maxdepth 1 -iname "*.tex" | cut -c3- | sort | rev | cut -c5- | rev ) ) The cutlery removes the ./ at the beginning of each file (but we still want to preserve the relative file ...


2

Several of the abstract fields (such as the one of kalesanUsesFSS) contain unescaped percentage characters, such as "5.2%". This leads BibTeX to consider the rest of the line as a comment, including the final "}". You may need your replace your "%" by "\%" (not tested).


3

If you use pdflatex --halt-on-error then it will stop at the first error. One way of introducing an error is to use an illegal character. The only one by default is 0 (ASCII NULL). Normally you can enter that as ^^@ but if you want it to work even in verbatim you need an actual byte 0 in the input stream.


1

I had this problem, too; when I removed this: \usepackage[T1]{fontenc} the problem disappears and the fonts become very nice and sharp again! Maybe you are using fontenc, or maybe it's some other package that's causing the problem. Check this possibility.


0

If you do not want to modify the source file, another possibility could be to use the option -output-format=dvi when compiling with pdflatex. It works for me with TeX Live under Windows. Remember to place the option before input file name. Just as an example, to produce a dvi output I use the following compile command: ...


3

Simply add bookmarksopen=true for the default bookmarks-open to also expand them. I will refrain from posting a screenshot as my viewer ignores all these options anyway and acroread simply takes forever to even consider possibly thinking about sometime in the distant future opening a file. (But the OP confirmed that it works in Adobe's viewer.) ...


2

According to the documentation of bookmark you can use the open option; if you want to set the level, you can say openlevel=<level>; so \usepackage[open,openlevel=1]{bookmark} will show something like whereas the simple open option will show Tested with Skim and Adobe Reader on Mac OS X.


2

I've managed to fix it. There is a long list of packages needed to be installed before compiling a cv using the moderncv template. All packages can be installed using the miktex package manager which on windows is installed by default in: C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\mpm_mfc_admin.exe First, install moderncv. Installing manually is more of ...


2

You should not use \bibliography{bibfile.bib}{} but \bibliography{bibfile}: \documentclass{article} \begin{document} \cite{foo} \bibliography{bibfile} \end{document} During the compilation LaTeX try to add the .bib extension and so it goes wrong. since the file bibfile.bib.bib does not exist.


1

\begin{figure}[ht] \centering \includegraphics[width=162mm]{images/fig1.png}% \begin{picture}(0,0) \put(-50,-50){\parbox{.45\linewidth}\centering \caption{Some text}\label{fig1}}} \end{picture} \end{figure} then adjust the -50,-50 coordinates to put the caption wherever you like.


12

∞ is U+221E so you want, for (pdf)teX \DeclareUnicodeCharacter{221E}{\ensuremath{\infty}}


2

There were actually two clashing problems, which in the beginning I thought was one problem - and as such messed up some points in my question. In light of newly revealed facts, I would like reclassify the above mentioned viewers into two categories. a) the following viewers differ only with respect to color model (rgb vs. cmyk) gv mupdf b) the ...


4

The warning is directly thrown by pdfTeX. The TeX macro level is not involved, thus package like silence do not work for this case. The warning can be suppressed by changing the source code of pdfTeX and recompiling.


4

There is no error message shown in your question. That is a normal error-free log, from a document that presumably looks like this \documentclass{article} \begin{document} \end{document} Which may not be the intended document, but check exactly what is in the file ./LatexThesis.tex Note that you are using LaTeX2e <2015/01/01> there have been 5 ...


7

Since you have MacTeX, use LaTeXiT, which lets you convert equations to images in several formats, including PDF and PNG. There is no need to write LaTeX support code: just enter the equation in the input box and press "LaTeX it!". If you want to convert equations in batch, you can write a simple script that adds the equation to a template based on the ...


17

standalone class is sufficient. You can enable the multi option, so that the contents of each (math) environment is cropped to its own page in a PDF file. Then you can either save each page directly as a .png image (Acrobat Pro, and perhaps Adobe Reader, allows you to do it in one go), or you can use the convert functionality (need Image Magick) provided ...


8

Here's what I do to go from a file of equations to png files using asymptote. You'll need the following 3 files in a directory. sample.bat - change the "5" to alter the png resolution asy sample -noV -render 5 -f png pause sample.dat - this file holds your equations. \frac{1}{2} = 0.5 y = \sin{x} a^2 + b^2 = c^2 sample.asy - this is the asymptote ...


5

The problem appears to be that latex automatically numbers equations in the equation environment. This default behavior of latex's is likely because authors often need to refer to equations. An easy solution is to remove numbering by using \begin{equation*} YOUR EQUATION GOES HERE \end{equation*}


2

It Seems to work here, tweak alpha opacity than general opacity. http://www.inkscapeforum.com/viewtopic.php?f=28&t=15739&p=65180#p65180 I am using pdftex and Inkscape 0.91


2

TeX's hyphenation rules do not work on the basis of words, except for special exceptions specified in \hyphenation. The body of the hyphenation rules are generated by matching substrings of words in the document to a set of letter patterns that encourage or discourage hyphenation at that point. So there is no sense really in which TeX does not "know" a word ...


1

To add the Navigation again you have to add it to your custom footline definition. \makeatletter \setbeamertemplate{footline} {% \insertslidenavigationsymbol% <-- THE LINE I ADDED \setbox\beamer@tempbox=\hbox{% \begin{beamercolorbox}[wd=.333333\paperwidth,ht=2.25ex,dp=1ex,center]{author in head/foot}% \usebeamerfont{author in ...


4

As suggested in the comments, there are the gitinfo packages, which offer a broad range of features. If you are looking for a quick-and-dirty solution instead, you can use Heiko's package catchfile to read the contents of a file into a macro. The syntax "| <cmd>" allows to input the stdout of <cmd> as a file. % arara: pdflatex: { shell: on } ...


1

this is more a comment than an answer, but it's too complicated for a comment. i don't know why your lower limit is disappearing; i don't get that result. however, if you're going to use \mathclap, you almost certainly want to use \limits on this integral so that the lower limit doesn't overprint the integral sign. and the "as" is almost certainly text, ...


1

\documentclass[12pt,letterpaper,fleqn,parskip=half]{scrartcl} \usepackage[T1]{fontenc} \usepackage[latin1]{inputenc} \usepackage{bookman} \newcommand{\gm}{\textbf{gmond}} \newcommand{\gt}{\textbf{gmetad}} \begin{document} The \gm\ daemon is the blurst. I hate \gm\ and \gt. \end{document} However, and responding to @Anti Earth's just criticism of the ...



Top 50 recent answers are included