Tag Info

New answers tagged

0

To recover the definition of \@alph you can add \appto\arabic@numbers{% \let\@alph\@origalph% \let\@Alph\@origAlph% } Code \documentclass[a5paper]{article} \newcommand{\subscript}[2]{$#1 _ #2$} \usepackage{amsfonts} \usepackage{polyglossia} \usepackage{enumitem} \setdefaultlanguage[numerals=maghrib]{arabic} \setotherlanguage{english} ...


2

There is two questions. In general you should ask for ONE problem in the some time. But, I will try to answer here. First question The main problem is that your \newcommand{\choiceline}[2]{\linenum{|#1|#2||#1|#2}} \sublinenumberstyle{alph} \let\fullstop\relax is called in the rightside environment, and so have a local impact. And the notes are inserted ...


3

The \footnoterule should occupy no vertical space. Here's a redefinition that places it at the right margin: \documentclass[a4paper]{article} \usepackage{xecolor} \usepackage{polyglossia} \usepackage{fontspec} \definergbcolor{titlecolor}{750000} \setmainlanguage{arabic} \setmainfont[Ligatures=TeX]{Amiri} ...


1

This should work (for right-to-left typing), in your preamble (of course the length is adjustable): \renewcommand\footnoterule{\rule{0.4\linewidth}{0.4pt}\hfill}


1

Here’s your example, with xecolor instead of xcolor, to support bidirectional text: \documentclass[a4paper]{article} \usepackage{xecolor} \usepackage{polyglossia} \usepackage{fontspec} \definergbcolor{titlecolor}{750000} \setmainlanguage{arabic} \setmainfont[Ligatures=TeX]{Amiri} ...


2

It's a problem with bidi that seizes the initiative and, for no apparent reason, restores the book definition of the theindex environment. \documentclass{book} \usepackage{polyglossia} \usepackage{kantlipsum} \usepackage{imakeidx} % nullify bidi redefinition % this should go after polyglossia and imakeidx have been loaded \let\imakeidxtheindex\theindex ...


0

For unicode Hebrew, the easiest is to use xelatex and the "Lucida Grande" font.


1

The first space is due to the fact that the English paragraph is shorter than the corresponding Danish one. The second space is due to the fact that, to TeX's eyes, the Danish paragraph ending with “før ham.” is one line longer, because the space between før ham. and \end{danish} is not removed. The first blank line can be removed by adding \looseness=1 to ...


3

The ucharclass package changes the class of the Latin characters, but polyglossia assumes this class is 0. You can try with \documentclass{standalone} \usepackage{ucharclasses} \usepackage{polyglossia} \setmainlanguage{french} \makeatletter \appto\french@punctuation{% \ifluatex\else \XeTeXinterchartoks \BasicLatinClass \french@punctthin = ...


5

The problem turns out to be a bug in the greek.lbx localization file. Instead of using its already defined \lbx@gr@mkbibmonth to format the date, it instead uses \mkbibmonth defined via \let\mkbibmonth\lbx@gr@mkbibmonth after first using \savecommand{\mkbibmonth}. Replacing the use of \mkbibmonth with \lbx@gr@mkbibmonth directly in the .lbx file solves the ...


0

Add in preamble: \DefineBibliographyStrings{english}{% dateapril = {April} } Now result is :


3

The autolang=hyphen option does what you want. Here's your example but I've made the margins deliberately large to show the hyphenation. Because of the very big margins this still results in some bad boxes, but this is to be expected. For comparison, the example without autolang=hyphen is given also. (I also corrected the month field to a numeric field, ...


4

Imho it is a problem of the implementation in polyglossia: the space is lost inside some boxes: \documentclass{article} \usepackage{fontspec, polyglossia} \setdefaultlanguage{french} \begin{document} \begin{tabular}{l} \today{} here: should have been a space before those two dots! \end{tabular} \mbox{\today{} here: should have been a space ...



Top 50 recent answers are included