Tag Info

Hot answers tagged

5

Instead of using \diameter, you can build the symbol yourself: \documentclass[12pt]{report} \usepackage{pict2e} \DeclareRobustCommand{\slashcirc}{{\mathpalette\doslashcirc\relax}} \makeatletter \newcommand\doslashcirc[2]{% \sbox\z@{$#1\m@th\circ$}% \setlength\unitlength{\wd\z@} \begin{picture}(1,1) \roundcap \put(0,0){\box\z@} ...


5

If you use xcharter there seems to be no problem: \documentclass[12pt]{article} \usepackage[utf8]{inputenc} \usepackage{XCharter}% \begin{document} DARPA’s \end{document}


5

Maybe something like this? (The trailing unary minus sign at the end of the first row is there just to demonstrate that the "middlescript letter" is aligned on the math-centerline.) \documentclass{article} \newcommand\mathmiddlescript[1]{\vcenter{\hbox{$\scriptstyle #1$}}} \newcommand\textmiddlescript[1]{$\vcenter{\hbox{\scriptsize #1}}$} ...


5

Here's an option in which I used the background package to position the sideways text: \documentclass{article} \usepackage[a6paper]{geometry}% just for the example \usepackage{background} \usepackage{eso-pic} \usepackage{contour} \newcommand\BackgroundPic{% \put(0,0){% \parbox[b][\paperheight]{\paperwidth}{% \vfill \centering ...


4

It's a good occasion for illustrating a macro by Victor Eijkhout, that can be found in TeX by Topic, section 12.6.8; the advantage over directly using \vcenter is that \setbox<number>=\xvcenter{...} is possible. The \midscript macro chooses a smaller size in (first level) subscripts or superscripts. It won't give good results in second level ones. ...


4

You can what you want with the plaintex package insbox. It defines \InsertBoxL and \InsertBoxR commands, with two arguments: the number of untouched lines before inserting the box, and the contents of the box. Also an optional argument: the number of supplementary wrapped lines, if the height of the box is not correctly calculated. ...


4

There is an implicit kerning between the upper case A and the apostrophe, if the font package charter is used. Because of the shape of the A, a negative kerning makes sense. It's not a bug, but by choice of the font designer. The following example compares three cases: Unmodified version with implicit kernings as defined by the font. Without implicit ...


4

the problem is clearly in the kerning instructions in the font, so what you want to do is inhibit kerning. there are several ways to do that: DARPA{}'s -- an empty group DARPA\/'s -- an italic correction DARPA{'}s -- isolate the apostrophe in its own group your choice -- they should all have the same result. warning -- if the passage containing this ...


3

If I understood you correctly, you like to determine rectangle with size determined with two coordinates (bottom left, top right). If this is a case, you can obtain this as follows: \documentclass[tikz,border=5mm]{standalone} \usetikzlibrary{fit} \begin{document} \begin{tikzpicture}[ mynode/.style 2 args = { draw, rounded corners, fill=black, ...


2

Ah, got it; see, I had: \tzrn[nf,baseline=(A.base)](A){y} ... which expands to: \tikz[remember picture]\node[nf,baseline=(A.base)](A){y} ... however, that is wrong, the baseline parameter should be applied to \tikz - not to \node (there was a post about this on this site, but I lost the link). The correct would be: \tikz[remember ...


2

You can achieve this effect with wrapfig.sty. In its documentation, you find: Placment and floating Parameter #2 (required) is the figure placement code, but the valid codes are different from regular figures. They come in pairs: an uppercase version which allows the figure to float, and a lowercase version that puts the figure "exactly here". [...] ...


2

Two options: Use t as optional argument for both frames; in this way, the frames' content will be top aligned: \documentclass{beamer} \usepackage{tikz} \usetikzlibrary{positioning} \begin{document} \begin{frame}[t] \frametitle{FRAME 1} \centering \begin{tikzpicture} \node[draw=black] (a) {A}; \node[draw=black, right=of a] (b) {B}; ...


2

Warning: this is not a general solution. This is a solution to be applied after you've completed most of your document. As already mentioned in the comments, you could get around this issue by removing the use of \limits: \documentclass{article} \usepackage{amsmath,amssymb,amsthm} \newtheorem{defn}{Definition} \begin{document} \begin{defn} An ...


2

As the two column float has to span the top of the following page, and (in latex 2015 release, or with fixltx2e with older format) all floats are kept in order, and so the single column floats have to come after that, I do not see how you can avoid a lot of white space after the first section, however you can do \documentclass[twocolumn]{article} ...


2

You mention no concern about float numbering, so my suggestion would be to forego any kind of floating for the single-column figures. For this, use the [H] float specifier: \documentclass[twocolumn]{article} \usepackage{lipsum} %used to generate filler text \usepackage{afterpage,float} \usepackage[demo]{graphicx} \begin{document} \section{Section with ...


2

\begin{minipage}[t]{7in} \includegraphics[width=7in]{Figures/SynthesisOverview} \end{minipage}% The minipage here isn't doing anything very useful as \includegraphics is already a box, and minipage just wraps it in another box. the problem is that [t] means make the reference point of the minipage the baseline of the top row, but here there is only one ...


1

The position of the label is calculated through the auto option. It is designed to make labels floating alongside the curve without overlapping. As a result the pin-edge is nearly orthogonal to the tangent line for safety. It is not difficult to override auto but it may ruin the whole engine. A workaround is to use the temporary point (label visualizer ...


1

I do not know why that syntax doesn't work, but you can use the syntax of the calc library. While not exactly the same, it does allow you to place axes relative to other nodes/coordinates. Note that the default anchor for the axis is south west, change that if desirable. In the code below I used at={($(nodeOne)+(0cm,1.5cm)$)}. When no anchor for the node is ...


1

There is actually a built-in workaround, which is to use \begin{tikzfigure}[Caption]%Figure environment does not work \label{test} \includegraphics[width=0.2\textwidth]{figure.pdf} \end{tikzfigure}


1

A simple workaround is \signature{vspace{-80pt} Susan R. Bumpershoot}


1

You can also define a node placed at the middle of the coordinates, and big half the distance of the two coordinates. \node[rounded corners, draw=red, minimum size=10cm] at (15,15) {}; Here are the corners to show it fits: Ouput Code \documentclass[border=10pt]{standalone} \usepackage{tikz} \begin{document} \begin{tikzpicture} \coordinate ...


1

The \FloatBar­rier command from the placeins package seems to do the trick. The documentation states; Placeins.sty keeps floats ‘in their place’, preventing them from floating past a \FloatBarrier command into another section. To use it, declare \usepackage{placeins} and insert \FloatBarrier at places that floats should not move past, perhaps at ...



Only top voted, non community-wiki answers of a minimum length are eligible