New answers tagged

1

You are introducing some spurious white-space after the opening brace before including the image. It should be: % arara: pdflatex \documentclass{article} \usepackage[demo]{graphicx} \usepackage{subfig} \usepackage{blindtext} \begin{document} \begin{figure} \centering \includegraphics[width=\textwidth,height=0.1\textwidth]{dummy.pdf} ...


0

See, if the following can help you: \documentclass{book} \usepackage{graphicx} \usepackage{showframe} \begin{document} \newpage \section{Appendix} \label{append} \vfill \begin{table}[htb] \includegraphics[width=\textwidth]{example-image} \caption['Tis table1]{'Tis table1} \label{table1} \end{table} \vfill \clearpage next page \end{document} I assume, ...


4

You know how to use coordinates. So you could just say \draw[thick] (C1.east) -- ++(1,1) coordinate (y) -- (y |- C2.south);. I left the red line in the code as thin and dashed for comparison. \documentclass[border=3mm]{standalone} \usepackage{tikz} \usetikzlibrary{calc} \begin{document} \begin{tikzpicture}[font=\sffamily] \node[draw, circle](C1) at ...


0

I cant reproduce your problem. Probably because I wrote own MWE (since you not provide your): \documentclass{article} \usepackage{graphicx} \usepackage[export]{adjustbox} \begin{document} \begin{figure}[h] \begin{minipage}[t]{0.45\textwidth} \centering \includegraphics[width = 1\textwidth,fbox]{example-image-a} ...


2

Enclose your picture and text below it in \parbox or in minipage: \documentclass[11cm,a4paper]{article} \usepackage{geometry} \usepackage{xcolor} \usepackage{graphicx} \usepackage{tikz} \definecolor{color0}{rgb}{0,0,0}% black \definecolor{color1}{rgb}{0.22,0.45,0.70}% light blue \definecolor{color2}{rgb}{0.45,0.45,0.45}% dark grey % <<<tikz block ...


2

By use near end you were very close to desired solution ... With pos= .. you can determine relative position of node on path. See MWE below. \documentclass{article} \usepackage{tikz} \usetikzlibrary{arrows,automata,positioning} \usepackage{amsmath,amssymb,amsfonts} \begin{document} \begin{tikzpicture}[>=stealth', shorten > = 1pt, node distance = ...


2

You are inserting several unwanted spaces and newlines. Don't use blank lines if you do not want new paragraphs to start. \adjustbox{valign=t}{ \subfloat{ has to be \adjustbox{valign=t}{% \subfloat{% because both lines introduce a spurious white space. It helps a lot if you load the package lua-visual-debug and compile with LuaLaTeX. You will ...


1

If you place the legend with \legend{...} instead of \node at (leg) {\pgfplotslegendfromname{grouplegend}}; there is another possibility that requires less changes in the code of your of (group-)plots in order to bring the legend below your plots. Furthermore, you can easily change the order of other elements, too. First, you have to define a new desired ...


0

Another solution (if you do not have pics because you are still with tikzpgf 2.10) you can change the definition of \gear to use relative coordinates (still need calc added to tikz packages): \newcommand{\gear}[7]{ node (#6) {#7} ($(#6)+(0:#2)$) \foreach \i [evaluate=\i as \n using {\i-1)*360/#1}] in {1,...,#1}{ arc (\n:\n+#4:#2) {[rounded ...


4

Instead of: \draw[engine] (a.east)+(8,0) \gear{8}{2}{2.4}{10}{2}{b}{Gear B}; see if this modification of above code is acceptable to you: \draw[engine,xshift=60mm] \gear{8}{2}{2.4}{10}{2}{b}{Gear B}; Edit: Alternative for above is use of scope (as suggested Peter Grill): \begin{scope}[shift={($(a.east)+(5,0)$)}] \draw[engine] ...


1

solved another one myself by looking at source code... It's /tikz/circuitikz/voltage/distance from node (grrr, I wish these were documented) \documentclass{standalone} \usepackage[siunitx]{circuitikz} \begin{document} \begin{circuitikz}[american] \draw (0,0) to[/tikz/circuitikz/bipoles/length=0.6cm, D*, v^=$v_g$] (2,0) node [right] ...


1

ah -- I found it: \raisebox does the trick: \documentclass{standalone} \usepackage[siunitx]{circuitikz} \begin{document} \begin{circuitikz}[american] \draw (0,0) to[/tikz/circuitikz/bipoles/length=0.6cm, D*, v^=$v_g$] (2,0) node [right] {\tiny\verb|default|}; \draw (0,1) to[/tikz/circuitikz/bipoles/length=0.6cm, D*, ...


0

There is also the figcaps package, which has two simple switches to forward all floats to the end in \figcapson (enabled by default) and \figcapsoff. \documentclass{article} \usepackage[printfigures]{figcaps} % printfigures to display figure floats %\figcapsoff % enable to keep floats in their positions \begin{document} <contents> \end{document} ...


1

The error appears because of the \tikzfading and has nothing to do with the background rectangle. I guess you could get the same issue with a simple \fbox. You can see that in the following MWE: % arara: pdflatex \documentclass{article} \usepackage{tikz} \usetikzlibrary{backgrounds,shadows} \begin{document} \begin{tikzpicture}[show background ...


4

Hadn't seen that library before, perhaps because it is a third-party library, and not discussed in the TikZ manual. The only documentation seems to be a short readme file, so I had a look at the code of the library itself. The library file can be found by running kpsewhich tikzlibrarybayesnet.code.tex in a terminal, on my system it is found in ...



Top 50 recent answers are included