Tag Info

Hot answers tagged

13

It's easier to see the difference in the log file. \documentclass[12pt]{memoir} \usepackage{microtype} \begin{document} \showoutput 1say.\index{say} 2say\index{say}. \end{document} shows ....\OT1/cmr/m/n/12 1 ....\OT1/cmr/m/n/12 s ....\OT1/cmr/m/n/12 a ....\kern-0.32639 ....\OT1/cmr/m/n/12 y ....\kern-0.97916 ....\OT1/cmr/m/n/12 . ....\penalty 10000 ...


5

You have solved much of the original problem yourself; you can solve the last bit to remove the Oxford comma before the et. al. in the bibliography entries with the following code added to your MWE: \xpatchbibmacro{name:andothers}{ % Removes comma before the "et al" {\finalandcomma}% }{% \addspace% }{}{} This gives: The final working example becomes: ...


5

This is not possible as LaTeX needs to know where a quotation is starting and where it ends. Imagine, you are writing "Outer with "inner quote"". No chance for LaTeX to know, what you want. The accent (apostrophe) is used for other stuff as you can see in this example: I can't use what I've written. So there are the following possibilities. ...


4

To get rid of the semicolon, the type field must be (as required by the Vancouver style) type={database on the Internet} and not type={page on the Internet} In fact, with the following contents for your ex.bib @Webpage{arXiv-web, type={database on the Internet}, title={arXiv.org e-Print archive}, key={arXiv.org e-Print archive}, ...


3

The problem you have is that you have used inbook (which assumes a bookauthor) for incollection. As a result you are getting a spurious \newunit after the (non-existent) author's names. Change to @incollection and all will be well. To demonstrate, I have used a (not released) package I use which marks \newunitpunct with a small blue line and watches for ...


3

I would suggest using a language that does not have the Oxford comma (british for example). But if that is not an option, a simple \renewcommand{\finalandcomma}{} in the \AtBeginDocument hook should do it: \AtBeginDocument{ \renewcommand{\finalandcomma}{}% } If we use that, we do not even need ...


2

You seem to be entering the bibliography "by hand" (unless you have done that simply to create your MWE, which of course (since you've tagged your question bibtex is possible). Anyway, much as I hate answering a question with "use some bibliography package you are not using", I'm going to stick my neck out and say that this makes a good case for using ...


1

For babel-style shortcuts, don't use "smart" quotes: using "dumb" double quotes is the way to go. \documentclass[a4paper]{scrartcl} \usepackage{fontspec} \usepackage{polyglossia} \setdefaultlanguage[spelling=new, babelshorthands=true]{german} \usepackage{csquotes} \begin{document} \enquote{Hallo} --- with \texttt{\string\enquote}, this works "`Hallo"' ...



Only top voted, non community-wiki answers of a minimum length are eligible