Tag Info

New answers tagged

1

There's no semicolon in the OML encoding, so it cannot be taken from the default letters font. Space is crucial to understanding why TeX takes things from certain places: only 128 places per font. If you think it should come from cmmi, ask what should be taken out to free up a slot?


1

I need to answer instead of commenting because of not having enough reputation. But I think some people may find it useful to know that Thomas K is not getting the same output with \blockcquote and \blockquote because both commands have different hooks which print the final output. For \blockquote it is \mkcitation which is defined with space and ...


20

TeX will not break a line at the “control space”, because it's allowed to break lines in formulas only after binary operators such as + or =. Glue in math mode is not an allowed break point. The spaces in $a,\ b$, and $c$ will be different, because TeX adds a thin space between a punctuation atom (the comma) and an ordinary atom (the ‘b’), independently ...


27

Yes it matters. In the first case the comma is from the math font, and depending on your math setup can be different from the text font. So you should make sure that all commas are either from text or math and not mixed. Which one is better depends on the context, in a normal sentence I would use the text comma. \documentclass{article} ...


0

Another possible reason why you might have trouble getting straight quotes when using fontspec: the config file. I'm not sure where it lives on other platforms; on linux locate fontspec.cfg will show you where it is. I just discovered that my wife's laptop (TeX Live 2014) had a very different fontspec.cfg than my laptop (TeX Live 2013). Specifically, hers ...


1

You've written the authors' names incorrectly and Bibtex is confused. If you put the surname first followed by the initial you have to put a comma behind each surname: author={Doe1, J. and Doe2, K. and Doe3, L.}, Alternatively you could put initials first and then surnames, in which case no commas are needed: author={J. Doe1 and K. Doe2 and L. Doe3},


3

It is enough to modify the value of \finalandcomma: \documentclass{article} \usepackage[english]{babel} \usepackage{filecontents} \usepackage[backend=bibtex,style=ieee]{biblatex} \begin{filecontents}{\jobname.bib} @article{doe2015, author={Doe1, J. and Doe2 K. and Doe3 L.}, title={Why I get this extra comma before the 'and'?}, year = 2015 } ...


5

The implementation in biblatex-ieee follows as far as possible that in ieeetran. The latter describes itself as being official correct, so this is a reasonable reference point. On the specific point about the 'Oxford comma' here, if you look at texdoc ieeetran and for example ref. 20 you will see C. Barratt, M. C. Grant, and D. Carlisle. with a comma. ...


0

Under beamer there are some restrictions for your usage: listings inside a frame requires you to use a fragile setup: \begin{frame}[fragile] \begin{lstlisting}[..] ... \end{lstlisting} \end{frame} You need the frame ending - \end{frame} on a line of its own without indentation. Indentation inside a lstlisting environment is always interpreted literally, ...


0

Changing from XeLaTex to LuaLaTex the problem was solved.


1

A complete minimal working example can look like this: \documentclass{article} \usepackage{listings} \begin{document} \begin{lstlisting}[language=bash] #!/bin/bash echo "Hello,world!" \end{lstlisting} \end{document} This compiles fine with XeLaTeX:


1

Here you are; \documentclass[12pt]{scrreprt} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[ngerman]{babel} \usepackage{csquotes} \usepackage[% backend=biber, style=authoryear-comp, bibstyle=apa]{biblatex} \DeclareLanguageMapping{ngerman}{ngerman-apa} \DefineBibliographyStrings{ngerman}{andothers={et\ \addabbrvspace al\adddot}} ...


0

As other answers have pointed out, csquotes is fantastic. Here are three reasons I like csquotes so much. Active quotation marks. Automatic management of nested quotations so that you can pretty much always just say 'quote this' and csquotes will figure out the right thing to do. Quotation marks which adapt automatically to both the global language of the ...


3

Yes, LaTeX will parse the left and right quotation marks correctly if you tell it to parse the input with UTF-8 encoding. \documentclass{article} \usepackage[utf8]{inputenc} \begin{document} ‘Hello’ \end{document}


0

It seems you are looking for the Unicode characters U+231C ("top left corner") and U+231F ("bottom right corner"). Can you type these in using your keyboard?


1

biblatex will not abbreviate first and middle names unless you add the firstinits=true option. \begin{filecontents*}{\jobname.bib} @article{Fujisawa:2015nla, author = "Fujisawa, K", title = "{Magnetised stars with differential rotation and a differential toroidal field}", doi = "10.1093/mnras/stv905", year = "2015", ...



Top 50 recent answers are included