Tag Info

New answers tagged

0

The problem occurs due to the \rowcolor{blue!10}\bottomrule at the bottom of the first table. As a workaround you can manually remove the last \rowcolor{} command but I'm afraid I don't know how to get that done automatically. I would have posted this as comment but don't have the rep. \documentclass[xcolor=table,professionalfonts,a4paper,11pt]{article} ...


1

The problem is that you have an extra \rowcolor{blue!10} \bottomrule at the bottom of your tables; this is somehow affecting what follows. You're actually making one too many of the \\rowcolor{blue!10} in your rep command; it adds it on to the end of the line but affects the next line. To fix, just make rws have one less like this. rws <- seq(1, ...


2

Far from perfection, but for a document with a single table you can use detex and then replace & by , and delete empty lines. In Linux you can use some tools as grep and sed for this. The first line of the table is then the columns types, so you can delete manually or with some tool like tail. Example command line: detex file.tex | grep -v '^$' | tail ...


0

I just solved it. The command I use in the user-defined commands for compiling and displaying a Rnw-file in my own pdf-viewer is "C:/whateverYourPathToRonYourMachineIs/R-3.0.1/bin/Rscript.exe" -e "library(knitr); knit2pdf('%.Rnw')" | pdflatex -synctex=1 -interaction=nonstopmode %.tex | "C:/whateverYourPathToYourPDFViewerOnYourMachineIs/Foxit Reader.exe" ...


4

I'll be your Answer the Unanswered officer tonight; From the comments, it has been verified that in certain cases, it might happen that in such cases deleting the previous plot files is needed.


1

The new version of Word (2013) lets you open and edit PDFs. The workflow is then: Use latex and pdflatex to make your PDF Open the PDF in Word 2013 Save as docx


1

Summary for future generations tested on TeXstudio 2.7.0 and the rest of the environment section from the question (not TeXmaker for which it shouldn't be much different) When it appears If you wish to compile .Rnw file while producing some figures with dev='tikz' option in knitr chunks AND you use \usepackage[czech]{babel} or \usepackage[slovak]{babel} ...



Top 50 recent answers are included