Tag Info

Hot answers tagged

18

The widetext environment changes the formatting from two-column to one-column to better accommodate very long equations that are more easily read when typeset to the full width of the page: \documentclass[twocolumn]{revtex4-1} \usepackage{lipsum} \begin{document} \lipsum[1] \begin{widetext} \[ a + b + c + d + e + f + g + h + i + j + k + l + m + n + o + p ...


12

To suppress the leading dots from the LoF and LoT, you can redefine \@dotsep: \documentclass[aps,amsmath,amssymb,11pt,nofootinbib]{revtex4-1} \usepackage{tikz,graphicx,slashed,stmaryrd,bbold,eepic,pst-all,pstricks-add,multirow,listings} \usepackage{hyperref} \begin{document} \makeatletter \renewcommand\@dotsep{10000} \makeatother \listoffigures ...


11

Since biblatex "reimplements the bibliographic facilities of LaTeX from the ground up, [it] naturally conflicts with all packages modifying the same facilities" (manual, section 1.5.4). Specifically, biblatex is incompatible with natbib. biblatex' natbib option only provides aliases for natbib's citation commands. From a look into the manual of RevTeX 4.1, ...


10

In order to remove the sidebar, use the hyperref setting: pdfpagemode=UseNone In order to restore the regular "Fit page width" zoom view at startup, use: pdfstartview=FitH Combining these gives you \usepackage{hyperref}% http://ctan.org/pkg/hyperref \hypersetup{pdfstartview=FitH,pdfpagemode=UseNone} If you're interested in a 150% start view, you can ...


9

Working with the assumption here that we are simply trying to ignore natbib entirely, all that needs to happen is that the various name clashes need to be dealt with. Setting up a demo where natbib is deliberately loaded before biblatex, it seems that the macros \bibhang, \citename, \bibfont and \Citeauthor need to be undefined. At the same time, it's ...


9

It looks if the revtex bst's are highly customized for for the class file. I have found that the following gives more or less the same output with a standard class \usepackage[sort&compress,numbers]{natbib} \bibliographystyle{apsrev4-1} \usepackage{doi}%<---------- \usepackage{hyperref} It also needs an additional bibtex file with a custom setup ...


8

I have never used revtex but the author's guide explicitly states: Please note the spelling of “acknowledgments.” This is also the full error message LaTeX produces: Class revtex4-1 Warning: Environment acknowledgements is obsolete; Use acknowledgments instead. So replacing acknowledgements by acknowledgments removes the message.


7

The revtex4-1 class uses simple numbers in the headers, relying on the format for distinguishing among the section level: roman number and all caps bold face for sections, letter and boldface for subsections, arabic number and italics for subsubsections. Thus it sets things up so that in references the missing bits are automatically supplied, via the ...


7

If I strip out most of the custom commands and package loading, then this is what I’m left with which still shows the problem: \documentclass{revtex4} \usepackage{amsmath} \usepackage{colortbl} \begin{document} $\begin{bmatrix} 1 & 2 \\ \end{bmatrix}$ \end{document} The problem seems to arise as a conflict between the revtex4 class and the ...


6

The fixme package assumes \@dotsep just expands to a decimal number, while revtex4 expects it to contain a dimension. A quick fix is to provide a redefinition as requested, in a group so the redefinition is not propagated; I use the hooks fixme executes before and after inputting the .lox file. \documentclass{revtex4} \usepackage[draft]{fixme} ...


6

Yes, revtex4 plays some tricks on hyperref. That is, revtex4 redefines the sectional macros that hyperref is tapping into, leading to the "lost \nameref". To fix this, you need the xpatch package and patch the correct sectional macros: \@ssect@ltx and \@sect@ltx, each of which are called depending on whether you use the starred variant (or not) of the ...


5

\documentclass[twocolumn,twoside]{revtex4} \usepackage{lipsum} \makeatletter \newcommand*{\balancecolsandclearpage}{% \close@column@grid \clearpage \twocolumngrid } \makeatother \begin{document} \maketitle \section*{Main Text} \lipsum[1-7] \balancecolsandclearpage \section*{Additional Material} \lipsum[8-10] \end{document}


5

The documentclass revtex4 doesn't provide the using of \include. You can open the aux-file of x_appendix and you will find the command \@setckpt which is defined as \def\@setckpt#1#2{}. You should change the document class.


5

Issue a \phantomsection just before marking the \label. \phantomsection sets a PDF mark for subsequent \labels that the accompanying \ref will jump to (forward or backward). See section 4 Additional user macros of the hyperref documentation. Here is your minimal example showing the location: \documentclass[onecolumn,twoside]{revtex4} \usepackage{xpatch}% ...


5

Class reftex4-1 uses the feature that references can be prefixed using \p@<counter>. You need to reset them for your redefined counters: \renewcommand\thesubsection{\thesection.\Alph{subsection}} \renewcommand\thesubsubsection{\thesubsection.\arabic{subsubsection}} \makeatletter \renewcommand*{\p@subsection}{} \renewcommand*{\p@subsubsection}{} ...


5

revtex4 has an option nofootinbib (presumably this will change all footnotes): \documentclass[nofootinbib]{revtex4} \textheight=2in %just for this example \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @book{book, author = "Arnold Author", title = "Book title", year = "2012" } \end{filecontents} \begin{document} Some text\footnote{With ...


5

\documentclass{article} \def\thesection{\Roman{section}} \def\thesubsection{\Roman{section}.\Roman{subsection}} \def\thesubsubsection{\Roman{section}.\Roman{subsection}.\Roman{subsubsection}} \begin{document} \tableofcontents \section{aaa} \subsection{bbb} \subsubsection{ccc} \end{document}


5

This happens only when the footnotes are inserted in the reference section. The problem is that \langle becomes written as \delimiter "426830A (and similarly for \rangle. Those double quotes confuse the BibTeX parser. There are a few strategies available: Safest. Enclose the math into \unexpanded: \footnote{footnote with math \unexpanded{$ \langle X ...


5

It's not entirely clear what's going on since your description of the problem doesn't state whether the word in question is an argument of an explicit \footnote command or of something else, such as \footcite. At any rate, the problem seems to arise in connection with a citation, however generated. The simplest solution, I think, is to write Schr{\"o}inger. ...


5

As noted in comments your input is mixing old style font and encoding handling with xetex. In particular xltxtra loads fontspec (the usual way to specify fonts with xetex) and that appears to be incompatible with revtex. Your example as posted can not be used but this cut down example generates the same error. \documentclass[aps,pra,12pt]{revtex4-1} ...


5

revtex4-1 (specifically the aps style) does not rely on tocdepth and prints sections, subsections and subsubsections in the table of contents independently on the counter's value. The only way to remove sections level is to redefine the relative command producing the entry in the table of contents so they do nothing. One has to keep in mind that the class ...


4

In revtex4, the metadata for the document (\title, \author and similar commands) should go after \begin{document}. There's no error with \documentclass[aps]{revtex4} \usepackage[spanish]{babel} \begin{document} \title{Title} \author{Myname} \begin{abstract} This is my abstract \end{abstract} \maketitle This is my document \end{document} You should ...


4

You can do this by redefining \NAT@biblabelnum and \NAT@citesuper (revtex4-1 internally uses natbib): \documentclass[a4paper,twocolumn, nofootinbib,superscriptaddress, aps,prb,citeautoscript, 10pt, eqsecnum,notitlepage,showkeys]{revtex4-1} \usepackage{filecontents}% just for the example \usepackage{hyperref} ...


4

This is a clear bug in revtex4-1 or, at least, in its documentation. It should always be possible to type \"{o} or \"o in order to get ö in text, but the problem is that footnotes are translated (wrongly) into BibTeX input for being typeset in the bibliography (the reason why this is done is, to me, very obscure). Remedies: either use the BibTeX ...


4

The \include instruction is made for big chunks of text so as to allow compilation without really inputting the files; it's mostly useful during preparation of large documents. In order to work properly, it must issue a \clearpage command. So it's not really useful for your problem. \documentclass[aps, prl, twocolumn]{revtex4-1} \begin{document} ...


4

For the aipauth4-1 and related bibliography styles, you should be using the 4-1 version of the documentclass, i.e.. revtex4-1 instead of revtex4. These new bibliography styles are one of the main features of the 4-1 release. See revtex4-1 on ctan. Here is a minimal working pair of documents: \documentclass[secnumarabic, graphics,floatfix,nofootinbib, ...


4

Often helps, and here as well: If something surprisingly doesn't work, put it into a box :-) \footnote{footnote with math \mbox{$ \langle X \rangle$}} (Version: if line breaks don't work, use \parbox) If something with BibTeX doesn't work, try putting it into braces: \footnote{footnote with math {$ \langle X \rangle$}} Both ways work here. Simple ...


4

If you look a little further through the log, you'll find it reads Class revtex4 Warning: No Society specified, using generic APS style. ... LaTeX Warning: Unused global option(s): [apl,aps4]. Notice that neither apl nor aps4 are recognised. Changing the input to \documentclass[apl, aps, twocolumn, superscriptaddress]{revtex4} removes the 'No ...


4

It seems that revtex4 uses a definition of \normalsize equal to that of the standard classes, namely, a line spacing of 13.6pt for the 11pt font size option. If you only want to change the line spacing of \normalsize, you may use the etoolbox package to patch this command (replace "13.6" with "13"). If you want to change the line spacing of all font size ...


4

As REVTeX uses natbib, you can use the mechanisms provided by that package to make this change \begin{filecontents}{\jobname.bib} @article{demo, author = "Other, A. N.", journal = "J. Irrep. Res.", year = 2012, pages = "1-10", volume = "200" } \end{filecontents} \documentclass[aps,prl]{revtex4-1} \bibliographystyle{apsrev4-1} ...



Only top voted, non community-wiki answers of a minimum length are eligible