Tag Info

New answers tagged

1

As the \binomor dbinom commands from amsmath have a fixed size which may not be enough (this is the case here if the fraction inside \binom is set in displaystyle), I use the DeclarePairedDelimiterX command, from mathtools to define a \Binom command, with a star version that adds a pair of implicit \left … \right around the parentheses. You also may ...


3

I would like to suggest you make the following changes: Instead of an array environment, use an align environment. Increase the vertical separation between the rows a bit. Don't use the {{... \choose ...}} "Plain-TeX" syntax. Instead, use the amsmath macro \binom{...}{...}. Reduce the space between the binomial term and the following {-1} exponent, and ...


1

Or like this: \documentclass{article} \usepackage{amsmath} \begin{document} \begin{equation} \begin{split} w_{\frac{mn}{m+1}-\rho} & = m\left(\dfrac{n-2}{1+\varepsilon_1}\right) m^{-\frac{mn}{m+1}+\rho} {{n-2}\choose{\frac{mn}{m+1}-\rho}}^{-1} \prod_{i=1}^{\frac{mn}{m+1}-\rho} (1 + \varepsilon_i) \\ ...


1

How about this? You actually do not use the functions provided by array, so I'd suggest you use align* from the amsmath package. I use \\[<dimension>] to add some space to a line break, e.g. \\[5pt]. Use \binom{a}{b} instead of a choose b. And use \left( ... \right) to have parentheses adapt automatically. \documentclass{article} ...


2

Package amsmath provides lots of macros and environments for mathematical typesetting. Environment align can be used instead of an additional array for aligning (with \nonumber one of the equation numbers can be suppressed if necessary). Alternatively, environment aligned can be used inside equation. With the proper environments, the math is set in ...


0

You say you want a bit of text with less width than the rest of the document. If that's all you want, I'd suggest you try the addmargin environment: \begin{addmargin}[4em]{1em} foo bar \end{addmargin} Usage is \begin{addmargin}[<left indentation>]{<indentation>}. There is a starred variant addmargin* where the optional parameter stands for the ...


2

We can use \mbox{} in the beging of the minipage \documentclass{article} \begin{document} \noindent \begin{minipage}{0.9\linewidth} \mbox{} \paragraph{A} Blah \paragraph{B} Blah \paragraph{C} Blah \newline \begin{minipage}[t]{0.5\linewidth} BLAH BLAH \end{minipage} \newline More blah \paragraph{D} Blah \paragraph{E} Blah \end{minipage} ...


1

\nompreamble controls what goes between the main nomenclature title and the nomenclature itself. \nomgroup is a one-parameter macro that controls what goes at the start of each subgroup (section 4 and 5.1 of the nomencl documentation). As an example: \documentclass{article} \usepackage{nomencl} \usepackage{ifthen} ...


4

A split environment cannot be broken across pages: for instance, when it appears in a numbered display, it gets just one equation number. The breakable display environments are gather, align, alignat and flalign. In order to break one of these, place \displaybreak before the \\ that ends the line. In order to emulate breaking split, use align and \notag in ...


2

I have found a way to do this while not throwing away the \left[ command, thank to this answer. It goes like this (perhaps my code is too complicated and can be simplified): \begin{align} & \hphantom{ \left[ \vphantom{\dfrac{ABCD}{EFGH}} \right.\kern\nulldelimiterspace } x_\alpha(s) x_\alpha(t) \\ & \left[ x_\alpha(s), \dfrac{ABCD}{EFGH}\right] ...


1

One more solution: \begin{align} x_\alpha(s) & x_\alpha(t) \\ \left[x_\alpha(s)\right.&,\left.x_\beta(t) \right] \end{align}


5

\documentclass[12pt]{article} \usepackage{amsmath} \begin{document} \begin{align} & \left. x_\alpha(s) x_\alpha(t)\right . \\ & \left[ x_\alpha(s), x_\beta(t)\right] \end{align} \end{document} Just putting a virtual bracket (\left.) will do the trick, because \left. and \left[ should have the same spacing. If you like the following alignment, ...


0

The word Through is unbreakable, so you can neglect the warning. There are also two typos in your bibliography: no space after 17, in [8] and Space after Prentice- in [9].


0

There are some conceptual problems with the code you've posted: Nesting sideways, landscape, and sidewaysfigure environments is bound to give you grief. A single sidewaysfigure environment suffices. You're trying to set up a tabular environment whose total width grossly exceeds the width of the (rotated) textblock. (For instance, 0.45*3=1.35>>1 -- and ...


0

I can't tell you exactly what is wrong without a proper example which can be compiled to reproduce the problem. I experimented, but failed to reproduce the issue you described. Even after completing your code to create a minimal document, I got errors: \multirow{}{}{} requires 3 arguments - not 1 nobody can compile a document which requires files they do ...


2

It's a typical problem due to an unexpected spurious space. The longer line ends almost at the boundary of the available space and there is a space (due to the end-of-line in the input) between the last $ and \vspace. Thus the paragraph consists of two lines, the second of which only contains \vspace. When \vspace is issued in LR-mode (that is, when ...


3

\documentclass[11pt]{beamer} \usepackage[T1]{fontenc} \usepackage{tgpagella} \usetheme{Warsaw} \begin{document} \begin{frame}{Proof 2: Symmetry Preserving Maps} \begin{itemize}[<+->]\setlength\itemsep{3ex} \item $\mathbb{Z}_2$ symmetry on $\mathbb{R}$: $x\longleftrightarrow -x$ \item $\mathbb{Z}_2$ symmetry on ...


1

\documentclass[11pt]{beamer} \usetheme{Warsaw} \usepackage{graphicx} \usepackage{lmodern} \usepackage{enumitem} \setitemize{label=\usebeamerfont*{itemize item}% \usebeamercolor[fg]{itemize item} \usebeamertemplate{itemize item}} \begin{document} \begin{frame}{Proof 2: Symmetry Preserving Maps} \begin{itemize}[itemsep=.5cm] \item $\mathbb{Z}_2$ ...


0

Make a copy of apalike.bst and name it something useful like apalike-nospace.bst. Save this in your local texmf folder in texmf/bib/bst. Then change the format.names function in the .bst file. The crucial change is in the following string in the function which tells bibtex how to format the name pieces: "{vv~}{ll}{, jj}{, f.}" This needs to be changed ...


3

A minipage does explicitly reset the list depth, see latex.ltx for this, in line 4886 following code can be found: \let\@listdepth\@mplistdepth \@mplistdepth\z@ The important thing is \@mplistdepth\z@,meaning zero list depth -- The inner enumerate environment behaves like being on the first level again, using the \itemsep value 'appropiate' for this ...


2

Don't know exactly why this fixes the problem, but it seems to. ;-) \documentclass{article} \usepackage{mtpro2} \usepackage{mathtools} \newcommand{\SQRTFIX}[2][ ]{{\hphantom{\scriptscriptstyle{#1}}}\SQRT[\mathllap{#1}]{#2}} \begin{document} \[ \sqrt[100]{1000000} = 1000 \quad \sqrt[3]{1000000} = 100 \] \[ \SQRT[100]{1000000} = 1000 \quad ...


1

Perhaps you might consider this simpler alternative. You can customize the list's appearance using the enumitem package if you like. \documentclass{article} \newcommand{\Job}[3]{% \textbf{#1}, #2\newline #3% } \begin{document} \begin{itemize} \item[2013--] \Job{Rice University}{Houston, TX}{Associate Professor} \item[2000--2012] \Job{Harvard ...


2

I used \par not \\ (usually), used \textbf not \bf (which shouldn't be used in latex) and added a missing \par in the scope of \raggedright (otherwise it does nothing) and use tabular not tabular* (tabular* can do nothing unless you add stretch glue between the columns). \documentclass{article} \usepackage{calc} \setlength{\parindent}{0pt} ...


0

If you're interested in manipulating the letter content in a more comfortable way, I would suggest foregoing the lettre document class and roll your own letter using article. It's super-easy, since you don't have to specify so manu parameters that don't get placed where you want them... you just specify what you want, where you want it: ...


4

No, they're not the same. When you use \hspace*{1cm} (or whatever length), LaTeX transforms this into \@hspacer{1cm} which in turn becomes \vrule \@width \z@ \nobreak \hskip #1\hskip \z@skip as described in my answer to the question you linked. The rule is as high and deep as the horizontal box that eventually it is typeset in. On the contrary, \strut ...


9

\hspace* is also valid at the beginning of a line: \documentclass{article} \usepackage[a6paper]{geometry} \parindent=0pt \begin{document} \hrulefill\sloppy This is a sentence which makes no sense. \hspace{3cm} And so on \ldots This is a sentence which makes no sense. \hspace*{3cm} And so on \ldots This is a sentence which makes no sense. ...


1

I'm gonnna add my own solution based on that by Mico. I dug into the \newcommand syntax and created some aliases in the preamble that makes my equations look like I want them and makes the equation code more compact. This is a working example: \documentclass[12pt]{article} \usepackage{amsmath} % My commands! % kerning: \newcommand{\mk}[1]{\mkern-#1mu} % ...


2

As LaRiFaRi suggested \newcommand*{\arraystretch}{0} supresses space between rows and @{} between columns. \documentclass{article} \usepackage{graphicx} \begin{document} \begin{figure} \centering \renewcommand*{\arraystretch}{0} \begin{tabular}{*{3}{@{}c}@{}} \includegraphics[scale=0.2]{example-image} & \includegraphics[scale=0.2]{example-image} ...


1

I do not know how to do this for the case of several aligns in one figure. I have never seen anyone using display math in a figure and I do not get the value of doing so. So I just give the solution for getting rid of \abovedisplayskip in figures also this is not what you are looking for. % arara: pdflatex \documentclass{article} \usepackage{amsmath} ...


1

The spacing issues you raise may be related more to the Greek letters in use (Gamma, Lambda) than to the occurrence of the "prime" characters. For extra-fine control of math spacing, consider using \mkern with positive or negative amounts of mu instead of \, (positive thinspace, equivalent to \mkern3mu when in math mode) or \! (negative thinspace, ...


1

You could use trim axis left and trim axis right as options for the tikzpicture and additionally border={45pt 0pt} as option for the standalone class. The first value inside the class option is the space added to the left and the right border of resulting bounding box of the image. It must be large enough to show the y-label but it could be also larger. In ...


4

By default, set in /tex/plain/base/plain.tex (or latex.ltx), the glue value is set (equivalently) to \baselineskip=12pt. i.e. it has no stretch or shrink, the same goes for \lineskip=1pt. So, with the defaults, intra-baseline distances can't flex in the way described. Spacing can look uneven if the boxes get too close together and \lineskiplimit is ...


1

The manual also says Note that the contents of statements are typeset in math mode. Therefore, non-math mode text must be enclosed in an \mbox{}. By using \mbox or \text (requires amsmath) for the text parts, it works. The manual is a bit wrong in the first examples actually, here is a code excerpt from pseudocode.tex, used to create the manual: ...


1

The tabstackengine package has a \fixTABwidth{T} macro to force all columns to be equal width (based on the widest column). In addition to that, I just set the intercolumn gap with \setstacktabbedgap{} and the vertical baselineskip with \setstackgap{L}{}, to achieve whatever spacing is preferred, using a \parenMatrixstack macro. \documentclass{article} ...


4

In addition to the vertical space between the final two rows of your matrix being smaller than that between other rows, the horizontal space between the first two columns (and between the final two columns) is smaller than that between the other columns. The first issue arises because the height of the \ddots glyph is -- assuming you're using the Computer ...


3

The problem is, as cfr mentions in her answer, that in calculating some elements (in your case, the bisectors and even the inscribed circle) the bounding box gets enlarged. ANother way to prevent the problem, instead of interrupting the bounding box, is to use the native \tkzClip command. Notice also that instead of manual \draws for the heights you can ...


1

Another potential solution, the sledgehammer method, so to say, would be to insert an \vspace*{-3.2cm} between the \end{tikzpicture} and \caption{Inscribed circle.}. With this, you can remove the space, but it does only address the symptom of the problem but not the cause.


1

I think that drawing the bisectors increases the bounding box. You can avoid this by interrupting the box while drawing them. \documentclass{article} \usepackage{amsmath} \usepackage{tikz} \usepackage{tkz-euclide} \usetkzobj{all} \begin{document} \begin{figure} \centering \begin{tikzpicture} \tkzDefPoint(0,0){A} \tkzDefPoint(5,0){B} ...


0

Barbara Beeton explains in a comment that this behaviour is intended to give good-looking fractions in typesetting situations where multiple fractions are near to one another, by setting the baselines of text in the numerator and denominator such that the various baselines of nearby fractions are lined up (even though they might contain a variety of ...


0

There are two great answers here that both do the job, but neither directly answered the question that I asked. I'm therefore adding this answer (my eventual solution) in case anyone comes across the question with a different use-case. I found this page: http://www-h.eng.cam.ac.uk/help/tpl/textprocessing/squeeze.html It is a very approachable introduction ...


5

Regarding the second question: The \@ isn't needed with words ending with lowercase letters. LaTeX assumes then anyway that the period is a end of sentence marker. \documentclass{article} \begin{document} I am new to LateX\@. And you? I am new to LateX. And you? I am new to Latex. And you? I am new to Latex.\ And you? \end{document}


1

The approach of the other answer is certainly better, but heres what I came up with: You want to replace periods, so do just that \documentclass{article} \usepackage{xstring} \begin{document} \section{original tex} %one paragraph from lipsum package Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Ut purus elit, %cut that here \section{with ...


4

To add bullets, you can make the period an active character and define a macro that adds the bullets: \documentclass{article} \begin{document} \begingroup % EDIT \let\origdot=. \catcode`.=\active \def.{\origdot\ensuremath{\bullet}} Hello. I am a sentence. Mr.\@ Black knows too little. \endgroup % EDIT \end{document} This results in: ...


0

This steals directly from David's answer at Push long words in a new line \documentclass{book} \usepackage{lipsum} \newcommand\lword[1]{\leavevmode\nobreak\hskip0pt plus\linewidth\penalty50\hskip0pt plus-\linewidth\nobreak\textbf{#1}} \begin{document} This text shows that non-breaking spaces are not working properly: \lword{``a:a~b:b~c:d~e:e~f:f~g:h''.} ...


3

Spaces (including a single carriage return) are gobbled under math mode. From the TeX Book, Chapter 18: Fine Points of Mathematics Typing (p 166): [consider] $$ F_n = F_{n-1} + F_{n-2}, \qquad n \ge 2. $$ It is perhaps worth reiterating that TeX ignores all the spaces in math mode (except, of course, the space after \qquad, which is needed ...


1

the only way i know to do this globally without checking to see what words are extending into the margins is to use \sloppy, and you really don't want to do that. the resulting interword spacing is often terrible, and it can change previously "good" paragraphs. the next easiest method is to look into the log file for overfull hbox messages, determine what ...


2

It depends on your use case, but there are packages for this kind of task. E.g., paracol.sty (asymmetric column widths to show the effect):


1

How about including those culprit words into a hyphenation list? Look here: http://www.forkosh.com/latex/ltx-244.html Have you tried adding \hyphenation{...} to your preamble?


2

Maybe it's not very professional, but I would use \phantom{what you don't want to see} for the first page and put inside what's added on the second one.


0

I hope this works: \documentclass[12pt]{report} \usepackage[utf8]{inputenc} \usepackage{blindtext} % enters dummy text in document (removable) %\usepackage[titles]{tocloft} % use tocloft in this way % other wise it interferes with titles settings \title{ {Learning Report Class}\\ {\large Institute of Self Learning }\\ } \author{J Kumar} \date{\today} ...



Top 50 recent answers are included