Tag Info

Hot answers tagged

5

Update In this updated version I still used \only instead of \visible, and used the visible on style to gratly simplify the code; with this new approach the images won't "jump" since most of the figure remains constant (overlayarea could still be used, but I think it's not required anymore). The subfigure counter has to be manually updated: ...


5

The remark is that it is not good to use caption and subcaption packages in beamer as they are not compatible fully (I removed them). You have also used [b] in your subfigure hence every thing is bottom aligned. It is better to use the width instead of scale in \includegraphics Here is your modified code: \documentclass{beamer} \begin{document} ...


3

So, I took a previous answer of mine and made it more serious by using captions rather than just minipage text. The I took your image saved it as molecule-orig.png and used imagemagic convert: convert molecule-orig.png -transparent white molecule.png So the background in molecule.png is transparent and doesn't obscure the car. \documentclass{article} ...


3

acsmall.cls and used images downloaded here: http://www.acm.org/publications/latex_style/v2-acmsmall.zip The acmsmall class defines a \subcaption command, so you can use minipages instead of subfigures for your purpose. MWE: \documentclass[prodmode,acmtecs]{acmsmall} \usepackage{graphicx} \begin{document} \begin{figure} ...


3

Update The subfloatrowsep, floatrowsep keys give you control on the horizontal separation between subfloats (floats) when using floatrow; however, simply using something like \thisfloatsetup{subfloatrowsep=qquad} in your current code will not produce the desired result since you are using \subfloat (from the subfig package). The solution is not to ...


2

The easiest solution in these cases is to add \protect in front of the usual suspects; \subref is one of them because it has a *-variant. \documentclass{article} \usepackage{graphicx} \usepackage{subfig} \begin{document} \begin{figure}[!ht] \centering \subfloat[]{% \label{subfig1}% \includegraphics[width=.4\linewidth]{fig1.pdf}% }% \qquad ...


2

The problem is that the first image is wider than \textwidth so it protrudes into the right margin. To prevent this, one option is to scale down your tikzpictures (I used scale=0.85). Also, notice that you had some spurious blank spaces that I killed in my code using %: \documentclass{article} \usepackage{tikz} \usepackage{amsmath} \usepackage{subfig} ...


2

You need to make the pictures appear to be of the same size to tikz. This can be done by setting the bounding box completely, or partially via trim left and trim right. \documentclass{article} \usepackage{tikz} \usepackage{amsmath} \usepackage{subfig} \usepackage{pgfplots} \usetikzlibrary{positioning} \pgfplotsset{compat=1.12} \begin{document} ...


2

You can use adjustbox with its export option which will make keys like max width, available inside \includegraphics. Also, it offers keys width, height etc to be used for adjustbox environment. Here is a sample. \documentclass{article} \usepackage[export]{adjustbox} \usepackage{showframe} %% for demo \setkeys{Gin}{height=2cm} \begin{document} \noindent ...


2

A better hack might be to use \makeatletter \renewcommand*{\m@mscapopboxes}{% \m@mcalcscapraise% \usebox{\m@mscap@fbox}%\m@mscapcheckside \ifscapmargleft% \rlap{\kern-\m@mscaplkern% \raisebox{\m@mscapraise}{\smash[b]{\usebox{\m@mscap@capbox}}}% }% \else% \rlap{\kern\sidecapsep% ...


1

The flashmovie package is not well programmed in that it introduces a lot of spurious space which prevents the inserted video boxes from being properly aligned. Consider using the media9 package. The lower right video example uses the same video player component player_flv_maxi.swf as used by the flashmovie package. Here, cube.mp4 from the media9 CTAN ...


1

Technically you can adjust sub-caption numbering in whichever way you like. If the structure is too fine-tuned to be described in an automated way, adjust them manually: \documentclass{article} \usepackage{graphicx,subcaption} \begin{document} \begin{figure} \centering \renewcommand{\thesubfigure}{ai} ...


1

Quick and dirty trick, add the following to your preamble: \makeatletter \renewcommand{\endsidecaption}{\m@mscapend@fbox\refstepcounter\@captype\m@mscaplabel% \begin{lrbox}{\m@mscap@capbox}% \raisebox{0pt}[\height][0pt]{% This line is added, to remove the depth of the box \begin{minipage}[c]{\sidecapwidth}% ...


1

I finally solve my problem, here you can find the result code using the cryptic documentation of memoir :) Correction of font size : \captiontitlefont{\normalfont}% title font \precaption{\raggedright}% for Caption N \captiondelim{\newline}% newline* \captionstyle{\raggedright}% for title \setlength{\belowcaptionskip}{\onelineskip} Correction of the ...


1

Try removing any imports of the subfigure and subfig packages; the former is deprecated, and the latter certainly should not be used at the same time as the former. Replacing them with the subcaption package should accomplish what you want (see, for example, here). Indeed, I don't think the subfigure package will accept the arguments you're passing to it, ...


1

You can achieve this by using \par (or a blank line) or \\. A little example: \documentclass{article} \usepackage{subfig} \usepackage{graphicx} \begin{document} \begin{figure} \centering \subfloat[][a\label{test1}]{\includegraphics[scale=0.4]{example-image-a}}\par \subfloat[][b\label{test2}]{\includegraphics[scale=0.4]{example-image-b}}\qquad ...


1

This gives the correct output: \documentclass{article} \usepackage{graphicx,subfig} \usepackage[heightadjust=all,valign=c]{floatrow} \usepackage{fr-subfig} \begin{document} \thisfloatsetup{subfloatrowsep=qquad} \begin{figure}[!htbp] \captionsetup[subfigure]{justification=centering} \ffigbox{% \begin{subfloatrow}[3]% ...



Only top voted, non community-wiki answers of a minimum length are eligible