Tag Info

Hot answers tagged

8

Use a multicolumn \documentclass{article} \begin{document} \begin{table} \caption{Model selection metrics} \begin{center} \begin{tabular}{l c c c c c} \hline {} & {\itshape BIC} & {\itshape AIC} & {\itshape CAIC} & {\itshape HQIC} & {\itshape Correlation}\\ \hline \hline Linear Regression & 138,210 & 138,014 & 138,236 & ...


8

Here you go. I suppose that this was the intention of the table. I changed the layout completely since I didn't find out the original table quite visually appealing. I hope you'll like it. Some comments: It looks like one table, not like two, so I made it one table. Please do not use \large inappropriately, there's no need for it in a table. \multirow ...


7

You want to use longtable: \documentclass{article} \usepackage{csvsimple,longtable,booktabs} \begin{document} \csvreader[ longtable=lrrrr, table head=\toprule\bfseries Item &\bfseries Alpha category (\%) \\\midrule, late after line=\\, late after last line=\\\bottomrule, before reading={\catcode`\#=12},after reading={\catcode`\#=6} ...


6

As Paul Gessler has commented, you can put every thing in one tabular environment with two p columns each having a width of >{\raggedright\arraybackslash}p{\dimexpr0.5\textwidth-2\tabcolsep-2\arrayrulewidth\relax} minipages are not needed any way. You can further use enumitem package and its resume option to continue numbering. I have also aligned ...


6

While skpblack has shown you how to do it as you wanted, this is an attempt to show you other ways of doing it. I have used threeparttable package which provides the tablenotes facility for notes. I have also used booktabs package for its \toprule etc over \hline. \documentclass{article} \usepackage{booktabs} \usepackage{threeparttable} \begin{document} ...


5

Your code has quite a few problems, any one of which makes the MWE uncompilable. As far as I can tell, none of them are related to the fact you mention in the title of the posting, which is that the table groups two pairs of columns using \multicolumn. The first instruction should be \documentclass, not \document class The packages siunitx and booktabs ...


5

You need to use a longtable rather than a tabular environment. If you longtable's native syntax, it's straightforward to retain full control over items such as header and footer material on every page. However, as @egreg's parallel answer shows, it's possible to do so using csvreader's syntax as well. \documentclass{article} ...


5

You can box the label and adjust it so that the bottom rule overlaps the first \hline. \documentclass[a4paper]{article} \newcommand{\tablelabel}[1]{% \multicolumn{1}{@{}l@{}}{% \setlength{\fboxsep}{0pt}% \setlength{\fboxrule}{\arrayrulewidth}% \hspace{-.5\arrayrulewidth}% \fbox{\hspace{\tabcolsep}\strut#1\hspace{\tabcolsep}}% ...


5

You are padding too much data in the table. Anyway, here is an attempt. \documentclass{article} \usepackage{booktabs,multirow} \usepackage{siunitx} \sisetup{detect-mode, group-digits = false, input-symbols = ( ) } \newcommand{\level}[1]{% \multirow{2}{*}{% \begin{tabular}{@{}>{\raggedright\arraybackslash}p{0.2\textwidth}@{}} ...


5

If you really don't care about how the output looks, you can use \clap, which is a variant of \llap and \rlap defined in this TUGboat article to be: \def\clap#1{\hbox to 0pt{\hss#1\hss}} Put that definition in the preamble (or load the mathtools package which also defines it) and then enclose any text to be overlapped like so: \clap{Property Text 1 ...


4

Well I don't understand exactly what you what to do with the table, or if you are understanding well how to build a table in LaTeX. According to what I understood from your table, and from your MWE, I would write it in this way \documentclass{article} \usepackage{siunitx,booktabs,caption} \newcommand{\splitcell}[1]{% ...


4

Here's my proposal, with booktabs, siunitx and no vertical rule: \documentclass{article} \usepackage{siunitx,booktabs,caption} \newcommand{\splitcell}[1]{% \begin{tabular}{@{}c@{}}\strut#1\strut\end{tabular}% } \begin{document} \begin{table}[htp] \centering \caption{The table caption} \begin{tabular}{ S[table-format=2.0] S[table-format=1.0] ...


4

The following answer isn't about the main topic of your posting, as it has already been answered by @skpblack. Instead, it's about a different aspect of typesetting a table with numbers in a typographically pleasing way: Which bold font face to use? When typesetting columns of numerical data, in which some numbers are to be rendered in the regular-weight ...


3

You haven't provided your requirements for quite a few design aspects, so I have to make some assumptions. In particular, in the examples below I'll assume that the two side-by-side figures should jointly span the entire width of the text block. You also haven't indicated whether or not the side-by-side figures should be able to float, in the LaTeX sense ...


3

Almost like @tohecz, but with the siunitx package: \documentclass{article} \usepackage{array,booktabs} \usepackage{mathtools} \providecommand\Midrule{\midrule[\heavyrulewidth]} \usepackage{siunitx} \begin{document} \sisetup{table-format=1.3, table-space-text-pre=(, table-space-text-post =\textsuperscript{***}} \begin{tabular}{l*{4}{S[}} \toprule ...


3

Is it like this? \documentclass[a4paper]{article} \usepackage{tikz} \usetikzlibrary{calc, positioning} \begin{document} \begin{tikzpicture} \node[anchor=north west,inner sep=0pt,outer sep=0pt] (A) { \begin{tabular}{|l|l|l|||l|} \hline $\texttt{o\_orderkey}$ & $\texttt{o\_orderdate}$ & $\texttt{o\_custkey}$ & rest \\ \hline 0 & 1992-01-01 ...


3

(migrated the following answer from a posting by the same OP, see organizing a table, that was later deemed to be a duplicate) Here's a solution that uses the tabularx package and a modified form of that package's X column type to typeset the six multiline header cells in the second row of the header. A happy side effect of using tabularx in this way is ...


3

Just to show another alternative with pgfplotstable. \documentclass[a4paper]{article} \usepackage{pgfplotstable} \usepackage{filecontents} \usepackage{longtable,siunitx} \begin{filecontents*}{data.csv} Time ( s ),Voltage ( V ),Sound Level ( dBA ),Frequency 0,0.03,56,183.3333333 0.5,0.04,56,366.6666667 1,0.03,56,550 1.5,0.03,56,733.3333333 ...


3

\intextsep deals with the gap between a float within the text body and the rest of the text around it (see Remove space after figure and before text). Since you're using only a tabular, there is no floating behaviour, hence the non-response from setting \intextsep. If you wish to add some space above/below the non-floating tabular, do so using ...


2

You forgot to specify the width for subtable. It should be \begin{subtable}{\textwidth} %% change \textwidth suitably Changing this in your code solves the issue. \documentclass{article} \usepackage{subcaption} \usepackage{booktabs} \begin{document} %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% \begin{table} ...


2

You can also do it with just two rows. Add some suitable space after each row. \documentclass{article} \usepackage{multirow, } \begin{document} \begin{table}[htb] \centering \begin{tabular}{|c|c|c|c|c|c|} \hline & \multirow{2}{*} {\begin{tabular}{@{}c@{}} 1, 2, 3, 4, 5, \\ 6, 7, 8, 9, 10, \\ 11, 12, 13, 14, 15, \\ 16, 17, 18, ...


2

Here's a solution that uses the dcolumn package and its d column type instead of the siunitx package and its S column type. The main advantage I see to using the dcolumn package is that it simplifies setting the single, double and triple asterisks in superscript position; doing so is not only stylistically pleasant but also serves to economize on much-needed ...


2

Note that the word "Computer" takes up almost as much space as does the word "Television". Rather than fiddle with one column width at a time in an effort to make the table look OK, I'd use the tabularx environment to assure that all five columns have the same width. \documentclass{beamer} \usepackage{tabularx} % for 'tabularx' environment ...


2

This question is not specific to beamer, so I'll put a general answer first and then a working example using beamer. To wrap text in a table column, here are two simple options: Use tabular and specify one of the columns as a paragraph with p{<width>}. You must specify the width of that column, while the other columns will fit the width of the ...


2

Option-1: You can add the space after each \\ like \\[2mm] at every row end. \documentclass{article} \usepackage{array} %% habitual addition \begin{document} \begin{tabular}{ l | c c c } \textbf{Programming Languages} & Java & C & Python \\[2mm] %%<-- note [2mm] here \textbf{Web Development} & Javascript & jQuery & ...


2

I've managed to make the code compilable but there are still some things that could be improved. \documentclass{book} \usepackage{tabularx} \usepackage{booktabs} \usepackage{thesis_style} \newcommand*\something{$\delta^{u}gil$} \begin{document} Text before the table. \begin{table}[h] \centering \begin{threeparttable} \begin{tabularx}{\textwidth}{XXXX} ...


2

It looks like you've encountered a conflict or incompatiblity between the \needspace macro and the longtable environment. The manual of the needspace package notes that the space reserved by \needspace is "approximate". To get exact amounts of reserved space, use either \Needspace or \Needspace*. Interestingly, if one replaces \needspace{2\baselineskip} ...


2

Another solution, using xcolor, colortbl, hhline and makecell: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[TS1,T1]{fontenc} \usepackage{lmodern} \usepackage[table, x11names, svgnames]{xcolor} \usepackage{colortbl} \colorlet{myblue}{SteelBlue3} \usepackage{amsmath} \DeclareMathOperator\re{\textsf{Re}} \usepackage{array, hhline, caption} ...


2

You are abusing \multirow anyway, hence do it once more ;-). \documentclass[a4paper,fontsize=12pt,a4paper,DIV=10,BCOR=10mm,twoside,titlepage=false,openany,pagesize]{scrbook} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[english]{babel} \usepackage{blindtext} \setkomafont{disposition}{\normalfont\bfseries} \usepackage{graphicx} ...


2

If I edit the code according to @David Carlisle's comment, everything seems fine: \documentclass{standalone} \usepackage{booktabs} \begin{document} \begin{tabular}{ c c c c c c} \toprule ‎j/i & 1:Tumor & 2:Envir & 3:Leuk & 4:Lymph & 5:Macroph \\ \midrule Tumor & 0 & 1 ‎& \(‎\pm1\) & ...



Only top voted, non community-wiki answers of a minimum length are eligible