Tag Info

New answers tagged

1

I had success at opening your document with Word 2010. First of all, I converted document to odt format. Because you don't have mk4ht command available, you need to use following htlatex call: htlatex test.tex "xhtml,ooffice" "ooffice/! -cmozhtf" "-cooxtpipes -coo" all these parameters are necessary, they are used in postprocessing of the xml file with ...


1

TeX4ht does work under MiKTeX 2.9 for Windows 7, although equations are often converted into bitmap pictures rather than MathML, unless the option "html,mathml" is used with the htlatex command. Here's what I did: Installed MiKTeX 2.9 with both miktex-tex4ht-bin-2.9 and miktex-tex4ht-base-2.9 installed with the package manager in administrator mode, on ...


4

This is really just a css issue. Stylesheets produced by tex4ht are pretty plain and basic, which is a good thing, because you can easily modify the appearance of things to your needs. By default, content generated by tex4ht is sized to fill whole page width. This is on the one hand wrong from typographical and usability points of view, as long lines are ...


5

Images are converted by t4ht command, which has -p option for disable the conversion. Options for t4ht are passed as fourth parameter for htlatex: htlatex filename "" "" " -p" you need to use "" for second and third parameters, when you don't use any options for tex4ht.sty and tex4ht command.


2

I think you will find many issues in tex4ht support for beamer, because it is really complex package which redefines many commands, which is what tex4ht do as well. \includegraphics is patched by both beamer and tex4ht, which creates a conflict. For easy fix of this issue, you may define custom command which will use \includegraphics with normal LaTeX and ...


5

I've created simple macro for calculating em value, you just need to divide the dimension by fontsize: % default font size \let\emwidth\f@size % convert pt to rem \newcommand\CalcRem[1]{\strip@pt\dimexpr(#1)/\emwidth} \emwidth is set to be the fontsize, parameter for \CalcRem is dimension, but it may be also an expression. \strip@pt is used to output ...


4

Colors are supported by tex4ht but there are two points: \color command isn't supported: The \Verb!\color{red}! instruction might be problematic since it does not on its own determine the extent of the text to be colored. As a result, its effect can cross logical boundaries. That is against the philosophy of markup languages in general and of XML ...


3

There is macro \:TOC in support .4ht file for each documentclass: \edef\:TOC{ \noexpand\ifx [\noexpand\:temp \noexpand\expandafter\noexpand\:TableOfContents \noexpand\else \noexpand\Auto:ent{\ifnum \c@tocdepth >-2 part,\fi \expandafter\ifx \csname @chapter\endcsname\relax \ifnum \c@tocdepth >\z@ section,\fi \else \ifnum ...


1

first option in htlatex's second parameter must be either name of custom config file, or html or xhtml. default ishtml, which is used if you omit the parameter. correct option for inline footnotes isfn-in`. so your command line call should be: htlatex main.tex "xhtml,fn-in"


1

This is little bit complicated, because minipage is not usual environment, but system of several macros dealing with optional parameters. This is modified cfg file: \Preamble{html} \Configure{HtmlPar} {\EndP\Tg<p>} {\EndP\Tg<p>} {\HCode{</p>\Hnewline}} {\HCode{</p>\Hnewline}} \makeatletter % to strip fraction from \textwidth ...


2

Try pic-align option: htlatex sample "xhtml, pic-align" for more available options see CVR's blog, more similar options for pictorial math exist.


0

Since htlatex seems to generate a DVI first, the following answer helped me: Cannot determine size of graphic So for setting the displayed size of a 530x260 JPG image in HTML, I did: \includegraphics[width=0.5\textwidth,natwidth=530,natheight=260]{image.jpg}


1

Use \fbox but include the text in a minipage. The following compiles Ok with tex4ht and produces the required frame around the text. The options for minipage can be adjusted as needed. \documentclass{article}% \begin{document} \fbox{ \begin{minipage}[t]{\textwidth} line 1 line 2 line 3 \end{minipage} } \end{document}


0

Bad news: The message is the result of a bug. EDIT: As Ulrike writes today (Juli 31, 2014), the bug in tex4ht has not been removed yet. Good news: You simply could tell tex4ht to go on. Just type "R" (or was it Ctrl-R?), and the compilation will go on.



Top 50 recent answers are included