Tag Info

Hot answers tagged

12

If I understood your question correctly, you probably have a Java project with a .tex file somewhere. Something like the following image: If we save our document, TeXlipse is configured to run the TeX builder for us. Saving the document with CTRL + S will give us the following files in my doc/ subfolder: The default setup is to rely on latex and .dvi. ...


8

I spent some time fiddling with this, and finally made it work. The instructions should be platform-independent, but for reference, this is on Eclipse 3.7.2/Texlipse 1.5.0/Win7 x64/MikTeX 2.9. I opted out of using the makeglossaries script since Perl is not usually found on Windows systems, and I had some issues with the script when the directories of the ...


5

You can configure TeXlipse to use a custom script through the following steps: Method 1: Script as part of the build process This method will include the script as part of the build process, that is, you need to tell TeXlipse to build your project via Ctrl + B, then your script will be executed. Go to Project > Properties: Select the Builders tab ...


5

There are very few fonts which cover all languages (let alone mathematics; see threads at typophile and stackoverflow), but Everson Mono seems to do what you want, although it'll cost you 25 euros.


5

You should enable a "Build partially" check-box in "Latex" menu. Here is exempt from TeXlipse FAQ: Why cannot I open an arbitrary TeX-file and compile it? TeXlipse or more generally Eclipse needs a project where your files are located. If you have many small files, e.g. letters, just create a project called e.g. "misc." and add your small ...


5

This is what I get compiling the following file with XeLaTeX: \documentclass{article} \usepackage{fontspec} \setmainfont{Pothana2000} \usepackage{polyglossia} \setmainlanguage{telugu} \begin{document} చేయి అనగా మానవులు, చింపాంజీలు, కోతులు మరియు లెమూర్లకు గల శరీరభాగమునకు వేళ్లు కలబాహ్యంగము. కోలా చేతికి ఎదురెదురుగా వున్న రెండు బొటనవ్రేళ్లు వుంటాయి కాబట్టి ...


4

From the screen shot, it appears as if the warning is displayed when you have a subfile open, not when compiling the main file. So, looking at this file alone, which is itself not compilable, there is a \subsection without a parent \section. As I mentioned in the comments, the following: test.tex: \documentclass{article} \begin{document} \subsection{foo} ...


4

you need an OpenType or TrueType font which supprts that language, eg Code2000. Then the following works: \documentclass{article} \usepackage{fontspec} \setmainfont{Code2000} \begin{document} తెలుగు \end{document} You have to run the example with xelatex or alternatively with lualatex; both are installed with every TeX distribution. Code2000 is ...


3

I found a solution using makeglossaries and keeping the PDF synced with PDF4Eclipse. This solution is based on this post Install Perl Make sure you have the makeglossaries.exe in your your tex distribution bin folder Make sure that you can call makeglossaries from the command line directly. $> makeglossaries makeglossaries: Need exactly one file ...


3

You have a different option now: just add % arara: pdflatex: {synctex: yes, action: nonstopmode} % arara: makeindex % arara: nomencl % arara: bibtex % arara: pdflatex at the beginning of your LaTeX file (say main.tex) and change the .bat file into @echo off arara main If you have an uptodate TeX Live 2012, arara will already be available. With ...


3

I created a project structure that circumvents this warning. For my articles, I have separate self containing sub-projects for the (sub)sections. It does not require any customized build files or the like, and somewhat enforces a separation of concern (common images, bib, style file ...). You can check it out, it is available here.


3

/usr/local/texlive/2008/bin/universal- I believe "yap" (short for "yet another previewer", right?) is a dvi file previewer for Windows machines. You should check out the section "Using preview to source linking on Mac OS X" of the online manual for TeXlipse (at bottom of http://texlipse.sourceforge.net/manual/build.html) for information on using MacOSX's own ...


3

TeXlipse has an auto-complete feature which you can access with ctrl+space.


3

I think this question doesn't depends on the Editor TeXlipse. So I want to try to answer in a more general way. Script To setup your own compilation run you can write your own script. For windows it could be a bat file and for Unix a shell-script. For example a simple script could be: #!/bin/bash # file mycompile echo "My project compilation" ...


2

I suggest to proceed with something like this, which is (in my opinion) more \LaTeXy and compiles fine for me. If you really need the italic title and sections, this can probably be changed, I just went with the defaults. \documentclass[paper=a4]{scrartcl} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{booktabs} \usepackage{amsmath} ...


2

I believe this is a problem due to TeXlipse trying to be smart, but it doesn't distinguishing when \section is used in a macro definition in the preamble or in the document environment. You might be able to trick TeXlipse into not “seeing” the \section command by saying \usepackage{titlesec} \expandafter\titleformat\expandafter{\csname ...


2

you can run pdflatex -shell-escape <file> with package auto-pst-pdf or run pst2pdf <file> to create all images on the fly as png or pdf or ... you can run xelatex instead of pdflatex without any additional package or additional conversion


2

I use Eclipse for other purposes than Java development (Python, TeXlipse), and I found that the slimmest download that works for me is the "Platform Runtime Binary", sitting at mere 50 MB. Your plugin will pull anything else that it needs for installation, so quite a few plugins will probably need to be installed anyway. This guarantees, though, that no ...


2

You can write directly Metapost source in the LaTeX file, loading the mpgraphics or the gmp package. Both require that the -shell-escape feature is enabled, but the second package can work also without it (and produces a shell script to be run after LaTeX compilation). Disclaimer: I'm gmp's author.


2

I'm the author of the blog post mentioned in the question. Mico, is right, the instructions are a bit outdated, but still seem to work if you specify the paths according to the installed version of MacTeX. I updated the post with the path directives found in Mico's answer. Please also leave a feedback or question on my blog if you find any issues. Thank you ...


2

The makeindex problem in TeXlipse is well-known. I guess that it is a bug in TeXlipse. I found a solution in my environment: Clean your project, here is important that no output.pdf file exits after that! Than build it again, for some unknown reasons now I have a index in my new pdf. Another solution is to replace the pdflatex.exe in your build settings ...


2

In short, it seems that TeXLipse does not like sub-folders More details on this other conversation can be of help Bibtex not showing using TexLipse (too bad it has been closed) I am using MikTeX and, if I avoid using subfolders, sometimes it works sometimes it doesn't. The problem still seems to be that Bibtex is not run!


2

You can put \currenttime in your tex file, e.g. in header or footer, to get the compile time in the pdf.


1

As far as i know (and tested) using Linked Resources does not work with TeXlipse. Instead, you might consider using the import package, which allows using absolute and relative paths to include files. It is also able to deal with server addresses (if you sync your files via a server) like //srv01/files/tex. Example: \documentclass{article} ...


1

You can save the new file with the extension bib and after this you can work like described at the user manual: http://texlipse.sourceforge.net/manual/bibtex.html


1

I fixed it by unchecking the default LaTeX builder and creating my own pdflatex and biber builders (pdflatex > biber > pdflatex (2) > pdflatex (final)). I think it had to do with having a different tmp folder where the .bbl and other files were being written so I used the same directory for all builders.


1

Let me see if I can address your questions. :) :set jack-the-ripper-mode on Question 1 I'm not versed into SyncTeX, so my answer to your first question will be more of a wild guess. For most of the engines, arara offers the synctex parameter to be added to the directive, as you did in your code. But I believe this feature must be enabled in the last ...


1

I managed to get the auto-refresh back using Texlipse and PDF4Eclipse by checking the following box in the custom build. Hopefully it can help you. Also, the synctex should be called in the last time pdflatex is invoked. Best,


1

In the builder of Texlipse you can call your .bat as usual and in the arguments pour %input. Then in your .bat you can do @echo off cd "%~dp1" set texSource=%~n1 pdflatex -synctex=1 -interaction=nonstopmode "%texSource%.tex" makeindex %texSource%.idx makeindex %texSource%.nlo -s nomencl.ist -o %texSource%.nls bibtex %texSource% Also, I suggest you ...


1

If you still have the issue, please send a bug report to TeXlipse. Thank you in advance. On Windows the smart key is ctrl+space. The knowledge of this question was already introduced in 11635.



Only top voted, non community-wiki answers of a minimum length are eligible