Tag Info

Hot answers tagged

9

I think the best way to achieve this is the following: Add a line TEXMFDISTRO = /usr/share/texmf to /usr/local/texlive/2015/texmf.cnf, creating it if it is not present. Copy the definition of TEXMF and TEXMFDBS from /usr/local/texlive/2015/texmf-dist/web2c/texmf.cnf to /usr/local/texlive/2015/texmf.cnf Add TEXMFDISTRO between TEXMFLOCAL and !!$TEXMFDIST in ...


5

Not every TeX Live package, package, includes a .sty file by the same name, package.sty. Sometimes it does. Sometimes it doesn't. To figure out what a package provides, read its documentation or look inside its directories. Alternatively, in some cases, you can simply ask TeX Live Manager. For example, tlmgr info algorithms returns this: package: ...


4

The error is due to the inclusion of e-french (formerly frenchle) in TeX Live. An update to babel-french solves the issue. Transcript when compiling the example with babel-french version 3.1g (TeX Live revision 37701) > pdflatex manu This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex) restricted \write18 enabled. ...


4

In my texlive installation (in ubuntu 15.04), I try install framed.sty latex package with the command: $ tlmgr install framed It was shown this error message: (running on Debian, switching to user mode!) cannot setup TLPDB in /home/taciano/texmf at /usr/bin/tlmgr line 5435. I did make the following steps: $ cd ~ $ mkdir texmf $ tlmgr init-usertree I ...


3

Since installing without documentation is an available option in the TeX Live installer, there seems no reason to assume that removing these doc folders will have any ill effects apart from texdoc not working. Here's a quote of a message by Reinhard Kotucha from the TeX Live Mailing list From: Reinhard Kotucha On 2012-02-17 at 20:57:33 +0100, ...


3

The solution is to install the libertine-legacy (TeX) package, as @user51830 pointed out. The current (2015-08) libertine package is a dummy package which points to libertineotf or libertine-type1 depending on the compiler that calls it, but even though it “serves the purpose” of libertine-legacy, it does not replace it fully and in particular it does not ...


3

Removing the doc hierarchy will not break anything but texdoc searching for documentation. But simple removal will bring back the documentation for each updated packages. If you want to stop installing documentation files in the future, you can set the tlmgr configuration option to not install doc files with tlmgr option docfiles 0. After that documentation ...


3

babel-french has now been updated to avoid this problem, so the fix suggested below is no longer needed. This is an unfortunate incompatibility in a the e-french files recently added. The simplest (temporary) local fix is to add an empty file french.cfg to the folder containing your document. This file will then be read instead of the french.cfg in the ...


2

There is no slanted font in the Linux Libertine distribution. You can do like LibreOffice does and fake the slanting geometrically. \documentclass{article} \usepackage{libertine} \makeatletter \setmainfont[ Extension=.otf, Numbers = {\libertine@figurealign,\libertine@figurestyle}, UprightFont = *_R, ItalicFont = *_RI, BoldFont ...


2

Another option is to use Bruno's \slantbox (Shear transform a "box") as a substitute for \textsl. I have set the default slant to 0.2. \documentclass{article} \newsavebox\foobox \newcommand{\slantbox}[2][.2]{\mbox{% \sbox{\foobox}{#2}% \hskip\wd\foobox \pdfsave \pdfsetmatrix{1 0 #1 1}% ...


2

For each YYYY version of TeX Live which I have installed, I set up two symbolic links as follows: cd /usr/local/texlive ln -s <YYYY>/bin/x86_64-linux/ ln -s current.<YYYY> <YYYY>/ For the active version, I then do ln -s bin.<YYYY> bin ln -s current.<YYYY> current For example, right now, it looks like this: ...


1

You've got two texlive installations: /usr/local/texlive/2014/ /usr/local/texlive/2015/ For your personal use, it is not necessary to change anything there. Just put into the file /home/<username>/.profile a line like PATH=/usr/local/texlive/2014/bin/x86_64-linux:$PATH; export PATH Save the file, log out (no need to reboot), log in again and ...


1

You need to install more fonts. This should be possible with something like tlmgr install psnfss (if necessary; I doubt it) and more importantly tlmgr install helvetic. Sometimes figuring out font package naming can be difficult…


1

When you install a texlive (I do it with symbolic links for the binaries) all is in the directory : /usr/loca/share/texlive/2014 or 2015 the binaries are links (for me) in /usr/local/bin pointing on the last installed 2014 or 2015 previously seen directory. the environment variables and pathes are set on the last installation (2014 or 2015) previously ...


1

I now did the following: $ sudo ln -s /usr/local/texlive/2014 /usr/local/texlive/active Edited /etc/profile.d/texlive.sh such that the only uncommented lines are export PATH=/usr/local/texlive/active/bin/x86_64-linux:$PATH export MANPATH=/usr/local/texlive/active/texmf-dist/doc/man:$MANPATH export ...


1

As mentioned in the comments, tlmgr in Debian/Ubuntu switches automatically into user mode. This is also issued every time tlmgr is started. In user mode, only packages that are located completely in texmf-dist can be installed, since there is no way to know where to install binaries/scripts. A future version of tlmgr might cater to this, but this is far ...



Only top voted, non community-wiki answers of a minimum length are eligible