Tag Info

New answers tagged

0

In many cases, they key thing is to run fmtutil and NOT sudo fmtutil-sys. Your Linux distribution is supposed to take care of updating the system folders, but it will not (and should not) touch your user directory (as it may be on a network drive, shared by multiple computers). The message Fatal format file error; I'm stymied tells you that the versions ...


2

@Johannes_B, @Sigur, @ArashEsbati, @cfr, thank you all; I installed windows update yesterday I think it is the one called Security update for windows vista x64-based systems KB3059317 ( I am not sure the second update window malicious object removal tool x86 KB890830 is for anything like that ) and now I am like anyone of you with TeXLive on his laptop. ...


1

I don't own the fonts, so this might be wild guess. But in general, you should have received a zip(?) file and you have to extract the files into your texmf-local directory. You can locate your texmf-local directory at command prompt with: kpsewhich -var-value=TEXMFLOCAL The general directory layout of files to extract to is shown below: ...


0

As mentioned by @cfr in a comment the packages are bundled by the distributer rather than the TeX Live base. In this case I needed to be looking for MacPorts specific bundles: https://trac.macports.org/wiki/TeXLivePackages


4

The Syntax package redefines the underscore character, so when you use it in filenames it is not read as it is but interpreted as a macro and expanded. Simple solution: avoid underscore in filenames. Not so pretty solution: capture the original underscore char in a macro before the syntax package changes its meaning (at begin document) and then use the ...


1

Don't run updmap. If you have run updmap, delete the directory named .texliveYYYY (e.g. .texlive2013) from your home directory. Note that the name of the directory begins with a dot. To be safe, rename it rather than deleting it. (Deleting the directory is safe but deleting some other directory which you think it this one may not be at all safe.) Always use ...


1

Building e-TeX is SUPER EASY. Here is the recipe that worked for me: mkdir mydir && cd mydir rsync -a --delete --exclude=.svn --exclude=Work tug.org::tldevsrc/Build/source/ . mkdir Work && cd Work ../configure --disable-all-pkgs make cd texk/web2c/ make etex cp etex /usr/local/bin/ <build new format> Assuming that you have TL ...


10

pdfTeX has been the standard engine for TeX Live (and MiKTeX) for some years. pdfTeX can be run without the extensions enabled as a (more-or-less) drop-in replacement for TeX90 or with the extensions enabled as a drop-in replacement for e-TeX. With a document that uses TeX90 and e-TeX primitives, pdfTeX will produce identical output to a 'real' etex binary ...


3

The definitions given of \thesection and \thesubsection are completely wrong. You get the same result, without the problem in \ref by doing \documentclass[nouppercase]{ifmbe} \renewcommand{\thesection}{\Roman{section}} \renewcommand{\thesubsection}{\Alph{subsection}} \makeatletter \def\@seccntformat#1{\csname the#1\endcsname.\ } \makeatother ...


3

The cause is a faulty definition of \thesection and \thesubsection, which include negative space at the end of the number: \renewcommand{\thesection}{\Roman{section}.\hspace{-3mm}} \renewcommand{\thesubsection}{\Alph{subsection}.\hspace{-2mm}} The following workaround uses \secref, which removes the space locally: \documentclass{ifmbe} ...


3

install the last version of eledmac which is in the CTAN, or wait for install by tlmgr. That is linked to the change of etoolbox behavior with the last version LaTeX 2015. It has been fixed, but between the frozen of TeXLive 2014 and the release of TeXLive2015. you can also add \usepackage{etex} before loading eledmac.


2

Yes, it's called mkjobtexmf. Give a look at this link: https://www.ctan.org/pkg/mkjobtexmf


4

I found other people come across the same problem and find the workaround via my question. So I undelete the question. Please refer to Issues page of TeX Live Utility: here for the cause and workaround. It seems that a new release of MacTeX Live 2015 has fixed the problem.


1

I think I can answer the question(s) you ended up with as follows: BasicTeX is configured to exclude documentation as part of its install settings. TeX Live Utility will respect that original setting to exclude documentation when future packages are installed. At some point, I'm planning to add a feature to TeX Live Utility that allows it to install the ...


3

Please read part 1 first. This is the second resource which may be of interest. A 1 page (double-sided) font sampler. Most fonts are supported by packages in TeX Live, but some require the use of the getnonfreefonts script. The sample Tengwar font at the very end is the only example not installed by default or easily installed using the script. Note that ...


4

Note the existence of The LaTeX Font Catalogue. Note also that I planned to provide two resources as part of a single answer. However, the site says I cannot do this so I'm going to split them up. The following resource may be of interest. A 1 page (double-sided) list of font packages. All packages are included in TeX Live. Not all fonts are listed, but ...


0

I faced the same problem. Try installing the following packages in order: sudo apt-get install texlive-latex-base sudo apt-get install texlive-latex-recommended sudo apt-get install texlive-latex-extra ... In my case base and recommended were already installed. Installing texlive-latex-extra packages resolved my problem.


0

The search function in the Cygwin package manager doesn't find texdoc, so I bit the bullet and installed everying under publishing (i.e. Latex related) along with with all that bloat. Somewhere within all that jetsam and flotsam was the nugget I needed, namely texdoc. After editing the texdoc config file and installing xpdf, It worked!


9

TeX Live 2014 is frozen forever and will no longer be updated. This happens in preparation for a new release. This happened at April 10. The new TeX Live 2015 should be available from June 12. Here is an explanation why TeX Live is frozen every year prior to a new release. You can manually install ctex by: Download it from CTAN Unpack it to your ...


0

My Solution Hi TeX users, I have found a solution or at least a work around that works with texstudio 2.9.4. I do not know, whether this works in earlier Versions, too. My portalbe Directory LaTeXportalbe |------------texstudio2.9.4 |------------texlive |------------gs |------------etc. How to Set the commands as the following: ...


0

As mentioned in the comments, texdoc is the way. The binary is included in our cygwin builds, as one can check in the svn repo http://tug.org/svn/texlive/trunk/Master/bin/i386-cygwin/ texdoc works practically out of the box, just call it with a package name or file name and in most cases will find documentation. If you need more help with it, call texdox ...


1

From the README apply the instructions given for MikTeX (quite counter-intuitive, eh?) and add Map emerald.map to .texmf/web2c/updmap.cfg and run updmap.


4

Don't follow the instructions in the README file as they are not current and will not ensure that the fonts are generally available to multiple engines. The following assumes that you have installed the package files successfully. It is strongly recommend to use TEXMFLOCAL if you can for this. You can find out where this is using kpsewhich -var TEXMFLOCAL. ...


2

The quickest way to check if a package is installed is to search for it with kpsewhich {package-name}.sty. So, to check for etoolbox, use $ kpsewhich etoolbox.sty /usr/local/texlive/2014/texmf-dist/tex/latex/etoolbox/etoolbox.sty If it finds the package, it will output the path (just like normal which). If it doesn't find the package, it will output ...



Top 50 recent answers are included