Tag Info

Hot answers tagged

2

Here's a TeXstudio macro that I use for exactly the purpose you mention: %SCRIPT txt = cursor.selectedText() editor.write("{"+txt+"}") cursor.clearSelection() One you have added this in the Edit Macros window (I used "Braces Around Text" as the Name and left the other fields blank), you can assign it a keyboard shortcut in Configure TeXstudio | Shortcuts. ...


2

Yes, you can insert accents directly by keyboard in TeXstudio. Note that, since TeXstudio is an editor which support a lot of font encoding you can type normally. No problem will appear until you compile your tex file. During the compilation process those accented characters should be interpreted by the compiler. This could be done in general loading some ...


2

With a simple dummy item of no label \item[] {}, one can write this: \documentclass{article} \usepackage{enumitem} \begin{document} Some text ... \begin{enumerate}[label*=\arabic*.] \item[] {} \stepcounter{enumi} \begin{enumerate}[label*=\alph*.] \item A subquestion. \item Another subquestion. \end{enumerate} \end{enumerate} \end{document}


2

There are 3 common ways to create a bibliography in LaTeX. Use the thebibliography environment. Use a database of bibliographical entries and BibTeX. The database takes the form of a .bib file. Use a database of bibliographical entries, Biblatex and Biber. The database can be in one of several forms, most commonly a .bib file. The template assumes ...


2

In TeXworks, special Unicode chars are inserted from the right-click menu: Right click -> Insert Unicode control character -> ZWSP Zero width space.


1

This is a known Qt Bug. See: https://bugreports.qt-project.org/browse/QTBUG-42074 https://sourceforge.net/p/texstudio/bugs/1127/


1

After the help of @Torbjørn I came up with this workaround. Create a mydefinition.cwl file and place it in the %APPDATA%/texstudio folder (I'm using Windows, don't know where it should go in other operative systems). Add the \DeclarePairedDelimiter{cmd}{left_delim}{right_delim}#md line in the .cwl file. In TeXstudio Options -> Completion check the box of ...


1

I had a similar issue. I had tooltip boxes appearing but the text was invisible. Here is an other solution that worked for me. With this one you are not forced to choose the style GTK+. Go Option/Configure TexStudio On the left bottom corner: Tick the box Show Advanced Options In the panel General/Appearance: Tick the box Ignore Most System Colors


1

As per @TimHoffman's comment, TeXStudio caches the contents of .bib files such that updates to the .bib might not be reflected in the autocomplete pop-up. As he also states, doing: Idefix -> Refresh Structure does indeed sort the problem out and new bibliography entries will appear in the autocomplete.


1

In fact, what is happening there is that TeXstudio is indenting the line (not the whole paragraph). Probably what you are calling paragraph is a single line. So when TXS wraps the line it shows an arrow on the left panel (near the line number) and then if you indent that line the whole block is also indented. If you want to indent only the first line of ...



Only top voted, non community-wiki answers of a minimum length are eligible