Tag Info

Hot answers tagged

17

There are two ways to write IPA symbols in LaTeX. One uses regular pdfLaTeX and the tipa package; the other uses XeLaTeX or LuaLaTeX and you can enter the symbols directly into your source, assuming you have the correct fonts. The SIL Doulos font is an excellent Unicode IPA font that is widely used in Linguistics. You can download it here. I'll outline ...


12

Could be tweaked a bit more but.... \documentclass{scrartcl} \usepackage{tipa,graphics} \makeatletter \providecommand\xloweraccent{\@ifnextchar[{\lower@accent x\empty}% {\lower@accent x\empty[\z@]}} \def\brak#1{\xloweraccent{% \raisebox{-.3ex}{\resizebox{!}{.6ex}{\bfseries(}}% {\fontencoding{T3}\selectfont\char12}% ...


12

Since this answer might be of use to other linguists, I'm giving a detailed answer of how to effectively transfer documents from Word to TeX, assuming you are using the regular SIL phonetic fonts in Word. The modern TeX engines LuaTeX and XeLaTeX both use UTF-8 as their file encoding, and can use any OpenType font on your system. See the following for some ...


11

it's always better to use "precomposed" characters rather than trying to cobble something together. this may involve some work with font tools, and others on this list are better able to address that than i. however, many fonts created for use within linguistics environments are available from sil international, and i suggest looking there before trying to ...


10

Thank you very much, David Carlisle! After learning how it works from your answer, I have been able to make my own tweaks: Instead of the brackets and the x, I am using the tipa characters that are produced with \textsublhalfring, \textsubrhalfring and \textovercross respectively. I also forced the bracketed diacritics to be always upright, so the kerning is ...


10

The Arabic font is not a factor. The problem is that fontspec redefines \textipa under the assumption that the Latin Modern fonts have the IPA glyphs, which however should be called by Unicode. Solution: restore the Computer Modern fonts for IPA. \documentclass[12pt,openany]{book} \pagestyle{plain} \usepackage[margin=1.8cm]{geometry} \geometry{a4paper} ...


9

The warnings are harmless, and the substitutions will happen automatically. If you want to get rid of the warning you could redefine the \textipa command and the IPA environments to always use Computer Modern as shown in the example below. If you decide later to change to using e.g. mathptmx then you would need to change the definition of \tiparmdefault to ...


9

xunicode (loaded by fontspec) contains the definitions of tipa.sty: \documentclass[12pt]{article} \usepackage{fontspec} \setmainfont{Charis SIL} \begin{document} Blowzy DJ frumps vex a knight QC \textturna \textipa{[\!b] [\:r] [\;B]} \end{document}


8

The tipa package redefines some standard commands and this is the cause for the errors you get, but provides a “compatibility” layer. Notably the command it redefines are \s (alias \textsyllabic) \* (no alias provided) \| (no alias provided) \: (alias \tipamedspace) \; (alias \tipathickspace) \! (alias \tipanegthinspace) If you call the package with the ...


8

You have to defer gathering the argument: \newcommand{\myipa}{\begingroup\shorthandoff{"}\myipaI} \newcommand{\myipaI}[1]{\tipaencoding #1\endgroup} This will typeset correctly the bit \myipa{"x""x"a"s}. Of course such a command can't go in the argument of other commands. Should you need it into a section title, say \shorthandoff{"} ...


7

Simply load the package tipa which defines IPA symbols and use them as in \asr p{\textepsilon}{\textltailm} \endasr MWE \documentclass{article} \usepackage{pstricks,pst-xkey,pst-asr,graphicx}\psset{everyasr=\tiershortcuts} \usepackage{tipa} \begin{document} \asr p{\textepsilon}{\textltailm} \endasr \end{document} Output


6

The problem is not actually with the tipa package itself, but with basically any font package you would load. The problem is caused by the fact that linguex defines a \b. and and \c. macro, but both of these are used as diacritic commands (\b puts a macron under a character, and \c puts a cedilla. So loading the font package after linguex removes the linguex ...


6

Here is a basic approach that compiles with pdflatex. Since this Unicode glyph is not available through the tipa fonts or in the default, you can create it yourself. You might wish to do it differently than in the example (perhaps a smaller size or a different symbol). The newunicodechar package allows you to make a Unicode character into a control ...


6

Use the tipa package for phonetic symbols. \documentclass{article} \usepackage{tipa} \begin{document} \textipa{I} \end{document} If you want an i without the dot, use \i: \documentclass{article} \begin{document} \i \end{document}


6

You can ignore it safely. Latin Modern fonts have no T3 encoding support. Since Latin Modern families come from Computer Modern fonts, it will works fine combining LM fonts with CM IPA fonts in T3 encoding.


6

You can use the IPA characters (of course you need that your file is encoded as UTF-8) % -*- coding: utf-8 -*- \documentclass[12pt]{article} \usepackage{fontspec} \setmainfont{Charis SIL} \begin{document} Blowzy DJ frumps vex a knight QC ɳ (U+0273), ɲ (U+0272), ʁ (U+0281), ɱ (U+0271), ə (U+0259) \end{document}


6

Do you need the fontenc package? Detexify says it should be \dh and that worked for me, with or without tipa \documentclass{report} \usepackage[T1]{fontenc} \usepackage{tipa} \begin{document} \dh \end{document} Link to Detexify for reference


6

It's the usual issue about xstring that by default tries to do full expansion of its arguments. \documentclass{memoir} \usepackage{xstring,tipa} \newcommand*\myreplace[1]{% \saveexpandmode\noexpandarg \StrSubstitute{#1}{:}{\textlengthmark}% \restoreexpandmode} \begin{document} \myreplace{gaga:} \end{document} If you don't need applications of ...


5

Use \textipa{\|+{\;L}} with additional braces. The command \| executes \@omniaccent that requires two arguments, so with \|+\;L the second argument is \;, which is wrong.


5

The support for tipa input provided by fontspec comes from the xunicode package. However, it does not cover everything that tipa can do. A work-around is to prevent xuicode loading: \documentclass[a4paper,12pt, oneside]{article} \expandafter\def\csname ver@xunicode.sty\endcsname{} \usepackage[tone]{tipa} % tone invokes the tone letters ...


5

I'm not familiar with the tipa package but you can use the \textsuperscript command for typesetting superscript in text (not math) mode: \documentclass{article} \usepackage{tipa} \begin{document} \textipa{/bI"wIl.d\textsuperscript{@}r.IN/} \end{document}


5

Using active characters is not recommended for this application: you lose the possibility of having any control sequence with an a in its name inside the argument of \myipa. How could you do it? Here's what's necessary. \documentclass{article} \usepackage{tipa} \newcommand\myipa{% \begingroup\catcode`\a=\active \begingroup\lccode`~=`a ...


5

It seems like a bug in silence.sty; it doesn't show if we patch \wrong@fontshape: \documentclass{article} \usepackage{silence,etoolbox} \makeatletter \patchcmd{\wrong@fontshape}{\@gobbletwo}{}{}{} \makeatother \WarningFilter{latexfont}{Font shape} \WarningFilter{latexfont}{Some font} \usepackage{lmodern} \usepackage[]{tipa} \begin{document} ...


5

I don't know anything about fonts, so I can't fully answer the question. However, a workaround might be to use kpfonts and replace your f's with s's. The following code gives: \documentclass{article} \usepackage[nofligatures,veryoldstyle]{kpfonts} \begin{document} \emph{osten ossing} \end{document} It is likely that if the character above is suitable, ...


5

Try \DeclareFontSubstitution{T3}{ptm}{m}{n} after \usepackage{tipa}


4

Compile with xelatex or lualatex: \documentclass{scrartcl} \usepackage{fontspec} \setmainfont{Doulos SIL}% or your preferred font for phonetics \begin{document} fə'nɛtiks \end{document} With xelatex or lualatex, you don’t load fontenc or inputenc, your source must be utf-8, and you can use any unicode-encoded truetype or opentype font that has the symbols ...


4

Search for its unicode, check the fonts which support it (or look, if it already exists on your machine), and include it with \symbol{} of the package fontspec. This requires Xe- or LuaLaTeX: % arara: lualatex \documentclass{article} \usepackage{fontspec} \setmainfont{Linux Libertine O} \begin{document} \symbol{"026A} \end{document}


4

The error is in using \xdef instead of \protected@xdef; all \text... macros in LaTeX cannot be used in the replacement text for \edef (and so \xdef). \documentclass{article} \usepackage{fixltx2e,hyperref,ifthen} \usepackage{tipx} \makeatletter \newcount\mod \newcommand*{\modulo}[2]{% \mod=#1 \@tempcnta=#2 \ifnum\mod<\@tempcnta\else \loop ...


4

As already said by egreg, quoting Unicode's CodeCharts: U+0280 LATIN LETTER SMALL CAPITAL R voiced uvular trill Germanic, Old Norse uppercase is 01A6 Ʀ Tipa version: \documentclass{article} \usepackage{tipa} \begin{document} \texttt{\string\textscr}: \textscr \end{document} Wsuipa version: \documentclass{article} ...


4

Leo Liu's answer says that you can safely ignore them. This answer is a complement to that answer. It tells you how to safely ignore them. (And it borrows heavily from Stefan Kottwitz's answer to an earlier question of mine) You can use the silence package to turn off warnings from the appropriate package. So \WarningFilter{latexfont}{Some font} ...



Only top voted, non community-wiki answers of a minimum length are eligible