Tag Info

New answers tagged

1

\documentclass{book} \def\numberline#1{#1} \renewcommand\thechapter{\Roman{chapter}} \begin{document} \chapter{Some title} \chapter{Some other title} \chapter{One more title} \tableofcontents \end{document} And if you have sections with the default TOC entry then use: \documentclass{book} \makeatletter \renewcommand*\l@chapter[2]{% ...


2

Even tocloft still uses the traditional setting of the ToC entry numbers inside a box (of width \cftZnumwidth, where Z is the sectional unit). But, we can patch \l@chapter to momentarily adjust \numberline - the macro causing the problems. The patching is supplied by etoolbox. Below I've done so, even though the readability of the ToC now completely suffers ...


1

The manual suggests \renewcommand{\cftafterZtitle}{\thispagestyle{empty}} where Z is the list type. In your case Z is equ so you should add \renewcommand{\cftafterequtitle}{\thispagestyle{empty}} to your preamble. By the way, your command \myequations should end with \ignorespaces instead of \hfill so that following text doesn't necessarily start a new ...


0

The problem is solved, by using titletoc. I give n answer combined with a use of the package fncychap and option Glenn. Using the following commands on the examples given above, gives a good form... \usepackage[Glenn]{fncychap} \ChNumVar{\Large}% Dimension of the number of the chapter \usepackage{titletoc}% \titlecontents{chapter}% <section-type> ...


0

A possible solution, but I am sure, this has been answered before (I took the \cftchapresnum... etc code from Karl Koeller's answer in the link provided by the OP) \documentclass{book} \usepackage{fmtcount} \usepackage{blindtext} \usepackage[titles]{tocloft} \usepackage{forloop} \newcounter{dummycounter}% \newlength\mylength ...


0

I didn't troubleshoot thoroughly enough. Using \renewcommand{\cftchapaftersnum}{\cftdotfill{\cftdotsep}} actually works, but you need to increase \setlength{\cftchapnumwidth}{4cm}.


1

A 'quick' solution could be, to store the definition of \thesection right after \appendices start, then use the old definition in the figure environment, since this is a group and append the : to the `\thesection. Since the figure environment is a group, the old definition will only be used for figure references/captions. Basically the same has to be done ...


1

If your intent is that subsections are typeset like A: Title you should use a different approach. \documentclass{article} \usepackage{appendix} \usepackage{chngcntr} \usepackage{etoolbox} \makeatletter \newcommand\colon@seccntformat[1]{\csname the#1\endcsname: } \apptocmd{\appendices}{\let\@seccntformat\colon@seccntformat}{}{} \makeatother ...



Top 50 recent answers are included