Tag Info

Hot answers tagged

5

This is a known bug in latex: add \RequirePackage{fixltx2e} at the start of the document.


4

Add the following lines in your preamble: \makeatletter \let\oldmarginnote\marginnote \renewcommand*{\marginnote}[1]{% \begingroup% \ifodd\value{page} \if@firstcolumn\reversemarginpar\fi \else \if@firstcolumn\else\reversemarginpar\fi \fi \oldmarginnote{#1}% \endgroup% } \makeatother MWE: \documentclass[twoside]{article} ...


4

The error you get is due to the fact that you're embedding a floating environment like figure in a minipage and this is not allowed. To achieve what you want, when you are in a two-column document, simply issuing the command \onecolumn puts you in one-column mode. Also, to have centered contents inside the figure, use \centering instead of a center ...


3

This is because you are using r (right align) as a column specifier. Use l (left align) instead. MWE: \documentclass[twocolumn]{article} \usepackage{booktabs} \begin{document} \begin{table*} \centering \begin{tabular*}{\textwidth}{@{\extracolsep{\stretch{1}}}*{1}{l}@{}} \toprule we must bare+in+mind the community as+a+whole. \\ nous devons ...


2

This uses basically the paracol package which provides for parallel setting and easy switching of columns. Longer column content is maintained in the corresponding column(s) of the next page(s) (See the red and blue text to demonstrate this) \documentclass[12pt]{article} \usepackage{xcolor} \usepackage{ragged2e} \usepackage{paracol} \usepackage{blindtext} ...


2

You can make the equation fit in the column, or you can put it in a two column float. I avoided \text as it uses text spacing and inconsistent spacing around the + which I assume was not wanted. I also avoided numeric keys for \label. \documentclass[twocolumn,article,a4paper]{memoir} \usepackage{amsmath} \begin{document} \begin{figure*} \begin{equation} ...


2

dbfloatfix (and the fix2col and stfloats packages on which it is based) is a fairly robust package and won't in isolation affect single column floats using the latex releases that it is designed to fix. However like any contributed package it runs the danger that it is harder to test potential latex updates against all contributed packages, whereas packages ...


2

I deleted the markup that was causing warnings in the log, and the floats appear at the top of page 2 as you requested: \documentclass[twocolumn]{article} \usepackage{lipsum} \begin{document} \title{Article Title Here} \author{balaji} \maketitle \begin{figure*} \centering\rule{0.8\textwidth}{0.3\textwidth} \end{figure*} \begin{table*}[!t] \centering ...


1

You should patch the \maketitle macro to insert \tableofcontents at the appropriate location: \documentclass[preprint,3p,twocolumn]{elsarticle} \usepackage{lipsum,etoolbox} \patchcmd{\maketitle}% <cmd> {\finalMaketitle}% <search> {\finalMaketitle\tableofcontents\vspace{\baselineskip}}% <replace> {}{}% ...


1

Try this... not sure whether it may break other link anchors: \documentclass[twocolumn]{scrreprt} \usepackage{hyperref,lipsum,etoolbox} \makeatletter \def\tmphook{\setlength{\HyperRaiseLinkLength}{\glueexpr\scr@chapter@sectionafterskip+35pt\relax}} % \patchcmd{<cmd>}{<search>}{<replace>}{<success>}{<failure>} ...


1

Use \onecolumn right after \appendices; if needed, you can switch back using \twocolumn (each of those commands starts a new page): \documentclass{IEEEtran} \usepackage{lipsum} \usepackage[]{minted} \begin{document} \section{Introduction} \lipsum \section{Material} \lipsum \appendices \section{BaudRate} ...


1

with multicols \documentclass{article} \usepackage{lipsum,multicol,amsmath} %\usepackage{widetext} %\usepackage{flushend} %\usepackage{cuted} \begin{document} \lipsum[1-2] \begin{multicols}{2}%\twocolumn \lipsum[1-5] \end{multicols} \begin{multicols}{2} \lipsum[1-5] \end{multicols} \end{document} I don'i have others packages.


1

Here is a very simple solution, loading titleps via the pagestyles option of titlesec, instead of fancyhdr: \documentclass[openany]{book} \usepackage[a4paper]{geometry} \usepackage{multicol} \usepackage{parskip} \usepackage{graphicx} \usepackage{changepage} \usepackage{lipsum} \pagestyle{plain} %CHAPTER FORMAT \usepackage[pagestyles]{titlesec} ...


1

The spaces are defined in the \@maketitle macro. You should patch or redefine this macro to change these spaces. For instance, add the following to your preamble: \makeatletter \renewcommand{\@maketitle}{% \newpage\null\vskip2em% \begin{center}% \let\footnote\thanks{\LARGE\@title\par}% ...



Only top voted, non community-wiki answers of a minimum length are eligible