Tag Info

Hot answers tagged

7

The problem is in the fact that babel-czech makes the hyphen a shorthand character, but soul has no check for an active -; the result is that as many characters at the end are mangled as there are hyphens in the text. Here is a workaround using regexpatch: \documentclass[12pt]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} ...


7

I'd consider ⟦ •[Gnats] are small animals •[Gnus] are big animals ⟧ as code obfuscation. Anyway, this works with all engines. However, for pdflatex it requires utf8 passed to inputenc or inputenx (as opposed to utf8x). \usepackage{newunicodechar} \newunicodechar{⟦}{\begin{description}} \newunicodechar{⟧}{\end{description}} \newunicodechar{•}{\item} If ...


5

You have to use a font that has the required glyphs. They are in FreeSerif, for instance. Here's how you can use them directly, by hiding the font change in a macro: \documentclass{scrartcl} \usepackage{fontspec} \usepackage{newunicodechar} \setmainfont{Linux Libertine O} \setsansfont{Linux Biolinum O} \newfontface{\freeserif}{FreeSerif} % for the ...


5

I am sorry about my non-LaTeX answer but I would signify that we can treat with UTF-8 codes as one token i normal 8bit pdftex and we can avoid the complications shown in David's and egreg's answers. You can try to create the UTF-8 encoded file: \input lmfonts \def\<#1{{\bf#1}} f\<oo b\<öll €\<€ f\<{oö} f\< öo \bye and process it by ...


5

A general answer, covering also the cases of three and four byte UTF-8 characters; \<ö or \<{ö} is allowed. If a space creeps in, like in the last example, it is removed. Maybe a test for a control sequence should be added, in order to catch wrong input; as long as you have just characters or { after \<, it should be safe. \documentclass{article} ...


4

This was a bug and should be fixed in the 2.0 DEV version of biber on SF. When decoding to UTF8, "\-" shouldn't really be touched.


4

▪ ▫ ▪ ▫ ▪ ▫ ▪ ▫ ▪ ▫ ▪ ▫ U+25AA and U+25AB


2

Left side: unicodes. Right side: unicode-math commands. Below: other possibilities (QED just yields a real square in Latin Modern Math, Cambria Math, Asana Math and TeX Gyre Pagella Math). % arara: lualatex \documentclass{article} \usepackage{fontspec} \usepackage{unicode-math} \begin{document} \setmathfont{xits-math.otf} \[\symbol{"025AA} ...


2

I believe the problem lies in the misconception about the use of the CJK environment - as @egreg said, it can't be enabled and disabled. Just enclose the whole document in one CJK environment and when using CJKutf8 (see here for what difference it makes) utf8 characters using latin script but outside of ASCII will be fine. Thus your MWE in a fixed version ...


2

You don't want a Unicode char here, you want a new command that inserts jsut the appropriate symbol. \newcommand*\floppy{{\fontawesome{}}} I've used an extra pair of braces to group the font change so there is no need for \normalfont. Note that in the usual TeX way you will need to allow for the space-skipping which occurs after the command, e.g. ...


2

\documentclass[border=10pt]{standalone} \usepackage{fontawesome} \setmainfont{Linux Libertine O} \def\floppyA{{\FA}} \let\floppyB\faSave \let\\floppyB \begin{document} Some awesome icons: \faSave\ %%% loads automatically the awesome icons \floppyA\ \floppyB\ \ \end{document}


2

If you have already the converted PDF files, here's a version that works with all engines: \documentclass{article} \usepackage{graphicx,stringenc} \usepackage{xparse,l3regex} \ExplSyntaxOn \tl_const:Nn \c_coloremoji_dir_tl { ./emoji_images/hires } \tl_new:N \l_coloremoji_input_tl \cs_new_protected:Npn \coloremoji_unicode:nn #1 #2 { ...


1

I believe that you just need to switch back to horizontal but perhaps I have missed something... \documentclass{report} \usepackage{CJKutf8, CJKspace} \usepackage[usebaselinestretch]{CJKvert} \usepackage{setspace,rotating} \begin{document} \begin{center} \begin{singlespace} \vspace*{-2cm} \parbox[c][5em][c]{15cm}{% \small In order to properly understand ...


1

Here is the friendly reply from GUST: this is what the developers have to say: It is a well-known -- needless to say, interim -- (mis)feature of LM, TG Pagella and TG Termes. TG Bonum and TG Schola have the proper slots. The issue will be corrected in the next release, hopefully, before long. so please be patient


1

Probably this thread will help to solve part of your problem how-to-create-multilingual-english-japanese-bibliographies-with-biblatex, see the answer by PLK (almost at the bottom of the page.) Your bibliography should be structured in following manner: @article{HondaSuzuki2014, LANGID = {japanese} author = {本田, 太郎 and 鈴木, 次郎}, ...


1

This question seems to be about the same error message and one of the answers also includes biber, so its probably related. quoted solution by egreg: add in your preamble \DeclareUnicodeCharacter{00A0}{ } but of course, your case my differ. This was for the "no-break space" character. I suppose opening the .bib file in an editor that can switch between ...



Only top voted, non community-wiki answers of a minimum length are eligible