New answers tagged

3

Because space is a special entity used in TeX at level of "typesetting material" (it does not correspond to any character code in the font but it has its base dimension plus stretchability minus schrinkability) then Knuth decided that the slot declared for space in typical text fonts is "free" and he put special character here: the cross dash for polish l. ...


0

The OT1 font encoding isn't enough for that. Add \usepackage[TS1,T1]{fontenc}


4

(pdf)tex knows nothing about Unicode so you get whatever symbol is in position 32 in the current font, none of the classic tex fonts is Unicode encoded (they only have 127 characters per font) Even if you use xetex or luatex, which do use Unicode fonts you should not use \char32, tex does not use a character for space, it uses space of adjustable size. The ...


5

One can use lmodern, but redefine the functions \', \H, and \", though that may have some danger associated with it. As wipet points out, this approach breaks hyphenation, which in itself is enough to recommend against its use. \documentclass[12pt]{article} \usepackage[T1]{fontenc} \usepackage{lmodern,stackengine,scalerel,graphicx} ...


9

Complex solution This solution skips loading fontenc and uses the package newunicodechar to redefine the accented characters, in order to preserve the original accents while retaining some hyphenation. The trick used is to split the word while shortening the interword space to nothing. As I said, some (but not all) hyphenation is preserved, as well as ...


1

You can experiment with different bars (this one is from the slashed L \L) \documentclass[12pt,a4paper,titlepage,oneside]{book} % il faudra ajouter [final] à la fin \usepackage[utf8]{inputenc} \usepackage[ibycus,frenchb]{babel} \usepackage[T1]{fontenc} \usepackage{lmodern} \makeatletter \DeclareTextCommandDefault{\KK} ...


1

With pdfx (v.1.5.8) your example works if you change the package-loading order to become: \documentclass {amsbook} \usepackage[a-1b]{pdfx}% ---- recommended to load it early \usepackage{amsmath} \usepackage{mathtext} \usepackage[T1,T2A]{fontenc} \DeclareSymbolFont{T2Aletters}{T2A}{cmr}{m}{it} \usepackage[utf8]{inputenc} \begin{document} $\CYRI^2$ ...


1

Using JabRef 3.3, exportation to CSV looks fine with an editor supporting UTF-8. The issue is the importation of an UTF-8 CSV file into excel. See https://stackoverflow.com/questions/6002256/is-it-possible-to-force-excel-recognize-utf-8-csv-files-automatically


19

Symbol from Unicode font (LuaTeX or XeTeX) If LuaTeX or XeTeX is used with Unicode fonts, then the symbol can be used directly if the font supports this code point. Example for some fonts: \documentclass{article} \usepackage{fontspec} \begin{document} \newcommand*{\test}[1]{% #1:&\fontspec{#1}\symbol{"262D}\\% } \begin{tabular}{ll} \test{DejaVu Sans} ...


0

I had two similar problems: "Unicode char \u8: " "Unicode char \u8:." (with dot) The problems were related to the .bib file (references list). The first problem was solved based on the \DeclareUnicodeCharacter{00A0}{ } stated by @egreg. The second one was helped by the @Chris H 's answer. I opened the generated file .log and looked for errors. I found: ...


3

In the first case (an 8-bit engine), the set up \newunicodechar{∫}{\int} uses active characters to make the multi-byte sequence ∫ expand to the control sequence \int. It is that which is therefore important. A quick \show reveals that \int expands to \intop\nolimits and that \intop is defined (\mathchardef) as \mathchar"1352. That's then the 'raw' ...


8

\documentclass{article} \usepackage{tipa,relsize,amsmath,graphicx} \def\Lenny{\raisebox{-.8ex}{\resizebox{2.5em}{1.2em}{% ${\overset{\left(^{\overset{\frown}{\circ}}\!\! % {_{{\overset{{\text{\scriptsize\textinvglotstop}}}{\mathlarger\smile}}}}\!\!\!% ^{\overset{\frown}{\circ}}\!\right)}{}}$}}} \begin{document} I am Lenny \Lenny \end{document}


4

You can use the following code (based on an example by David Griffiths): \documentclass{report} \usepackage{graphicx} \def\len{{\mbox{$\resizebox{.31in}{.08in}{\includegraphics{len}}$}}} \begin{document} Here's a sample: $\resizebox{.31in}{.08in}{\includegraphics{len}}$ Can I put it into a line of type? ...


71

If you use a Unicode aware TeX dialect like XeLaTeX it is just to paste the text and make sure the chosen font contains the characters. \documentclass{article} \usepackage{fontspec} \setmainfont{DejaVu Sans} \begin{document} ( ͡° ͜ʖ ͡°) \end{document}


121

Staightforward with a stack. \documentclass{article} \usepackage{stackengine,graphicx,trimclip,scalerel} \begin{document} \savestack\eye{\rotatebox{90}{$^\circ\mkern-6mu\raisebox{1pt}{)}$}} \savestack\nose{\raisebox{3pt}{\scalebox{1}[-1]{\clipbox{0pt 1pt 0pt 0pt}{?}}}} \savestack\mouth{\rotatebox{90}{(}} \scaleleftright{(}{\stackanchor[2pt]{\eye \nose ...


22

With some help from Detexify, I got this first approximation: \documentclass{article} \usepackage{tipa} \usepackage{amsmath} \begin{document} $\overset\frown{\smash(^\circ} \underset\smile{\ \text\textinvglotstop} \overset\frown{\ ^\circ} )$ \end{document}


3

@UlrikeFischer is correct - biber only has one field to work with and so chooses the encoded format for maximum compatibility. You could easily use a sourcemap to copy to another verbatim field (like verba) and use that as the printable version whilst keeping url for the hyperref link. This would need a minor style change but should be relatively easy (make ...


1

The automatic translation is intended as a feature. Since the strings are not directly customizable, like in Word for example, the automatic translation helps the user without having to translate it yourself each time. Of course, these strings can be changed. In order to customize it, I loaded titlesec and also babel to help. Chương is now in full ...


2

There are a few issues with your setup. You need the T1 encoding You need the textcomp package The palatino package is obsolete The utf8x option is not recommended. \documentclass{memoir} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{textcomp} \usepackage{mathpazo} \begin{document} ĵÊÄ¡£ÄãÇÕãl£¿¬FÚÔ 50.0441° N \end{document} ...


1

The following seems to work: \documentclass{memoir} \usepackage[utf8x]{inputenc} \usepackage[T1]{fontenc} % <-- new \usepackage{palatino} \begin{document} ĵÊÄ¡£ÄãÇÕãl£¿¬FÚÔ 50.0441° N \end{document} Addendum: Instead of the using the nearly obsolete palatino package, you may want to consider loading the more recent newpxtext and newpxmath packages. ...


7

The form of the error message you show suggests an older latex release but for all releases the error comes from this or an older version with the same name. \def\UTFviii@defined#1{% \ifx#1\relax \PackageError{inputenc}{Unicode\space char\space\expandafter \UTFviii@splitcsname\string#1\relax ...



Top 50 recent answers are included