Tag Info

New answers tagged

0

Building on @PLK's answer, here is an example biber.conf that selectively removes URLs from specified entry types, rather than selectively keeps them. Note that entry types aren't case sensitive. <?xml version="1.0" encoding="UTF-8"?> <config> <sourcemap> <maps datatype="bibtex" map_overwrite="1"> <map> ...


1

According to this blog on the moderncv package there is a field called \homepage{} which will link to an internet page. This gives a link to the an internet page above the social link. In the MWE this can be added after the \social[]{} field ... \social[linkedin]{} \homepage{www.youtube.com} \usepackage{pdflatex, ...


3

You can use the user keys to store additional information. For example: \documentclass[12pt,BCOR=15mm]{scrbook} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[ngerman]{babel} \usepackage{hyperref} \usepackage[xindy,nonumberlist]{glossaries} \GlsSetXdyCodePage{duden-utf8} \makeglossaries \newglossaryentry{glossaries} { name=Glossaries, ...


1

This problem seems to come from the pdf reader that is used. Therefore my idea is to add something invisible that breaks up the url for the program but not for the person reading it. Something like \url{www.google}\rlap{~}{.com} does not work, though, because the space ~ is ignored. An ugly workaround that works for me (with Sumatra PDF) is: ...


7

It's your PDF viewer's fault: Mac OS X Preview (at least v7.0) recognises URLs and makes them clickable, whether they be typeset with a special package (hyperref, url) or not. To convince yourself, try compiling the following example and open the output in Preview; the URL will be clickable. So there's really nothing you can do about it on the author's ...


1

The solution in apacite: how to suppress url if doi is avalable? can be modified as follows (it requires the environ package). \usepackage{apacite} \usepackage{etoolbox} \usepackage{environ} \newtoggle{bibdoi} \newtoggle{biburl} \makeatletter \undef{\APACrefURL} \undef{\endAPACrefURL} \undef{\APACrefDOI} \undef{\endAPACrefDOI} ...


0

I tried this and the links were working in Preview but they weren't on Adobe Acrobat Pro. I removed the baseurl= http:// option under hypersetup onn the moderncv.cls file and it worked. I'm not sure why but it did. I don't know if its going to be the same with Okular but its worth a try.


1

On the moderncv.cls file I removed the baseurl= http:// option under hypersetup and it worked. I'm not sure why but it did.


5

The \url command can be redefined the same way as hyperref. The following example first defines url command \guilurl, which uses single guillemots as angle brackets. Then \url is redefined using \guilurl: \documentclass{article} \usepackage[T1]{fontenc}% \guilsinglleft and \guilsinglright \usepackage{lmodern} \usepackage{amstext} \usepackage{hyperref} ...


4

How about ps. I do not think it is a good idea to post such a long url in the document. Use a small name and use that for the link. But if this is what you want: \documentclass[10pt,letterpaper]{article} \usepackage{hyperref} \usepackage{longtable} ...



Top 50 recent answers are included