Tag Info

Hot answers tagged

6

Use the fancyvrb package: \documentclass{article} \usepackage{fancyvrb} \fvset{tabsize=4} \begin{document} I'm regular text \begin{Verbatim} I have no tab I have 1 tab I have 2 tabs I have no space I have 4 spaces I have 8 spaces \end{Verbatim} \end{document} The site is changing tabs to four spaces, so this might seem ...


3

You can redefine the way Verbatim works using \RecustomVerbatimEnvironment, adding the formatcom key to execute formatting commands at the start of the Verbatim environment. Since the environment scope limits the extent of what happens with the content of formatcom, there is no need to reset it at the end: \documentclass{article} ...


3

something like this might be a start Start the file \input texinfo @c -*-texinfo-*- @iftex @input texinfoextras @end iftex then compiling (e.g. for Info) with makeinfo --no-iftex texinfo.texi to hide the input command from this processor. For processing with texi2pdf, a sensible texinfoextras.tex could be @catcode`@\=0 \let\oldexample\example { ...


2

Wrong syntax, please check the documentation of package fancyvrb. The environment name starts with an uppercase letter V and the options are not inbetween, but follow \begin{Verbatim}. \begin{Verbatim}[samepage=true, gobble=4] sc <- read.table("~/pathToData/sc.data.txt", quote="\"", comment.char="") some more code and even more ...


2

You have some errors in your WME. I only correct them and use article and instead of tufte-handout (I havent instaled it in my MikTeX). Also I comment the babel for the same reason: \documentclass[twoside,symmetric]{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} %\usepackage[spanish,mexico]{babel} \usepackage{array} \begin{document} ...


2

As Mike Renfro points out in the comments, many text editors support converting between tabs and spaces; some will even make the change seamless and transparent by printing some number of blank spaces when you press the tab key. This is probably the easiest answer to your exact question. Another solution if you happen to be a Linux (maybe OSX) user would be ...


2

verbatim material cannot appear in the argument of another command, so the usual approach \only<1>{\begin{verbatim}...\end{verbatim}} won't work. The easiest solution is to use the onlyenv environment (thanks to daleif for his comment about this): \documentclass{beamer} \begin{document} \begin{frame}[fragile] \begin{onlyenv}<1> ...



Only top voted, non community-wiki answers of a minimum length are eligible