Tag Info

New answers tagged

2

Two options: Using some tabulars for each layer and the subcaption package: The code: \documentclass{article} \usepackage{subcaption} \usepackage{graphicx} \begin{document} \begin{figure} \begin{minipage}{\linewidth} \centering \begin{tabular}{ccc} \includegraphics[width=.28\linewidth,height=1cm]{example-image-a} & ...


0

You can have multiple rows, e.g. look at this example from ClassicThesis: begin{figure}[bth] \myfloatalign \subfloat[Asia personas duo.] {\includegraphics[width=.45\linewidth]{gfx/example_1}} \quad \subfloat[Pan ma signo.] {\label{fig:example-b}% \includegraphics[width=.45\linewidth]{gfx/example_2}} \\ \subfloat[Methodicamente o ...


0

With a \Centerstack of the stackengine package, you can just use a normal c column of tabular. In the MWE below, I additionally horizontally-align columns to the right, left, and center, using the optional argument of \Centerstack. \documentclass{article} \usepackage[usestackEOL]{stackengine} \setstackgap{L}{\normalbaselineskip} \begin{document} ...


0

You can use a m{width} column type from array package \documentclass{article} \usepackage{amsmath} \usepackage{array} \begin{document} \begin{tabular}{m{1cm}m{1cm}m{1cm}} \shortstack{1\\ 2\\3\\4} & \shortstack{1\\2} & \shortstack{1\\2\\3} \end{tabular} \end{document}


0

You can try with the optional argument for the subfigure environment, so images will be aligned by the top, bottom or centers. The possible values for the optional argument are b, t, or c. For example, with b: \begin{subfigure}[b]{.45\linewidth} \end{subfigure}\hill \begin{subfigure}[b]{.45\linewidth} \end{subfigure} A different alignment option can be ...


6

They are centred vertically. That is, they are centred on the current baseline. (See explanation below.) The problem is that the bottom of the tikzpicture is on the baseline by default. To centre that, we can use baseline in the argument for the picture: \documentclass[12pt,letterpaper]{article} \usepackage{array} \usepackage{tabularx} \usepackage{tikz} ...


1

Another possibilities is use split environment instead rcases and added curly brace after it: \documentclass{scrartcl} \usepackage{mathtools} \begin{document} \begin{align*} a+b &=0 \intertext{some text a} c+d &=0 \intertext{some text b} \begin{split} \lambda_a &= x\\ \lambda_b &= y \end{split}\;\bigg\} \quad \text{some text c} ...


0

This is one way to obtain the same formula structure and have the equal signs line up. \documentclass{scrartcl} \usepackage{amsmath} \begin{document} \begin{align*} & a+b =0 \text{ some text a } \\ & c+d =0 \text{ some text b } \\ & \hspace{1.5mm} \left. \begin{array}{l} \lambda_{a} = x \\ \lambda_{b} = y \end{array} \right\} \quad \text{ ...


0

Normally one would use multirow to overlap column 3 and the picture. Instead, I used \raisebox to \smash the picture and computed how much space would be needed at the end. The only fudge factor was the 1.6ex used to center the picture within the row. \documentclass[12pt,a4paper]{article} \usepackage{amsmath,amsfonts,amssymb,tikz} ...


2

To get aligned to line up with the first line remember the [t] option. Don't use \text for anything but textual comments in display math. This _\text{el} is not a textual comment. Better to use another construction. \documentclass[a4paper]{memoir} \usepackage{mathtools} \DeclareMathOperator\Tr{Tr} % for text only subscripts ...


5

Correct this behaviour manually by vertically skipping back to the same baseline: \documentclass[10pt]{article} \usepackage[margin=0.75in, left=1.5in]{geometry} % Section headers in margins % http://tex.stackexchange.com/a/1315/10906 \usepackage{titlesec} \titleformat{\section}[leftmargin] {\sffamily} {}{0pt}{} \titlespacing{\section} {4pc}{1.5ex ...


3

There's no need to issue \singlespacing, which is causing your vertical mis-alignment. Regardless, you can also use a tabular to stack content vertically within math mode: \documentclass{article} \setlength{\parindent}{0pt} \setlength{\parskip}{12pt plus 1pt minus 1pt} \usepackage{amsmath,array,setspace} \usepackage[margin=25mm]{geometry} % Margins ...


0

With tikz, simply change the vertical location of the signature image with yshift key \documentclass{article} \usepackage{graphicx} \usepackage{tikz} \begin{document} \begin{tikzpicture} \draw[thick](0,0)--(5,0)node[midway,yshift=1.2cm](c){\includegraphics[width=4cm]{example-image-a}}; \node[yshift=-3mm] at (c.south) {\textbf My Name}; \end{tikzpicture} ...


1

I am not sure if I got you right as you have not give so much information. But maybe you have been searching for the [b] parameter of the tabular environment. Like it stands now, it is too wide for the page, but as I do not know your documentclass and margin settings, I just leave it as it is. % arara: pdflatex \documentclass{article} ...


6

You can use the path operator |- in the paths: \draw[->] (model) -> (model|-solver.north); And also in the node positioning: \node[font=\bfseries] (solution) at (model|-simplification) {Solution}; Fixes: The alignment problem was due to the fact that Solution was much shorter in height than Simplification, because this last one has a "P" in it ...


0

You need to add the [t] positioning specifier not only to the minipage environments, but to both tabular environments as well. %% preamble stuff omitted \begin{longtable}{|A|B|} \fbox{ \begin{minipage}[t][6cm]{0.14\paperwidth} \begin{tabular}[t]{|p{0.12\paperwidth}|} % <--- "[t]" is new Left Table\\ left Table\\ ...


6

As this: \documentclass{article} \pagestyle{empty} \usepackage{pgfplots} \pgfplotsset{compat=1.12} \begin{document} \begin{tikzpicture}[scale=.9] % to suppress Overfull \hbox \begin{axis}[axis lines=none,samples=150,domain=-10*pi:10*pi,ymin=-.5, ymax=1.5] \addplot [mark=none]{sin(deg(x-pi))/(x-pi)}; \addplot ...


2

If I understand your posting correctly, there are three separate formatting issues in play: On pages that contain floats and text, the floats must be at top or bottom of the page. On floats-only pages, if there are two or more floats, they must be "centered" on the page, i.e., the spaces above, between, and below the floats must be equal; and if ...


0

\documentclass[10pt]{article} \usepackage{graphicx}% to include graphics \usepackage{subcaption} % this package aligns images \begin{document} \begin{figure} \begin{subfigure}[b]{\textwidth} % placement of image and width of box for image \centering \includegraphics{a.jpg} \caption{figure one} \end{subfigure} \\ % space can be added using \\[] ...


3

This is a well known (and documented; cf. section 9.5 of the beamer documentation) effect with overlays and I am afraid there's no general solution. Two possible solutions are to use \struts for the \items or to use an overprint or an overlayarea environment: \documentclass{beamer} \begin{document} \begin{frame} \begin{block}{The One} ...


4

The problem is that catchfilebetweentags ignores blank lines. If you remove the blank line in the “local” part, you get exactly the same. Solution: use \par in the auxiliary file instead of a blank line. \documentclass{article} \begin{document} %<*eq001> \begin{multicols}{2} \begin{equation} \label{equ:X} X = ...


1

This works perfect as long as your text doesn't get too long. \documentclass[tikz, border=6mm]{standalone} \begin{document} \begin{tikzpicture}[x=1mm, y=1mm] \coordinate[](0_r1) at (0,22.5); \coordinate[](0_r2) at (0,42); \coordinate[](0_r3) at (0,49); \coordinate[](b1_r2) at (14.4,42); \coordinate[](b1_r3) at (14.4,49); ...


2

This is a known issue, and it has been treated before1 but it could be a problem in the code for the fit library.2 However you can use the solution found in one of those questions and use the label instead. I also think it's easier if you create a new command for placing your nodes which reduces 3 lines of code for one node, to one line of code, using the ...


2

Try choosing the same anchor as the left group, then add an x-shift to compensate for this. Note that the unit of length for the shift should be chosen relative to the font size (em, ex, ...) and not fixed units (pt, in, mm, cm, ...). \documentclass[border=2mm]{standalone} \usepackage{tikz} \usepackage{tikz-timing} \usetikztiminglibrary{nicetabs} ...


1

This is the command I usually employ to cope with this situation: \newcommand*\cleantop{% \dimen@ \baselineskip \advance \dimen@ -\topskip \prevdepth \dimen@ } After this definition, I use \cleantop at the beggining of the floating environment, as I show in the following MWE: \documentclass{scrbook} \usepackage{lipsum} \usepackage{showframe} ...


5

I see nothing strange: \documentclass{scrbook} \usepackage[utf8x]{inputenc} \usepackage[T1]{fontenc} \usepackage[ngerman]{babel} \usepackage{graphicx,float} \usepackage{lipsum} \usepackage{fancyhdr} \pagestyle{fancy} % just to show the head sep \begin{document} \makebox[0pt][l]{\vrule height0pt depth0.2pt width 30cm}% \lipsum[3] \newpage ...


5

Three options: Using a tabular* of width equal to \textwidth and m{<length>} columns. Using the adjustbox package. Boxing one of the images to measure its height (this assumes all four images have the same height). In all three cases the labels are placed inside a \rotatebox. The code: \documentclass{article} ...


2

One option would be to use fixed height minipage's instead of column environments: The code: \documentclass[10pt,aspectratio=1610,t]{beamer} \usepackage{tikz} \begin{document} \begin{frame}\frametitle{Minimum Working Exaple} \begin{minipage}[t][.8\textheight][t]{.5\textwidth} This is the first column.\par ...


2

The first rule is indented with the standard paragraph indentation. Right click the line right next to the rule, select Paragraph settings, uncheck the box for Indent paragraph.


0

Ok, I took Bernhards answer as a started and created two possible solutions for future reference. I kept the second one with a longer heading, because all columns with rotated headings remain the same width. \documentclass{article} \usepackage{siunitx} % To align the numbers later on \usepackage{booktabs} ...


1

It is simple with makecellandt its \rotcell command, if you accept a two-lined column head. I took the opportunity to use siunitx for the last column. \documentclass{article} \usepackage{siunitx} % To align the numbers later on \usepackage{booktabs} \newcommand{\ra}[1]{\renewcommand{\arraystretch}{#1}} \usepackage{multirow, makecell} \usepackage{rotating} ...


1

I don't fully understand your first paragraph, but I suspect you might want to just switch the p and the m. \documentclass{article} \usepackage{array} \begin{document} \begin{tabular}{|>{\raggedright\arraybackslash}m{0.5in}|>{\raggedright\arraybackslash}p{0.5in}|} \hline abcde fghijk lmnopq & $\Bigg( x \Bigg)$ \\ \hline \end{tabular} ...


1

From data, which you provide, I only can suggest to ad option h to figure environment. If after line, to which follows figure is enough place, figure will stay there, otherwise it will move on top to next column/page. \begin{figure}[h]% <--- h as here, sometime help !h \centering \caption{Original Image} ...


2

The easiest way to me seems to be to load enumitem and define a new list: \usepackage{enumitem} \newlength\myitemwidth \setlength\myitemwidth{5em} % <<< choose what you need here \newlist{myacronymlist}{description}{1} \setlist[myacronymlist]{ labelindent = 0pt , labelsep = 0pt , leftmargin = \myitemwidth , labelwidth = \myitemwidth , ...


2

I introduce the leftitemize environment, that places its labels in a 2cm wide left-aligned box (in bold). The labels are aligned with the enclosing environment margin. \documentclass{article} \usepackage{enumitem} \let\svitem\item% \def\mybox#1{\makebox[2cm][l]{\bfseries#1}} \newenvironment{leftitemize} ...


1

You have to use the top align parameter [t] of the minipage environment here. % arara: lualatex % you may use pdflatex, just remove the package I've loaded \documentclass{article} \usepackage{lua-visual-debug} % just for demo \begin{document} \noindent % this was missing \begin{minipage}[t]{0.4\textwidth} By:\\ Student ...


2

Following the answer given by @LaRiFaRi, groupplots works for me (code at ShareLatex): \documentclass{standalone} \usepackage{pgfplots} \usetikzlibrary{pgfplots.groupplots} \pgfplotsset{compat=1.3} \begin{document} \begin{tikzpicture} \pgfplotsset{footnotesize,samples=10} \begin{groupplot}[group style = {group size = 3 by 1, horizontal sep = ...


1

I would use the package adjustbox here. Please note the option valign=t I added to each image: % arara: pdflatex \documentclass[headsepline]{scrreprt} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \PassOptionsToPackage{demo}{graphicx} % you can remove this. \usepackage[export]{adjustbox} \usepackage{tikz} \usetikzlibrary{positioning} ...


2

You can even have wider margins fiddling with the font size and the value of tabcolsep. I took the opportunity to simplify your code and improve the appearance of the table with siunitx and makecell: \documentclass[landscape, 12pt]{report} \usepackage[showframe, nomarginpar, top=0.8in, bottom=1.25in, left=1in, right=1in]{geometry} \usepackage{siunitx} ...


2

You can dispense with the minipages; it's enough to use a tabular with b (botoom) alignment in which the central column is of paragraph type p{<length>} (thus allowing text wrapping) and not to leave blank lines between the tabular and the legend: The code: \documentclass{beamer} \usepackage[english]{babel} \usepackage[utf8x]{inputenc} ...



Top 50 recent answers are included