305 reputation
17
bio website rrt.sc3d.org
location
age
visits member for 2 years, 3 months
seen Sep 1 at 13:27

Jul
2
awarded  Curious
Feb
13
awarded  Yearling
Aug
4
comment How can I modify a fontinst encoding (e.g. t1.etx)?
So far, I can find no way to do this. I have resorted instead to shipping patches to existing .etx files.
Aug
2
comment How can I modify a fontinst encoding (e.g. t1.etx)?
(Note: as I said before twice, and hence perhaps unclearly, sorry, the entries I am getting are not the last entry, but the combination of all entries; in my case, for "c" for example, the original ligatures and kerns for "c" plus my additional ligature.)
Aug
2
comment How can I modify a fontinst encoding (e.g. t1.etx)?
Reading more carefully, it seems that multislot.sty's \resetslot doesn't actually work (it retains kerns and ligatures), which means it's not going to help me. So maybe I do have to revert to a modified t1.etx.
Aug
2
comment How can I modify a fontinst encoding (e.g. t1.etx)?
Ah yes, of course I want to reset those slots, that is, 141 and 173, but without getting the "first entry only" behavior of \setslot that multislot.sty gives.
Aug
1
comment How can I modify a fontinst encoding (e.g. t1.etx)?
For example, in the above, I want to add a ligature for c and for s, while retaining all the existing ligatures and kerns.
Aug
1
comment How can I modify a fontinst encoding (e.g. t1.etx)?
Thanks. As far as I can tell, none of the possible multislot commands do what I want, as I want to have multiple \setslot...\endslot commands take effect (not just the first) and in the example quoted about changing l to lambda, the "buggy" behavior mentioned is exactly what I want to occur, i.e. retain the original kerns and ligatures. So maybe what I'm doing is right?
Aug
1
asked How can I modify a fontinst encoding (e.g. t1.etx)?
Jul
7
accepted How can I suppress a terminal ligature?
Jul
6
comment How can I suppress a terminal ligature?
foss\noboundary does the trick. @egreg, could you make that an answer so I can mark it as such? Thanks!
Jul
5
comment How can I suppress a terminal ligature?
Unfortunately, I can't use LuaTeX, owing to microtype features that it doesn't yet support (at least, not without upgrades I'm not yet prepared to make). I'll test the \noboundary command as soon as I can, which, if it works, is an entirely reasonable solution.
Jul
5
comment How can I suppress a terminal ligature?
Fixed @mafp, thanks & sorry.
Jul
5
asked How can I suppress a terminal ligature?
May
7
comment How to substitute one glyph sequence for another with OTF feature files in LuaTeX?
That is exactly what I said in my second sentence: as far as I can tell, multiple glyphs on the RHS are not allowed, hence the contorted code in my example.
May
6
asked How to substitute one glyph sequence for another with OTF feature files in LuaTeX?
Jan
14
comment How do I use glyphtounicode to make Caslon Pro ligatures searchable?
I can of course get the result I want by just using \setmainfont[Ligatures={Rare}] {Adobe Caslon Pro} and manually entering long s's in the source.
Jan
11
comment microtype settings for Adobe Caslon Pro?
Great, I look forward to that. As I said, I can't actually tell what most of the basic settings above are intended to do, because of missing context, and I explained why in each case.
Jan
11
comment microtype settings for Adobe Caslon Pro?
The activate option looks useful. Some things I don't understand about the above: first, you specify tracking=true, but then you don't use tracking. Next, you specify factor=1200, but you don't specify a font size, so it's hard to judge whether it's a good idea; ditto for stretch and shrink. I can't see a reason to pass "final" when there's no "draft" for it to override. I'm really after glyph-by-glyph adjustments for Caslon, as is supplied for some fonts in the package, e.g. Times.
Aug
6
comment Automatically adding space before punctuation in old-style English texts
Thanks @Mico, I have adapted the default French settings to make the spacing before each of ; : ! and ? the same, as that is what seems to be the case in the facsimile I'm working from (though there the extra space varies quite a bit).