153 reputation
6
bio website bioltfws1.york.ac.uk/~albl500
location York, United Kingdom
age 29
visits member for 2 years
seen yesterday

PhD student in Computational Biology,
University of York, UK.


Aug
30
awarded  Popular Question
Sep
27
comment How to set up spell-checking with vim?
Indeed, seems to be a bug in tex documents, as opposed to plaintex docs. In the MWE, set filetype=tex breaks spell-checking. In my actual thesis, set filetype=plaintex fixes it.
Sep
27
comment How to set up spell-checking with vim?
Seems to be a filetype detection problem.. I opened the two intro's side-by-side and noticed that the commands were highlighted in different colours. Where spell-checking doesn't work, set filetype returns tex, whereas when it does work, it detects plaintex.. Guess I'll have to add the filetype to the settings line..
Sep
27
comment How to set up spell-checking with vim?
It doesn't seem to be a problem with my .vimrc now, but the content of my actual introduction.tex. I just copied it over to the MWE - it doesn't work - so i'm cutting stuff out of it to see if I can the problem...
Sep
27
comment How to set up spell-checking with vim?
oww, well that fixed it for the MWE, but not my actual thesis intro.
Sep
27
comment How to set up spell-checking with vim?
As yours worked, I had a look in my ~/.vimrc, and I found the culprit: let g:tex_flavor = "latex". Removing that fixes it
Sep
27
comment How to set up spell-checking with vim?
The only highlighted words in intro.tex are in the vim settings line: spelllang and gb. If I use \chapter* and \section*, then it works as expected..
Sep
27
comment How to set up spell-checking with vim?
I'm just using the default colorscheme, but no difference with desert, or others...
Sep
27
asked How to set up spell-checking with vim?
Jul
24
awarded  Critic
Nov
5
awarded  Scholar
Nov
5
accepted Per-project texmf directory
Nov
5
comment Per-project texmf directory
Good point. The template I'm using came with a Makefile, which I haven't been using, but I can configure Kile (and MacTex I imagine) to just run make. Obviously I've got to add your changes to the Makefile, but that will do :)
Nov
5
comment Per-project texmf directory
Thanks for the explanation (+1)! I figure the LaTeX builder (e.g. Kile/MacTex) should allow configuration of the build environment. Kile, at least though, doesn't seem to have settings to configure the build commands' environment; only the commands' arguments. So to make this work (on KDE), I'd have to set TEXMFHOME in /etc/environment (or whichever file it is that configures the global KDE environment). Would you consider this a bug/limitation of Kile? Can I define TEXMFHOME in a project-specific config file or something?
Nov
4
awarded  Supporter
Nov
3
awarded  Student
Nov
3
asked Per-project texmf directory
Nov
3
awarded  Autobiographer