265 reputation
111
bio website
location
age
visits member for 3 years, 5 months
seen yesterday

Jul
19
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@giordano I've added a few of those lines in the question itself, but the change needs to be reviewed, as I don't have enough reputation to edit it myself.
Jul
18
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@giordano There is no auto/ subdirectory there; the class file is in a subdirectory of /usr/local/texlive/texmf-local/tex/latex/, where I don't have write permission as a regular user.
Jul
18
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@DavidCarlisle I see. No, there is no lisp version of the class that I can find.
Jul
18
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@DavidCarlisle yes, in ~/.emacs.d/elpa/auctex-11.87.5/style/babel.el I have babel.el (and babel.elc).
Jul
18
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@giordano, ah, sorry, I misinterpreted your question. I don't know anything about auto-generated style files. How do I check whether I have one or not?
Jul
18
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@DavidCarlisle, changing the \usepackage command to \@nameuse{RequirePackage}[french]{babel} didn't fix the problem either.
Jul
18
comment How can I avoid AUCTeX wrongly inferring the language of a document?
@giordano, this happens even when I run emacs -q, so it seems that my custom settings are not the problem.
Jul
18
comment Double-quote produces guillemets in emacs
@egreg Yes, but it's in a conditional branch in the class file - I guess AUCTeX doesn't see that?
Jul
18
comment Double-quote produces guillemets in emacs
@giordano Good suggestion, thank you. I've checked that now and I think it is indeed the problem. But now how can I fix it? (Question updated with more info.)
May
13
comment Double-quote produces guillemets in emacs
It has happened in english papers that are not using the babel package at all, and in french papers that are using it. The files do not contain any local variables. And, as I said, this happens even when I completely delete the contents of the file, so it seems like these things cannot be causing this behavior.
Apr
7
comment Emacs, RefTeX and Cleveref – can they work together?
This used to work for me, but since upgrading to Emacs 24.3 and auctex 11.87, it no longer works. Any suggestions?
Oct
21
comment RefTeX broken in Emacs 24.3.1?
Thank you! You were of course correct, that solution that I referenced no longer works, but the newer one that you link to does.
Mar
30
comment Proof titles with ntheorem
Beautiful, thank you!
Mar
27
comment Numbering theorems as subsubsections
So, I guess another question is: what numbering scheme do you think makes the most sense in a situation where one has sectioning units ranging from chapters to subsubsections?
Mar
27
comment Numbering theorems as subsubsections
Thank you for your answer. Could you please explain why you think this makes it harder to read? To me it seems simpler: now there is only one thing numbered 1.1.1.1, whereas before there could have been more.
Nov
28
comment elsarticle class not displaying email addresses
@cyberSingularity: that worked beautifully. Post as an answer and I'll accept it. And thanks!
Apr
4
comment How to change citation style in amsrefs?
Thanks! Much appreciated.