18 events
when toggle format what by license comment
Aug 4 '17 at 18:57 history edited Alexander Gelbukh CC BY-SA 3.0
edited title
Aug 4 '17 at 14:00 answer Alan Munn timeline score: 6
Aug 4 '17 at 13:54 comment added Johannes_B The answer would just copy the code from natbib. It was already done. of course one could argue that to avoid natbib, one could just as well copy tge relevant code from the more modern biblatex package.
Aug 4 '17 at 13:51 comment added Alexander Gelbukh Yes, \setcitestyle{numbers} solved the svjour3 problem, thank you! But even with this, I would be interested (for the future, or for other readers) to know the answer to the original question, if somebody wants to provide it.
Aug 4 '17 at 13:42 comment added Alan Munn You're solving the wrong problem here. Load the svjour3 class with the natbib option, add \setcitestyle{numbers,square} and \bibliographystyle{plainnat} to your preamble. Then use regular natbib commands. If that doesn't work, edit your question with a minimal example showing this and then perhaps we can solve the problem.
Aug 4 '17 at 13:26 comment added Alexander Gelbukh It works if I add \usepackage{natbib} and copy all its parameters from the class, but this is hacking, not an intended use of the class.
Aug 4 '17 at 13:21 comment added Alexander Gelbukh In my MWE, just changing \documentclass{article} for \documentclass[natbib]{svjour3} here produces this error. Maybe it's a problem of configuration of my computer, not sure.
Aug 4 '17 at 13:16 history edited Alexander Gelbukh CC BY-SA 3.0
added 808 characters in body
Aug 4 '17 at 13:12 comment added Alexander Gelbukh Yes, but in my case it gives an error Bibliography not compatible with author-year citations. I do not see how to give it an option [numbers]. (How to debug this would be another question.) But in any case, I thought there should be a trivial way to get rid of the brackets without more packages.
Aug 4 '17 at 13:08 comment added Michael Palmer Alan is right. The template that comes with that class has \DeclareOption{natbib}{\AtEndOfClass{\RequirePackage{natbib} - so you just start your document with \documentclass[natbib]{svjour3}. This loads the natbib package, and you should be all set.
Aug 4 '17 at 13:00 comment added Alan Munn The svjour3.cls has a natbib option, so it's definitely compatible with natbib. You're asking people to reinvent the wheel.
Aug 4 '17 at 12:51 comment added Bobyandbob A minimal working example with bibliography (MWEB), that illustrates your problem would help a lot.
Aug 4 '17 at 12:42 comment added Alexander Gelbukh I am not sure if it will not alter a given style. In addition, I cannot get it working with the particular style I have to use, svjour3.cls.
Aug 4 '17 at 12:42 comment added Johannes_B natbib was created to do what you want. Where is the problem?
Aug 4 '17 at 12:34 comment added Michael Palmer Why do you not want to use natbib? It is very widely used and accepted by publishers.
Aug 4 '17 at 12:26 history edited Alexander Gelbukh CC BY-SA 3.0
added 142 characters in body; edited tags
Aug 4 '17 at 12:26 history edited lockstep
edited tags; edited tags
Aug 4 '17 at 12:21 history asked Alexander Gelbukh CC BY-SA 3.0