4

So I have several external references like this one

@misc{epa_2013,
  author = {EPA},
  title = {National Pollutant Discharge Elimination System},
  url = "{\url{http://cfpub.epa.gov/npdes/}}",
  note = "Accessed: 2/6/2013",
}

And when I compile my document, I get question marks instead of a URL:

Rendered Bibtex

I have the following preamble:

\documentclass{tJDE2e}

\title{{\itshape International Journal of Digital Earth} \break Name of Paper}
\author{Our Authors}

\usepackage{graphicx} % support the \includegraphics command and options
\usepackage{color}
\usepackage{subfigure} 
\usepackage{placeins}


\usepackage{url}


%needed for correctly facing smart quotes
\usepackage [english]{babel}
\usepackage [autostyle, english = american]{csquotes}
\MakeOuterQuote{"}

\date{} 
\begin{document}

\maketitle
\begin{abstract}

And for the references section, I have this:

\bibliographystyle{tJDE}
\bibliography{reference}

I've tried removing the \url, I've tried changing the url package to hyperref...no matter what I do, I can't seem to get the URLs to render as actual URLs.

EDIT: here is the tJDE2e template for the Digital Earth journal

http://www.tandf.co.uk/journals/authors/tjdelatex.zip

5
  • Welcome to TeX.SX. Commented Feb 27, 2013 at 10:08
  • 1
    The tjDE2e class and the tJDE bibliography style aren't available on CTAN, so please provide a link.
    – lockstep
    Commented Feb 27, 2013 at 10:11
  • Sorry about that. I added the link to the journal's template/style guide at the end.
    – djsumdog
    Commented Feb 27, 2013 at 10:18
  • The question marks stem from missing years, and your bibliography style seems to insist on them, even in misc entries.
    – mafp
    Commented Feb 27, 2013 at 10:27
  • Hmm. So I tried adding years. That gets rid of one set of question marks (and the ones in the citations in the paper as well), but the URL still doesn't display in the bibliography. I still get ??? at the end.
    – djsumdog
    Commented Feb 27, 2013 at 11:05

1 Answer 1

6

The bibliography style you use, tJDE, does not recognize url fields in bibliography entries. Use the note field for that. The question marks stem from missing year fields that the style enforces even for misc entries (violating the standard). The question marks at the end stem from missing accessed fields that are required for misc entries (violating the standard). Since you have that information, move it there:

@misc{epa_2013,
  author = {EPA},
  title = {National Pollutant Discharge Elimination System},
  year = 2013,
  note = "\url{http://cfpub.epa.gov/npdes/}",
  accessed = "accessed 2/6/2013",
}

should work.

3
  • This won't work with the new sigplan/sigconf acmart.cls style. Commented May 16, 2017 at 20:50
  • @mafp If year is not available in citation, then it returns ????. Is there any way possible to get rid of question marks for non-available fields. Commented Feb 21, 2018 at 10:16
  • @rudreshdwivedi did you figure out how to work in case of citations without year? Commented Feb 27, 2020 at 9:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .