I want to use XeLaTeX as typesetting engine and Biber for my references. I want to have a 1-click-compilation setup, preferably in a GUI editor. I work on Windows, thus a solution for TeXworks or TeXnicCenter would be great.

For TeXnicCenter, I wonder how to tweak the existing setting to use XeLaTeX and Biber: enter image description here

Also, for TeXworks, I have no idea how to set it up properly: enter image description here

I would love to know how to set up the two editors in Windows. However, please feel free to add solutions also for other editors.

  • 2
    Have a look at arara, which might give you a nice solution independent of the editor (given you can configure arara in the IDE). It is part of TeX Live 2012 if update the installation regularly. – Uwe Ziegenhagen Feb 28 '13 at 13:33
  • Well, unfortunately, I could not find any hints on how to install arara on Windows. I wrote a new question for that: tex.stackexchange.com/q/100318/16868 – mcbetz Feb 28 '13 at 13:44
  • I just answered that question. – Uwe Ziegenhagen Feb 28 '13 at 14:00
  • Regarding the texify dialog in texworks: Last time I looked into the texify + biber question (october 2010) I had to set an environment variable and write some fake \bibstyle and \bibdata command to the aux-file to coax texify to call biber. See this discussion miktex.10937.n7.nabble.com/…. – Ulrike Fischer Feb 28 '13 at 14:30
  • textify was more of an intermediate solution. I would love to focus more on the arara solution, but could not get a working MWE yet (see answer below). – mcbetz Feb 28 '13 at 14:31

Actually, arara can be called from TeXworks as well as from TeXnicCenter. To get a XeTeX + Biber workflow, you should have the following setup:

Your mwe.tex, save as UTF-8:

% arara: xelatex
% arara: biber
% arara: xelatex


Test \autocite[100]{test2013}.


Your mwe.bib:

    title = {Arara Primer},
    author = {Pufahl, Mario},
    year = {2013},

And in the settings, enter the following:


enter image description here


enter image description here

  • Actually, this only works THEORETICALLY, as I get errors when trying to run the MWE in both IDEs. Both IDEs give me an error: No mwe.aux file! LaTeX Error: The font size command \normalsize is not defined: there is probably something wrong with the class file. – mcbetz Feb 28 '13 at 14:28
  • it's missing \documentclass{} etc. – percusse Feb 28 '13 at 14:33
  • Ay, of course. I was too focused on a minimal solution to skip the import parts.. – mcbetz Feb 28 '13 at 14:36
  • Unfortunately, it is still not running. It outputs: Run biber on mwe.bib again and rereun XeLaTeX – mcbetz Feb 28 '13 at 14:47
  • 1
    When you have % !TEX TS-program = xelatex, it tells TeXworks to run xelatex as main program instead of arara. – Paulo Cereda Feb 28 '13 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.