16

In Lyx, by default most paragraphs are indented (except at beginning of section and after lists). How can I cancel the indentation for specific paragraphs?

3
  • 1
    On a case-by-case basis, you could insert an ERT with \noindent at the start of the paragraph.
    – Werner
    Mar 4, 2013 at 18:51
  • 1
    You can, but you should ask yourself why you'd want to do it, to begin with. I see no reason whatsoever for not indenting the start of a new paragraph (except after titles). You can indent the text after a list, just leave an empty line. If LyX doesn't allow it, it's another reason why not using it.
    – egreg
    Mar 4, 2013 at 18:51
  • 3
    To have a consistent appearance of your document, you could change the indentation for the whole document under "Document > Settings > Text Layout" or use vertical skips instead...
    – e-birk
    Mar 4, 2013 at 18:56

2 Answers 2

17

Right click in the paragraph, click Paragraph Settings, uncheck Indent Paragraph in the lower left corner of the dialog box. (This does the same as Werner's comment, \noindent is added to the LaTeX source, but you do not need the ERT.)

enter image description here

5

In my case, I didn't want the identation for texts coming right after an equation. I was following the approach suggested by Torbjørn T., but it was kinda cumbersome in my case, since I had a lot of equations, and I didn't find any keyboard shortcuts for doing it.

However, I've just noticed that if you continue to write right after the equation (without pressing the Enter key) the line will continue as if it were part of the same paragraph, which was exactly what I was looking for.

3
  • 1
    Good point! This is actually the correct method in that context, as it avoids starting a new paragraph altogether. Mar 16, 2017 at 17:52
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Mar 16, 2017 at 18:06
  • Is there a means of defaulting all paragraphs to be non-indented?
    – paul frith
    Oct 13, 2023 at 16:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .