8

I like to work with the tex on one half of the screen and the pdf on the other.

How do I hide the console window (with transcription log, error report, etc) unless there is an error? And how can I keep the focus on the tex window?

That way, I command-T to see my pdf, but keep typing.

4

Currently I use macOS Mojave, v. 10.14. As addressed by @layman, the currently accepted answer no longer works (at least it did not work for me). The workaround I've used is the following:

  • Open TexShop and compile your source.
  • Take the console and place it in a non-bothersome position (this can be on a new desktop, your current desktop, etc... (I have yet to test if this works in a new window))
  • Go to TexShop, Preferences, Console, and then select the option "All consoles start at a fixed position". This will allow you to let the console run, but do it in a fixed position away from where you are.
  • After having done the above, click the "Set with current position" button. This will let your current non-obstructive placement of the console become the default placement.
  • On the same page, select the "when error occurs" option. This stops TexShop from moving to the location of the console when there is not an error.

Each time you close TexShop (or the console that you've set the position of), the current position of the console that you set will be forgotten. Simply place the console in the non-obstructive location again, and click the "Set with current position" button again under the console tab to reset this.

5

You can find options for those in the preferences:

  • TeXShop, Preferences, choose tab "Console" and set "Show Console" to "when error occurs" (default is "always")
  • TeXShop, Preferences, choose tab "Typesetting" and set "After Typesetting" to "continue editing" (default is "bring preview forward")
  • Is it possible to ignore warnings? – Sibbs Gambling Oct 26 '14 at 2:52
  • Neither of these work anymore on MacOS High Sierra (10.13) in full screen split mode. I'm beyond annoyed that the console sits permanently in front of the PDF. – layman May 16 '18 at 22:55
-2

I also encountered the bug on MacOS High Sierra (10.13) in full screen split mode. It might help to drag the console window away as a separate window outside. And then switch to the full window in TexShop. When you click 'Typeset', the console shows the result like in backend, and you will not get bothered by the console window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.