33

In texmaker, though I have configured the dictionary, i cannot still check the spelling, any idea??

enter image description here

12
  • 1
    I use Texmaker as well. I sometimes tried the check spelling option. But for me it didn't work either.
    – Dave
    Commented Mar 10, 2013 at 16:29
  • 2
    Depending on the Version of Texmaker you’re using (the current is 4.0), you might have to restart after switching the dictionary. If that doesn’t help, could you specify what the expected behavior is versus the behavior you’re getting?
    – doncherry
    Commented Mar 10, 2013 at 18:47
  • 2
    i did it but getting the same error
    – Noor
    Commented Mar 10, 2013 at 20:53
  • @Noor Which error? (Don’t forget to @username other users when responding to their comments.)
    – doncherry
    Commented Mar 11, 2013 at 3:15
  • 1
    @texenthusiast, my configuration is correct: /usr/share/myspell/dicts/hyph_en_GB.dic and the inline option is checked. It doesn't work.
    – juliohm
    Commented Sep 24, 2013 at 9:14

12 Answers 12

36

I had the same problem but the .dic files that I used didn't work.

Texmaker Error : Can’t open the dictionary

To solve this error you need to install the spell-checker

  • Use: sudo apt-get install myspell-de-de myspell-en-us or use sudo apt-get install myspell-*

on 4/8/23 Michael edited I had to install hunspell sudo apt-get install hunspell-en-gb then i restarted TexMaker and under options->configure TexMaker I choose editor and under spelling dictionary I entered /usr/share/hunspell/en_GB.dic and now I can spell check on Ubuntu 20.04 LTS!!


  • Then find the dictionary: locate *.aff

There were two directories that contained dictionary files in my computer; /usr/share/hunspell/ and /usr/share/myspell/. Only one of the "myspell" dictionaries worked, while all the "hunspell" dictionaries worked (so far) .

Probably the .dic file from "myspell" doesn’t work without a corresponding .aff file...

  • Chose the .aff file that you want and enter its path into texmaker at options --> configure texmaker --> editor --> spelling dictionary then click ok.

  • Right click on your "code" and click on check spelling to make sure it's working.

5
  • 1
    This worked great for me. Thanks! It appears the default TexMaker folder for dictionaries is just wrong.
    – Dr_Zaszuś
    Commented May 9, 2017 at 14:48
  • 3
    This worked for me. I used sudo apt-get install myspell-de-de myspell-en-gb and then I redirected TexMaker to /usr/share/hunspell/ Commented Sep 22, 2017 at 16:29
  • 2
    This did not work for me (Ubuntu 18.04.2, Gnome 3.28.2). Dictionaries are installed in /usr/share/hunspell/dicts/, Texmaker is pointed to the .dic file in that directory. Restarted Texmaker. Still get the error "can't open dictionary". Commented Apr 13, 2019 at 14:02
  • 1
    Cannot edit my comment, so adding another: the solution was to use the file icon in Texmaker to open the File manager and point to the .dic file, instead of typing in the path to the .dic file. Commented Apr 13, 2019 at 14:11
  • For recent Ubuntu it seems myspell is not maintained anymore. Hunspell works well on 20.04.
    – Arnaud
    Commented Oct 27, 2020 at 13:31
17

/usr/share/hyphen are not the right directory for spelling dictionaries. The spelling dictionaries are in the /usr/share/myspell directory and spell dictionaries are in fact always composed of 2 files: the .dic (which must be selected) and the .aff file.

0
10

Inside /usr/share/myspell/dicts you should have links to both the .dic AND the .aff file of the language (e.g. en_US or en_GB).

/usr/share/myspell/dicts$ ls -og |  grep /en_US
lrwxrwxrwx 1 24 Jan 30 11:21 en_US.aff -> ../../hunspell/en_US.aff
lrwxrwxrwx 1 24 Nov  3 13:03 en_US.dic -> ../../hunspell/en_US.dic

Then from configuration, make TexMaker "Spelling dictionary" point to the .dic file:

/usr/share/myspell/dicts/en_US.dic

This is the description/explanation from MySpell Wikipedia entry:

The spell checking is done using the .aff file for the locale together with the .dic file. The .dic file is a list of words along with a group of letters which refer to the affixes found in the .aff file. This saves space because instead of having include all forms of a word, like jump (jumping, jumps, jumped), the .dic file will include the word once and the references to the affixes in the .aff file allow the construction of all the other forms.

If you don't have an .aff file, you can get one the en_US .dic/.aff for Hunspell from wordlist.sourceforge.net.

9

I had the same problem and in my case I had to give a new path /usr/share/hunspell/en_US.dic to the dictionary since /usr/share/hyphen/hyph_en_GB.dic was non existent (on my ubuntu 14.04).

2
  • Worked for me on Ubuntu 14.04. Thanks!! :)
    – dksahuji
    Commented Dec 23, 2015 at 11:31
  • Didn't work for Ubuntu 10.04 Commented Aug 8, 2018 at 20:54
4

I am using Texmaker 4.1 on Ubuntu 14.04, and faced a similar problem; turns out that myspell-en-gb was not installed. Simple fix: sudo apt-get install myspell-en-gb and make sure the dictionary path is correctly set as /usr/share/myspell/dicts/en_GB.dic in Texmaker's configuration window.

2

To configure the spell checker: "Configure Texmaker" -> "Editor" -> "Spelling dictionary" -> click on the button at the end of the line to select the dictionary with the file browser. From the list pick the required dictionary; for my case US-dic.

2

I had a similar problem, solved it by using a different .dic file.

You can get it from here.

Home -> speller -> [yyyy.mm.dd] -> hunspell(...).zip

source

2

With Ubuntu 16.04, the spell check was not working for me. The config referred to a non-existent file.

Using locate *.aff I found en_US.aff in /usr/share/hunspell, fixed the config to this file and spell check is now working.

I am using TeXLive installed using this. See also here.

2

I solved the problem just writing in the terminal $locate *.aff and then change my directory in texmaker for the new one.

2

(this should be a comment but i dont have reputation enough)

In my case, in /usr/share/hunspell/ I have several files which are only symbolic links and some of then which are the actual files. The only one that work are the ones which are not symbolic links.

2

I got this issue in Texmaker in my Ubuntu 16.04

There's just following simple steps to get rid of this.

1) Click options in the menu bar of your Texmaker window, and select Configure Texmaker

2) Click Editor in the leftmost column

3) Check whether the spelling dictionary bar ends with en_GB.dic or anything else other than en_US.dic (maybe Texmaker doesn't have in-built en_GB.dic installed - at least this was the case with me)

5) Install the .dic and .aff using sudo apt-get install myspell-de-de myspell-en-gb

6) The .dic file will normally be installed at /usr/share/hunspell/en_GB.dic. Or else you could just locate it.

7) Give /usr/share/hunspell/en_GB.dic to the spelling directory in the configure Texmaker and you're good to go.

1

I had the same issue and I fixed it using the following approach:

Download an up-to-date spelling dictionary and make sure it includes the ".aff" file. You can get one from wordlist.sourceforge.net. Unzip, put it wherever you want, and then go to preferences->editor in texmaker and point to where you have your ".dic" file.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .