11

I'm using \minipage to put two tables side by side. But when the two tables are not of equal length, the shorter of the two is vertically centered with respect to the other. I would like both tables to be aligned horizontally at the top (i.e. so that I could draw an imaginary straight flat line from (1) through (2)).

\documentclass{article}
\usepackage{gb4e}
\begin{document}
    \begin{table}[h]
        \begin{minipage}{0.5\linewidth}
            \begin{exe}
                \ex
                    \begin{tabular}[t]{l l}
                        ich & `I'\\
                        du & `you'\\
                        er & `he'\\
                    \end{tabular}
            \end{exe}
        \end{minipage}
        \begin{minipage}{0.5\linewidth}
            \begin{exe}
                \ex
                    \begin{tabular}[t]{l l}
                        Schiff & `ship'\\
                        Haus & `house'\\
                        Mund & `mouth'\\
                        Auto & `car'\\
                        Buch & `book'\\
                        Stuhl & `chair'\\
                    \end{tabular}
            \end{exe}
        \end{minipage}
    \end{table}
\end{document}

enter image description here

1
  • 4
    Use [t] as option for the minipage environment.
    – user10274
    Commented Mar 10, 2013 at 18:11

1 Answer 1

11

As Marc van Dongen says in a comment, add [t] as an option to both minipage environments:

\documentclass{article}
\usepackage{gb4e}
\begin{document}
    \begin{table}[h]
        \begin{minipage}[t]{0.5\linewidth}
            \begin{exe}
                \ex
                    \begin{tabular}[t]{l l}
                        ich & `I'\\
                        du & `you'\\
                        er & `he'\\
                    \end{tabular}
            \end{exe}
        \end{minipage}
        \begin{minipage}[t]{0.5\linewidth}
            \begin{exe}
                \ex
                    \begin{tabular}[t]{l l}
                        Schiff & `ship'\\
                        Haus & `house'\\
                        Mund & `mouth'\\
                        Auto & `car'\\
                        Buch & `book'\\
                        Stuhl & `chair'\\
                    \end{tabular}
            \end{exe}
        \end{minipage}
    \end{table}
\end{document}

enter image description here

1
  • 1
    Please don't add [h] to all tables. You usually don't need them and they make LaTeX layout harder.
    – vy32
    Commented Aug 21, 2017 at 12:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .