1

I tried finding the solution on line, and could not find any suitable answer to my question.

My aim is to make a nomenclature. In order to do this, I need to perform the operation makeindex filename.nlo -s nomencl.ist -o filename.nls. However, I seem to only get rejections. (0 entries accepted, 2 rejected).

I'm having trouble interpreting the log file, so here it is.

This is makeindex, version 2.15 [MiKTeX 2.9 64-bit] (kpathsea + Thai support).
Scanning style file C:/Program Files/MiKTeX 2.9/makeindex/nomencl/nomencl.ist.......
** Input style error (file = C:/Program Files/MiKTeX 2.9/makeindex/nomencl/nomencl.ist, line = 70):
   -- Unknown specifier lethead_prefix.
** Input style error (file = C:/Program Files/MiKTeX 2.9/makeindex/nomencl/nomencl.ist, line = 71):
   -- Unknown specifier lethead_suffix.
** Input style error (file = C:/Program Files/MiKTeX 2.9/makeindex/nomencl/nomencl.ist, line = 72):
   -- Unknown specifier lethead_flag.
...done (10 attributes redefined, 3 ignored).
Scanning input file Slutrapport.nlo...
!! Input index error (file = Slutrapport.nlo, line = 1):
   -- Illegal page number -100.
!! Input index error (file = Slutrapport.nlo, line = 2):
   -- Illegal page number -100.
done (0 entries accepted, 2 rejected).
Nothing written in Slutrapport.nls.
Transcript written in Slutrapport.ilg.

Am I missing something fundamental or why is it rejecting?

  • 2
    Welcome to TeX.sx! – Corentin Mar 11 '13 at 15:52
  • 3
    Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – mafp Mar 11 '13 at 15:55
1

Perhaps you've included the whole nomenclature into a separated file and you're calling it to the main file with the command \input{filename.tex}.

I had the same problem with the nomenclature rejection but I read something has to be written before the nomenclature into the nlo file in order to generate an output. I just placed the nomenclature inputs after using an equation and the problem was solved.

Perhaps it's not your case, but if it is give it a try.

| improve this answer | |
0

I encoutered the same problem today while using TexStudio. After repeatedly generating the empty .nls file due to rejections. The solution was to mark the glossary section within TexStudio.

Tool Section TexStudio

A single click at Glossary and Index fixed the issue after using

makeindex filename.nlo -s nomencl.ist -o filename.nls

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.